Répondre à la discussion
Affichage des résultats 1 à 20 sur 20

Problème de filtrage



  1. #1
    Maxime86

    Problème de filtrage


    ------

    Bonjour,

    Nous sommes en train de fabriquer une lampe de plongée qui peut varier d'intensité sous l'eau.
    Notre lampe est alimenté en 110V DC par une génératrice, et nous faisons varier l'intensité des lampes par un MOSFET et nous gérons le rapport cyclique avec un microcontrôleur (fréquence de 2kHz).

    Notre problème est que lors du changement d'intensité des lampes il y a des apparitions de bruit sur notre alimentation DC et ce bruit parasite les images de notre caméra.

    Nous avons essayé un filtre passe-bas passif (fc=100Hz) placé juste après notre alimentation mais cela ne change rien, ni même une capacité placé en parallèle de l'alimentation.

    Merci aux futurs répondants.

    -----

  2. Publicité
  3. 📣 Nouveau projet éditorial de Futura
    🔥🧠 Le Mag Futura est lancé, découvrez notre 1er magazine papier

    Une belle revue de plus de 200 pages et 4 dossiers scientifiques pour tout comprendre à la science qui fera le futur. Nous avons besoin de vous 🙏 pour nous aider à le lancer...

    👉 Je découvre le projet

    Quatre questions à explorer en 2022 :
    → Quels mystères nous cache encore la Lune 🌙 ?
    → Pourra-t-on bientôt tout guérir grâce aux gènes 👩‍⚕️?
    → Comment nourrir le monde sans le détruire 🌍 ?
    → L’intelligence artificielle peut-elle devenir vraiment intelligente 🤖 ?
  4. #2
    PIXEL

    Re : Problème de Filtrage

    hello ,

    vous venez de découvrir l'épineux probléme de la CEM

    votre alim rayonne trop d'harmoniques HF, et chatouille les circuits proches de la cam.

    c'est pas un simple condo qui va régler le probléme , c'est toute la conception du circuit qui est à revoir pour minimiser les émissions parasites.

    de nombreux cours trainent sur la toile.

  5. #3
    f6bes

    Re : Problème de Filtrage

    Citation Envoyé par Maxime86 Voir le message
    Bonjour,

    Nous sommes en train de fabriquer une lampe de plongée qui peut varier d'intensité sous l'eau.
    Notre lampe est alimenté en 110V DC par une génératrice, et nous faisons varier l'intensité des lampes par un MOSFET et nous gérons le rapport cyclique avec un microcontrôleur (fréquence de 2kHz).

    Notre problème est que lors du changement d'intensité des lampes il y a des apparitions de bruit sur notre alimentation DC et ce bruit parasite les images de notre caméra.

    Nous avons essayé un filtre passe-bas passif (fc=100Hz) placé juste après notre alimentation mais cela ne change rien, ni même une capacité placé en parallèle de l'alimentation.

    Merci aux futurs répondants.
    Bjr à toi,
    C'est pas un filtre passe bas qu'il faudrait, mais j'aurais plus confiance en un filtre "sélectif" (qui ne garantira pas forcément un bon résultat suivant comment tout cela est agençé).

    A+
    Vide pour l'instant

  6. #4
    bobflux

    Re : Problème de Filtrage

    Il faut un shéma complet de la lampe, des photos de la réalisation (layout des circuits imprimés, trajets des fils), et beaucoup plus de détails ...

  7. A voir en vidéo sur Futura
  8. #5
    gienas
    Modérateur

    Re : Problème de filtrage

    Bonjour Maxime86 et tout le groupe

    Bienvenue sur le forum.

    Je confirme les propos de mes prédécesseurs, mais je tique sur ce "détail":

    Citation Envoyé par Maxime86 Voir le message
    ... Notre problème est que lors du changement d'intensité des lampes il y a des apparitions de bruit sur notre alimentation DC et ce bruit parasite les images de notre caméra ...
    Ce qui laisse sous entendre qu'il n'y a pas de problème en régime stable. Ce devrait être encourageant.

    Il faut en effet savoir comment cela fonctionne, et comprendre pourquoi seulement en "dynamique" ce défaut apparaît. Serait-ce un potentiomètre qui "crache"?

  9. #6
    Maxime86

    Re : Problème de filtrage

    Bonjour,

    Merci pour vos réponses.

    Notre générateur est en DC et lorsque le transistor est juste saturé la source reste stable à 100V sans déformation.
    Lorsque l'on applique le signal carré (0-12V 2kHz)sur la gachette notre DC deviens déformé. (apparition d'harmoniques 1 3 5 du signal 2k)

    Nous avions donc pensé à un filtre passe-bas pour atténuer au maximum toutes les fréquences (filtre passif RC 1er ordre avec fréquence de coupure à 100Hz ce qui atténue de 20dB à 1kHz). Cela a eu pour résultat de rendre notre DC oscillant.
    Nous pensons à un filtre passe-bas LC passif pour atténuer encore plus(atténuation 40dB à 1kHz).

    Pour les tests: nous avons une source de 110V, 5 lampes de 100W pour simuler la lampe de 500W, un transistor IRF630N et un générateur de fréquence.

    Voici le schéma grossier de nos tests:

    Image supprimée.

    Voici ce qu'on relève avec l'analyseur de spectre: (réglage: -30dBm, span 10kHz et repère 2kHz/V).

    Image supprimée.



    Pour être conforme à l'épinglé

    http://forums.futura-sciences.com/el...ointes-pj.html

    Le lien vers l'image a été supprimé.

    Les PJ doivent être sur le serveur.

    Merci de la replacer.


    .
    Dernière modification par gienas ; 18/12/2010 à 20h48. Motif: supprimé les liens vers les serveurs tiers

  10. Publicité
  11. #7
    Short

    Re : Problème de filtrage

    Plutôt directement tenter un sélectif avec le bon coef d'amortissement.
    UTC- Génie Mécanique

  12. #8
    DAUDET78

    Re : Problème de Filtrage

    Citation Envoyé par bobfuck Voir le message
    Il faut un shéma complet de la lampe, des photos de la réalisation (layout des circuits imprimés, trajets des fils), et beaucoup plus de détails ...
    Maxime86
    Tu peux répondre ?
    J'aime pas le Grec

  13. #9
    Maxime86

    Re : Problème de filtrage

    Voici plus d'explication:

    Notre projet est actuellement en test donc nous n'avons pas créé de layout, nous faisons nos test actuellement sur des breadboards.
    Voici les photos que nous avons pris durant nos tests.
    Je n'ai pas accès présentement à Orcad je posterai dès que j'y aurai à nouveau accès.
    Images attachées Images attachées

  14. #10
    DAUDET78

    Re : Problème de filtrage

    Et tu t'étonnes d'avoir un émetteur radio avec ce montage, sans filtre LC et avec des fils volants ?

    Dans ton application finale, ta lampe est dans un container métallique étanche? Le NMOS est près de la lampe? Tu as un filtre LC en entrée de la boiboite ?

    Rien a voir avec ta manip actuelle.
    J'aime pas le Grec

  15. #11
    Maxime86

    Re : Problème de filtrage

    Oui notre carte sera dans un caisson étanche de dimension 2.2*3.3 pouces.
    Notre lampe sera placé sur le casque du plongeur (donc loin du MosFET).
    Pour le filtre nous avons seulement essayé un RC, nous testons le LC lundi. Le filtre sera normalement placé à l'entré de notre caisson.

  16. #12
    DAUDET78

    Re : Problème de filtrage

    Citation Envoyé par Maxime86 Voir le message
    Notre lampe sera placé sur le casque du plongeur (donc loin du MosFET).
    Ca, ce n'est pas la bonne approche.... Le NMOS doit être près de la lampe et il y a un filtre LC en entrée du caisson sur le 100V. On envoie à la lampe du 100V DC "propre" et le signal de grille du NMOS
    J'aime pas le Grec

  17. Publicité
  18. #13
    bobflux

    Re : Problème de filtrage

    Bref, avec tous ces fils et cette conception c'est normal que ça parasite tout ce qui passe à côté...

    http://sketchtag.com/KRbxUR2s14

    Ce petit schéma résume toute la chose. Il faut minimiser l'aire des boucles parcourues par des courants qui changent rapidement, donc le MOSFET doit être à côté des ampoules.

    L,C1 : empêche les parasites de sortir. L est une ferrite style VK200, C quelques microfarads si ton alim a de la patate, sinon beaucoup plus.

    R1 C2 : snubber qui absorbe les parasites lorsque le MOSFET se coupe.

    Tout ceci sur une petite carte de 2x2 cm à côté de la lampe.

    Sinon, tu mentionnes une génératrice, c'est un groupe électrogène ? Si oui, ces machins peuvent avoir un temps de réaction assez long à un changement de charge, pendant ce temps la tension peut errer un peu... la solution la plus simple serait de limiter la vitesse de variation de l'intensité lumineuse...

  19. #14
    Maxime86

    Re : Problème de filtrage

    Pour daudet78
    Rectification, notre Mosfet sera proche de la lampe.

    Pour bobfuck
    Merci pour le schéma du montage nous allons essayer cette solution

  20. #15
    f6bes

    Re : Problème de filtrage

    [QUOTE=Maxime86;3323602]Oui notre carte sera dans un caisson étanche de dimension 2.2*3.3 pouces.

    Bjr à toi,
    500w dans ce volume ??
    Je me poserais des questions !!
    Refroidisseur qq part ??

    A+
    Vide pour l'instant

  21. #16
    bobflux

    Re : Problème de filtrage

    Citation Envoyé par f6bes Voir le message
    500w dans ce volume ??
    Je me poserais des questions !!
    c'est juste le MOSFET, 500W sous 110V c'est ~ 5A donc avec un MOSFET dimensionné pour, il chauffera très peu (une liaison thermique au boîtier est conseillée certes, mais il faut faire extrêmement attention à l'isolation quand on est un peu mouillé ...)

  22. #17
    DAUDET78

    Re : Problème de filtrage

    Citation Envoyé par bobfuck Voir le message
    il chauffera très peu
    Ce n'est pas le NMOS qui inquiète F6bes ...... mais la lampe qui dissipe 500W thermique dans un doigt de gant !
    J'aime pas le Grec

  23. #18
    gienas
    Modérateur

    Re : Problème de filtrage

    Bonjour à tous

    Citation Envoyé par DAUDET78 Voir le message
    Ce n'est pas le NMOS qui inquiète F6bes ...... mais la lampe qui dissipe 500W thermique dans un doigt de gant !
    Si j'ai bien compris, ce ne devrait pas être un problème. On dispose d'un refroidissement par eau.

    Et puis, en plongée, comme il faut garder la tête froide, la lampe sur le casque, devrait rester au frais.

  24. Publicité
  25. #19
    f6bes

    Re : Problème de filtrage

    Citation Envoyé par gienas Voir le message
    Bonjour à tous

    Si j'ai bien compris, ce ne devrait pas être un problème. On dispose d'un refroidissement par eau.

    Et puis, en plongée, comme il faut garder la tête froide, la lampe sur le casque, devrait rester au frais.
    Bjr à toi,
    Oui, mais entre la lampe et l'eau je suppose que le contact n'est pas dés plus ...intime !!
    C'est pas un "vapotron" !
    http://dspt.perso.sfr.fr/Vapotron01.gif (refroidissement par eau)
    A+
    Vide pour l'instant

  26. #20
    Maxime86

    Re : Problème de filtrage

    Bonjour,

    Pas de problème pour le refroidissement, on va coller le refroidisseur sur le caisson (en aluminium) et la lampe sera utilisé pour aller jusqu’à 300pieds (91mètre) et une température de 4°C dans l'eau (Québec).
    Preuve en image !!!
    Nous on aura un caisson avec une lampe halogène 500W.
    Images attachées Images attachées  

Discussions similaires

  1. Problème filtrage sélectif
    Par E-Fab dans le forum Électronique
    Réponses: 4
    Dernier message: 25/05/2010, 14h46
  2. Probleme de filtrage avec Matlab
    Par pietro225 dans le forum Électronique
    Réponses: 2
    Dernier message: 16/05/2009, 18h32
  3. Filtrage
    Par Vickthor dans le forum Physique
    Réponses: 2
    Dernier message: 14/12/2008, 14h07
  4. Problème Electronique Complexes et Filtrage.
    Par L'Etudiant dans le forum Électronique
    Réponses: 59
    Dernier message: 16/01/2006, 18h23
  5. problème de filtrage
    Par superbat dans le forum Électronique
    Réponses: 7
    Dernier message: 27/09/2004, 21h22
Découvrez nos comparatifs produits sur l'informatique et les technologies.