Répondre à la discussion
Affichage des résultats 1 à 18 sur 18

Petite question sur ci



  1. #1
    superbat

    Petite question sur ci


    ------

    Bonjour,

    J'ai un multiplexer à implémenter et je ne sais pas à quoi correspond Vss et à quoi ça sert ???

    Voici le scema interne :

    http://pdf.alldatasheet.com/datashee.../ADG406BN.html

    Merci

    -----

  2. Publicité
  3. #2
    Jack
    Modérateur

    Re : Petite question sur ci

    bonjour,

    Vss est la "masse" de la partie logique alors que gnd est la "masse" analogique.

    A+

  4. #3
    superbat

    Re : Petite question sur ci

    Merci pour la réponse, zut ... j ai connecté Vss à 5 v, tension d'alimentation, ça peut détruire le CI ?

  5. #4
    Jack
    Modérateur

    Re : Petite question sur ci

    je ne pense pas, mais il faudra vérifier le bon fonctionnement de ton circuit.

    A+

  6. A voir en vidéo sur Futura
  7. #5
    gienas
    Modérateur

    Re : Petite question sur ci

    Bonjour superbat et tout le groupe

    Petite objection. Vss est la source de tension négative, symétrique ou non de Vdd, puisque le circuit est capable de "gérer" des signaux analogiques positifs et négatifs.

    La masse, oui peut-être, mais pas avec des signaux alternatifs, ou bidirectionnels.

  8. #6
    Jack
    Modérateur

    Re : Petite question sur ci

    Exact gienas, Vss peut être négative.

    A+

  9. Publicité
  10. #7
    superbat

    Bon, ça fonctionne pas...

    Vous devez avoir rason, tout dépend du référenciel mais entretemps mon multiplexer ne fonctionne pas, j 'ai du faire une erreur...

    Voici les connections :

    Allimentation entre 5v et 0v

    Vdd : 5v
    Vss : 0v
    En : 5v avec une intensité de 1 mA
    Gnd : 0v

    Les entrée A0 ... A3 sont attaquées avec du 5v et une intensité de 1mA (résistances de 4,7 K pour protéger)

    Voilà, merci de votre aide... je vois pas où je me suis trompé

  11. #8
    superbat

    Là c est bizarre ...

    C est curieux, car lorsque je séléctionne s1, en sortie j 'ai 0,4 v, c est bon.
    Mais si je sélectionne s2, j'ai 5v en sortie, là je comprends pas.
    s4, s6, s8 sélectionnés, toujours du 5v ???

    Je vois plus trop le rôle du mulitplexeur.

  12. #9
    gienas
    Modérateur

    Re : Petite question sur ci

    Je ne suis pas sûr du tout que ton multiplexeur soit bien monté ou bien alimenté. Je ne saisis pas ce que tu trouves "bon"

    Le principe est d'établir une seule liaison suivant le codage présent sur les entrées logiques A0 à A3. Il faut en effet EN à l'état haut, 5V par exemple.
    A0 à A3 reçoivent le codage 0000 (0) à 1111 (15)

    Pour chaque code de 0 à 15, un seul des interrupteurs est fermé entre D et S0 à S15. Il faut intercaler ces interrupteurs dans un circuit qui exploite la fermeture de tous ces interrupteurs, chacun à son code.

  13. #10
    Jack
    Modérateur

    Re : Petite question sur ci

    superbat,

    il me semble que tu n'as pas donné le signal analogique que tu appliques, ni sur quelle patte tu l'appliques.

    Alors je ne comprends pas comment tu peux justifier que le fait de mesurer 0,4V te semble normal.

    A+

  14. #11
    superbat

    Recapitulatif

    Oui j'ai compris le rôle du multiplexer, voilà ce que je veux : si je mets du 2,5 v sur s3 par exemple et que je choisi s3 en mettant a0 et a1 à 5v je veut obtenir du 2,5v en sortie D.

    Exemple de test sur mon montage :

    s1 ... 16 ne sont connectés à rien du tout. Je choisi s2 comme entrée. pour celà a0 = 0v, a1 = 5v, a2 = 0v, a3 = 0v.

    Là j 'ai la surprise de trouver 5v sur D.

    Bref je trouve très bizzare d'avoir 5v sur D à chaque fois que je choisis une entrée analogique paire.

    Alors les connexions sont les suivantes :

    Vdd : 5v
    Vss : 0v
    En : 5v avec une résistance de 4,7 k.

    a0, a2, a3 : 0v

    a1 : 5v avec une résistance de 4,7 k.

    Gnd : 0v

    J'obtient la sortie D = 5v snnifff
    et s2 = 5v.

    Si je connecte s2 à la masse D = 4v.

    Bref j'ai du me gourrer quelque part ... si quelqu un voit où c est je lui serai très reconnaissant.

    Merci

  15. #12
    superbat

    Re : Petite question sur ci

    up (en attendant une reponse)

  16. Publicité
  17. #13
    gienas
    Modérateur

    Re : Petite question sur ci

    Bonsoir superbat et tout le groupe

    Surprise ce UP!

    Nous n'avons aucune chance de te donner la réponse que tu es le seul à pouvoir trouver.

    1- ton circuit a peut-être souffert. En as-tu essayé d'autres?
    2-tu n'es pas sûr de ton montage. Comment le serait-on, nous?
    3-as tu vérifié l'ensemble de ton schéma, que même nous ignorons. Ta description est plus que légère.

    Tu dois commencer par établir un montage proche de celui proposé par le constructeur. Tu dois présenter des niveaux logiques manuels ou automatiques (un compteur par exemple).
    Tu dois présenter des niveaux analogiques si possible différents pour "détecter" ce qui passe.
    Tu dois faire des mesures correctes, et les interpréter.

    Si après cela cela coince encore (ce dont je doute), donne nous des détails précis, peut-être pourrons nous y réfléchir..

  18. #14
    superbat

    Re : Petite question sur ci

    Alors pour repondre a tes questions :

    1- oui j'en ai essayé d autres, ça fait la meme chose
    2- Je me base uniquement sur le schema du constructeur
    3- Il n'y a pas d'ensemble de schema puisque dans un premier temps je teste seul le circuit intégré avec l'allimentation.

    Pour plus de précisions, je commande les entrees logiques de sélection A0, A1, A2, et A3 à partir du port parralèle de l'ordi. J'ai placé une résistance en série à chaque entree logique au cas ou d'une résistance de 4,7 k.

    Bref, en me contentant d'allimenter le multiplexer et en me contentant de sélectionner le chanel Sx désiré à partir de A0, A1, A2, et A3 j'obitent en sortie D, 5V si x est pair et 0,4 V si x est impair. Alors que je croyais que D = Sx. (NB : les Sx ne sont connectés nul part)

    (En) reçoit 5v par l intermédiaire d une résistance de 4,7 k.

    Il n'y a rien d'autre sur le montage, à part le régulateur de tension.

    Désolé de me répéter c'est juste pour conserver le sujet de mon problème pour ceux qui n'ont pas lu plus haut.

    http://pdf.alldatasheet.com/datashee.../ADG406BN.html

  19. #15
    romelec

    Re : Petite question sur ci

    bonsoir,

    "les Sx ne sont connectés nul part"
    à mon avis c'est pas forcément bon: que veux-tu mesurer avec une entrée en l'air?

    connectes ces entrées à qqchose déjà...

    tu as bien connecté la masse du port// à la masse du montage?

  20. #16
    gienas
    Modérateur

    Re : Petite question sur ci

    Bonjour à tous

    Tout à fait d'accord avec romelec

    J'ai vérifié la datasheet pour le 5V monosource. C'est permis

    Prévois quand même un découplage alim au pied du circuit, qui est parfois "nerveux".

    Contrôler, à l'oscilloscope la "propreté" des signaux de commande, ainsi que celle de la sortie.

    Ne pas laisser d'entrée (ni sortie analogique) en l'air. Mettre une résistance de 10 à 100k.

    Eviter les résistances en série avec les entrées logiques. Le circuit est certes compatible TTL, avec très faible courant d'entrée, mais ce n'est pas "prudent" de les laisser.

    Plutôt que de générer des niveaux par le port parallèle, à ce stade, il serait plus opportun de mettre des switches sur les entrées logiques, et de présenter les niveaux depuis la plaque d'essai seule.

    Il n'est pas impossible que les signaux ne soient pas continus mais pleins d'oscillations dues à des accrochages. Il est nécessaire de vérifier à l'oscilloscope.

  21. #17
    superbat

    Re : Petite question sur ci

    (Oui la masse du port parralele est connectée à la masse du montage)

    Bon, ok, je vais dans un premier temps connecter tous les Sx à la masse pour suivre le conseil de Roelec.

    Ensuite si ça marche pas je vais connecter les entrées logiques directement au montage comme a dit Gienas.

    A tout de suite

  22. #18
    superbat

    Re : Petite question sur ci

    C est bon, j ai trouvé,

    Si les Sx pairs étaient à 5v c 'était logique car j'avais un court-circuit entre A0 et la sortie.

    Voilà, merci de votre aide

  23. Publicité

Discussions similaires

  1. Petite question sur un dl
    Par dudivine dans le forum Mathématiques du supérieur
    Réponses: 9
    Dernier message: 03/03/2007, 23h23
  2. petite question sur conductimétrie
    Par trater dans le forum Chimie
    Réponses: 1
    Dernier message: 12/12/2006, 23h31
  3. Petite question sur l'accélération
    Par skyskiper dans le forum Physique
    Réponses: 3
    Dernier message: 26/02/2006, 10h57
  4. Petite question sur l'hélium
    Par Hawkboy dans le forum Chimie
    Réponses: 7
    Dernier message: 23/12/2005, 22h38
  5. Petite Question sur Photorésistance
    Par Tartopommes dans le forum Électronique
    Réponses: 8
    Dernier message: 03/06/2003, 01h46
Découvrez nos comparatifs produits sur l'informatique et les technologies.