Répondre à la discussion
Affichage des résultats 1 à 1 sur 1

Projet de robot guidé par US



  1. #1
    grdboy

    Projet de robot guidé par US


    ------

    Tout d'abord bonjour à tous,

    Je suis en train de réaliser un projet qui a pour but de créer un robot qui évite les obstacle grâce leur détection par ultrasons. J'ai un niveau scolaire "Terminale S" et je suis plutôt novice en électronique.

    Voici mon projet plus en détail :

    Un circuit Émetteur sera chargé de générer un signal carré alternatif autour de 0V de fréquence 40kHz et d'amplitude 4.5V.
    Le transducteur émettra ce signal et d'éventuelles réflexions seront captées par deux récepteurs Gauche Droite.
    Le signal récupéré sera amplifié, redressé et filtré pour obtenir une tension continue. Cette tension viendra se soustraire à celle de la pile alimentant le moteur opposé.

    CircuitÉmetteur ==> Émetteur
    RécepteurG ==> CircuitRécepteurG ==> Moteur Droit
    RécepteurD ==> CircuitRécepteurD ==> Moteur Gauche

    Ainsi si un obstacle s'approche du récepteur droit par exemple le moteur gauche ralentira provocant ainsi une rotation du robot.

    Je me base pour ce projet sur des schémas de télémètres ou radars de recul récupérés sur Internet et j'utilise PSPice Student.

    Montage de l'émetteur :
    Un signal carré est produit grâce à un NE555 puis ce signal est rendu alternatif grâce à deux portes NAND connectées comme sur le schéma.

    Montage du récepteur :
    Je crée d'abord une masse virtuelle à 4.5V pour pouvoir alimenter les AOP. J'utilise des LM324 pour les deux AOP suiveurs et un LT082 comme amplificateur. Le signal récupéré du transducteur est supposé sinusoïdale (lu ça je ne sais plus où mais corrigez moi si je me trompe ...) et est donc modélisé par un générateur sinusoïdale dont je fais varier l'amplitude entre 50mV et 400mV selon si "ça capte fort ou pas". Après amplification, redressement et filtrage je place un AOP en suiveur pour adapter l'impédance.

    Seulement mon montage fonctionne pour une résistance du moteur R1=1k et donc le courant est 1000 fois plus petit que la tension. Or pour utiliser ce moteur : http://www.selectronic.fr/article.as...tier=11.1807-2
    Il me faut, pour 6V 66mA soit une résistance du moteur d'environ 100 Ohm.
    (De plus j'arrive aux limites de la démo de PSpice m'interdisant tout nouveaux composants, même une résistance de plus)

    Ma question : Dois-je utiliser un transistor pour amplifier le courant à ce niveau ou y a t-il plus simple ?

    Et pour ceux qui sont arrivés jusque là, s'il y a quelque chose qui cloche dans mes schémas ou mon projet n'hésitez pas à me dire ; )
    Merci d'avance.

    PS:La diode après le TL082 peut sembler "à l'envers" mais c'est fait exprès, je récupère l'alternance négative car il y a écrêtage pour des valeurs "fortes" (par exemple pour une amplitude venant du récepteur de 400mV)

    PSS : en PJ
    - Le montage émetteur
    - Le montage récepteur
    - La tension au borne de R1 (Moteur) pour une amplitude initiale de 100mV
    - L'intensité dans les même conditions
    - L'écrêtage pour une amplitude initiale de 400mV

    -----
    Images attachées Images attachées

Discussions similaires

  1. Commande robot filo-guidé
    Par Parisien09 dans le forum TPE / TIPE et autres travaux
    Réponses: 13
    Dernier message: 11/01/2011, 13h55
  2. Projet Robot Picky
    Par yaros dans le forum Électronique
    Réponses: 16
    Dernier message: 19/11/2010, 16h45
  3. Projet Robot E=M6
    Par Widleau dans le forum Technologies
    Réponses: 33
    Dernier message: 19/07/2010, 09h06
  4. [projet] robot sumo
    Par olivier_elec dans le forum Électronique
    Réponses: 11
    Dernier message: 19/01/2010, 23h01
  5. Projet Mû robot primitif
    Par -Tupac- dans le forum Électronique
    Réponses: 12
    Dernier message: 16/11/2007, 16h56
Découvrez nos comparatifs produits sur l'informatique et les technologies.