Répondre à la discussion
Affichage des résultats 1 à 10 sur 10

ATmega 64a



  1. #1
    Heartz

    ATmega 64a


    ------

    Bonjour,


    J'ai une télécommande de modélisme qui ne marchait plus et vu que ça sentait le cramé du coté de l'ATmega j'ai donc décidé d'en recommander un et d'en ressouder un.
    Une fois le pic ressouder et programmer, aucun soucis. Et quand j'allume ma télécommande l'écran de s'allume pas et aucune réaction de la télécommande :/

    Je voulais savoir si certain d'entre vous savaient si il y a différents type D' atmega 64a avec des sorties pas au même endroits ou je en sais pas ... Mais la je n'ai pas trouver de solutions à part ce forum

    Merci d'avance pour ceux qui m'ont lu et qui essayerons de m'aider !

    -----

  2. Publicité
  3. #2
    Franck-026

    Re : ATmega 64a

    euh, tu avais le programme d'origine???

  4. #3
    PA5CAL

    Re : ATmega 64a

    Bonjour

    Un détail de vocabulaire : un ATmega n'est pas un PIC. Le premier est un microcontrôleur d'Atmel à architecture AVR, et le second un microcontrôleur de Microchips à architecture de type Harvard.

    À ma connaissance, il existe plusieurs ATmega64 avec des différences mineures, mais il n'y a pas de différences entre les ATmega64A.


    Il faut que tu t'assures que :
    - le reste du circuit n'est pas en panne (parce que si ça a «cramé» il y a forcément une raison, et parce que le µC n'a peut-être pas été la seule victime) ;
    - le µC a été correctement soudé (s'il a été monté ainsi), sans pont ni faux contact ;
    - le µC a bien été programmé, avec le bon programme.
    Dernière modification par PA5CAL ; 30/06/2012 à 12h15.

  5. #4
    Heartz

    Re : ATmega 64a

    Non je n'avais pas le programme d'origine mais une version "custom" du firmware d'origine qui est bien mieux.

    Désoler pascal pour la faute j'ai été trop vite dans mon message j'ai trop l'habitude de posez des questions sur les pic que je me suis trompé

    Pour le reste du circuit qui serait en panne, avant la télécommande s'allumait mais n'envoyait pas de signaux donc j'ai pensé que ça pouvait être des entrées/sorties de l'atmega qui étais "cramé" même si je ne sais absolument pas comment ça a pu se produire

    pour le soudage pas de problème, en revanche pour enlever l'autre pic j'ai un peu abimer le pcb j'ai du remplacer certaine piste par des fils

    pour la prog,aucun problème ...


    Merci pour vos réponses !

  6. Comparatifs

    Gagnez du temps et de l'argent grâce à nos comparatifs de produits. Parmi nos sujets :
  7. #5
    Franck-026

    Re : ATmega 64a

    et on redit: un atmega ca n'est pas un PIC mais un µC (bis repetitae)

    Es tu sur que ton soft "custom" fonctionne reellement?

  8. A voir en vidéo sur Futura
  9. #6
    ftorama

    Re : ATmega 64a

    C'est cool, j'ai plus rien à faire (les habitués comprendront).

    Evidemment comme dit par les autres, ça serait bien de s'assurer que le firmware fonctionne effectivement. Ensuite, vu que tu as saccagé les pistes, il va falloir tout bipper pour vérifier que toutes les pattes sont bien reliées à leur piste respective et qu'il n'y a pas de court-circuit entre voisines.

    Enfin, il y a toujours l'hypothèse tout à fait plausible que l'Atmega ne soit pour rien dans la panne de la radiocommande et là, retour à la case départ avec un circuit abîmé qui plus est.

    Sinon, elle est à combien la radio neuve?
    Quand un homme a faim, mieux vaut lui aprendre à pecher que de lui donner un poisson.

  10. Publicité
  11. #7
    PA5CAL

    Re : ATmega 64a

    Citation Envoyé par Heartz Voir le message
    ...pour enlever l'autre pic...
    Grrrr !!!

  12. #8
    Heartz

    Re : ATmega 64a

    faut vraiment que je pense à me relire ^^'

    le firmware custom marche très bien c'est celui qui avait avant et il a toujours marcher

    Je ne comprends vraiment pas comment ça se fait :/

  13. #9
    PA5CAL

    Re : ATmega 64a

    Et le reste du circuit fonctionne bien ? Il n'y a pas de panne ?

  14. #10
    Heartz

    Re : ATmega 64a

    Avant que je n’enlève l'atmega la radio s'allumait bien je pouvais naviguer dans les menus etc mais le recepteur ne recevait rien

    Du coup il y avait pour moi deux solutions à ce probleme :

    Le module Hf de la télécommande et le µcontroleur

    sachant que je n’avais pas d'oscillo pour tester j'ai pris le moins chère, le µC à 3€ au moins je me suis pas ruiner ...

    Mais bon si il n'y a pas d’explication "magique" c'est que je me suis planté quand j'ai virer l'ancien µC :/ me reste plus qu'a prier pour que mon atmega reste en vie pendant le déssoudage :/

Discussions similaires

  1. atmega 8
    Par fopic dans le forum Électronique
    Réponses: 7
    Dernier message: 14/12/2011, 08h51
  2. ATmega
    Par gcortex dans le forum Électronique
    Réponses: 36
    Dernier message: 22/05/2011, 08h58
  3. programmation ATmega
    Par gcortex dans le forum Électronique
    Réponses: 2
    Dernier message: 24/05/2010, 09h37
  4. ATméga 16
    Par spray_kim dans le forum Électronique
    Réponses: 21
    Dernier message: 13/04/2010, 19h56
  5. atmega 8
    Par lampard123 dans le forum Électronique
    Réponses: 1
    Dernier message: 11/02/2008, 11h04
Découvrez nos comparatifs produits sur l'informatique et les technologies.