Répondre à la discussion
Page 1 sur 2 1 DernièreDernière
Affichage des résultats 1 à 30 sur 42

Alimentation



  1. #1
    Janosch

    Alimentation


    ------

    Bonjour!

    J'ai récemment réalisé un accordéon Midi (surtout grâce à vous, merci ), et j'ai quelques "trucs" que j'aimerais améliorer :
    Il y'a des résistances qui chauffent beaucoup, ça m'inquiète, et ensuite j'aimerais bien me lancer dans le multiplexage.
    Pour les résistances qui chauffent: je met le shéma de mon circuit en pièces jointes:
    Alim 37 Optos.gif

    Pour les fourches otpiques c'est celles là: http://www.gotronic.fr/pj-365.pdf

    Les résistances ne noircicent pas mais elles chauffent bien quand même.
    Y'a une erreur dans le circuit, où bien c'est normal qu'elles chauffent?
    J'attends vos réponses, ensuite on reparlera du multiplexage .

    -----

  2. Publicité
  3. #2
    Janosch

    Re : Alimentation

    J'ai oublié de préciser que j'utilisais un adaptateur secteur qui fait 12V, 2A pour alimenter tout ça.
    Je sais que 2A c'est plus que suffisant, mias j'ai que ça sous la main.

  4. #3
    f6bes

    Re : Alimentation

    Citation Envoyé par Janosch Voir le message
    J'ai oublié de préciser que j'utilisais un adaptateur secteur qui fait 12V, 2A pour alimenter tout ça.
    Je sais que 2A c'est plus que suffisant, mias j'ai que ça sous la main.
    Bjr à toi,
    Qui peut le plus peut le moins.Donc c'est PAS les POSSIBILITES de ton adaptateur qui créent probléme.
    Ton "accordéon" ne consomme QUE ce qui doit consommer.....pas plus.
    En attendant la validation, Bon AM.

  5. #4
    Janosch

    Re : Alimentation

    Qui peut le plus peut le moins.Donc c'est PAS les POSSIBILITES de ton adaptateur qui créent probléme.
    Ton "accordéon" ne consomme QUE ce qui doit consommer.....pas plus.
    En attendant la validation, Bon AM.
    J'ai pas tout saisi... Tu me confirmes que le problème ne vient pas de l'alim?
    De toute façon j'avais plutôt des doutes sur le choix de mes résistances, et peut être est-ce normal qu'elles chauffent?
    Merci en tout cas d'avoir répondu

  6. #5
    Janosch

    Re : Alimentation

    Personne ?

  7. A voir en vidéo sur Futura
  8. #6
    f6bes

    Re : Alimentation

    Citation Envoyé par Janosch Voir le message
    J'ai pas tout saisi... Tu me confirmes que le problème ne vient pas de l'alim?
    De toute façon j'avais plutôt des doutes sur le choix de mes résistances, et peut être est-ce normal qu'elles chauffent?
    Merci en tout cas d'avoir répondu
    Bjr à toi,
    C'est PAS parce que ton alim PEUT débiter 2 A qu'elle les débite si ton montage n'en demande pas autant.

    C'est PAS parce que ton compteur électrique peut débiter 45 A que ta cafetiére consomme 45 A !
    Ta cafetiére ne consomme QUE ce qu'elle à besoin.
    Pour ton alim ..c'est pareil.

    Quelle es la PUISSANCE d etes résistances ?
    Quelle est la consommation par "branches" ?
    Tes R chauffent elles de maniére anormale ( à s'y bruler )?
    A+
    Dernière modification par f6bes ; 24/07/2012 à 07h58.

  9. Publicité
  10. #7
    DAUDET78

    Re : Alimentation

    En gros, tu as environ 20mA par chaine de LED
    En gros, tu dissipes, dans la 270, une puissance de 6V*0,02=0,125W . Pour des 1/4W, c'est tout a fait raisonnable

    Si je me souviens bien, en son temps, je t'avais proposé le multiplexage que tu avais refusé.
    Dernière modification par DAUDET78 ; 24/07/2012 à 08h26.
    J'aime pas le Grec

  11. #8
    Janosch

    Re : Alimentation

    En gros, tu dissipes, dans la 270, une puissance de 6V*0,02=0,125W
    Pourquoi 6V?

    Si je me souviens bien, en son temps, je t'avais proposé le multiplexage que tu avais refusé.
    C'est exact, mais à l'époque je pensais que je pourrais éviter, puisque j'avais assez d'entrées sur mon arduino,
    mais aujourd'hui en voulant faire évoluer mon projet, je vois bien que j'aurais dû t'écouter.

  12. #9
    DAUDET78

    Re : Alimentation

    Citation Envoyé par Janosch Voir le message
    Pourquoi 6V?
    Au pif, c'est la chute de tension dans la 270 ohm ......
    Mais tu es plus à même de faire la mesure exacte !
    J'aime pas le Grec

  13. #10
    Janosch

    Re : Alimentation

    Je crois que j'ai trouvé: effectivement j'avais pas pensé mesurer la tension...
    Résultat: Mon alim ne délivre que du 10.9V (jpense pas que ce soit très grave si? vaut mieux que je mette des R de 220 au lieu des 270?)
    Les branches avec les R270 sont bien à 6V (bon pif!)
    La branche R390 est à 3.65V,
    et la branche R330 est à 10,9V !!! Kézako?

  14. #11
    dr4gon993

    Re : Alimentation

    alors If =20mA oui
    VF = 1.2V C'est écrit dans la doc page 3 en haut !

    donc du sfh9310

    http://pdf1.alldatasheet.com/datashe...C/SFH9310.html

    tu as 4 diodes par ligne on se place dans le cas le plus défavorable donc 1.2v par diodes.


    Uvr=12-(1.2*4)= 12- 4.8 = 7.2V

    P=U*I Uvr=7.2V I= "20mA" r=????

    Alors dimensionnement de la résistance Uvr=R*I donc U/I =R = 360ohms

    P=u*I= 7.2*0.02= 0.144w une résistance 1/4 de watt suffit.

    Toi avec 270ohm pour 7.2v tu as 0.026 soit 26mA ....

    le fait que ça chauffe c'est pas grave .... c'est normal si ça chauffe dans les limites prévu à la résistance que tu as mis, pour dissipé, après faut bien que tu faces t'es dimensionnement.

  15. #12
    DAUDET78

    Re : Alimentation

    Tu mesures entre quoi et quoi ?
    Pour calculer la puissance dissipée dans la résistance, il faut mesurer aux bornes de la résistance !
    J'aime pas le Grec

  16. Publicité
  17. #13
    Janosch

    Re : Alimentation

    Toi avec 270ohm pour 7.2v tu as 0.026 soit 26mA ....
    J'ai 5 diodes par ligne!
    du coup c'est pas du 7.2V mais du 6V.

    Mais ce qui m'intéresse ducoup c'est pourquoi j'ai du 10.9V sur la branche des 4 diodes. J'ai vérifié, pas de faux contacts sur le circuit...
    Ca peut griller une résistance?

  18. #14
    Janosch

    Re : Alimentation

    Oups, nan c'est pas ça que j'ai mesuré...

    Au bornes des 270 j'ai 4.9V.
    R390 j'ai 7.3V.
    et R330 j'ai 0V.

  19. #15
    DAUDET78

    Re : Alimentation

    Donc tu as 18,1mA dans les LEDs alimentées par les 270
    Donc tu as 18,7mA dans les LEDs alimentées par les 390
    Donc tu as 0,0000mA dans les LEDs alimentées par les 330 ....... y a un os !
    J'aime pas le Grec

  20. #16
    Janosch

    Re : Alimentation

    Donc tu as 18,1mA dans les LEDs alimentées par les 270
    Donc tu as 18,7mA dans les LEDs alimentées par les 390
    Vaut mieux un peu trop ou pas assez? en gros est ce que je devrais baisser la valeur de mes résistances?(prendre des 220 au lieu de 270)?

    Donc tu as 0,0000mA dans les LEDs alimentées par les 330 ....... y a un os !
    J'avoue... je chercherais quand j'aurais plus de temps...

  21. #17
    DAUDET78

    Re : Alimentation

    C'est bon le 18 mA ...... si ton phototransistor détecte bien le passage
    J'aime pas le Grec

  22. #18
    Janosch

    Re : Alimentation

    Donc tu as 18,1mA dans les LEDs alimentées par les 270
    Peux tu m'expliquer le calcul que tu as fait?

    si ton phototransistor détecte bien le passage
    oui.

  23. Publicité
  24. #19
    dr4gon993

    Re : Alimentation

    test la continuité entre toute les photo diode histoire de savoir si il ya a un pb de continuité puis test toute les diode une a une si une a carmé et ouvert la ligne sa sera la première de la ligne en général

  25. #20
    DAUDET78

    Re : Alimentation

    Citation Envoyé par Janosch Voir le message
    Peux tu m'expliquer le calcul que tu as fait?
    Non ......
    Car si tu n'es pas foutu d'appliquer la loi d'ohm ..... je ne le ferais pas à ta place !
    J'aime pas le Grec

  26. #21
    ald

    Re : Alimentation

    Citation Envoyé par DAUDET78 Voir le message
    Non ......
    Car si tu n'es pas foutu d'appliquer la loi d'ohm ..... je ne le ferais pas à ta place !
    Ça y est, il revient juste de vacances et il va se fâcher tout rouge. Ca va faire encore du bruit.

    Cordialement

    ald

  27. #22
    Janosch

    Re : Alimentation

    Car si tu n'es pas foutu d'appliquer la loi d'ohm ..... je ne le ferais pas à ta place !
    ok ok!

    test la continuité entre toute les photo diode histoire de savoir si il ya a un pb de continuité puis test toute les diode une a une si une a carmé et ouvert la ligne sa sera la première de la ligne en général
    Ce qui concerne les 0v aux pattes de la R330, je finirais bien par trouver, ne vous inquiétez pas pour ça.

    Bon... MULTIPLEXAGE!
    J'ai à peu près cerné le principe, mais il y'a des zones d'ombre... (beaucoup d'ombre)
    je met un shéma en PJ, vous aves le droit de rigoler!

    Opto Multi.jpg

  28. #23
    Janosch

    Re : Alimentation

    Je vous demande pas de faire tout le travail, mais donnez moi au moins des pistes...
    quelles pattes faut il connecter sur la grille?
    faut-il multiplexer uniquement les transistors optiques ou faut-il multiplexer les diodes aussi?
    Est ce que c'est judicieux de faire une grille 6x7?
    Dois je rajouter d'autres compsants (j'ai vu d'autres multiplexage avec des transistors ou des 1N4148 il me semble)?

    Je sais que je suis une chèvre en électronique, mais il faut un début à tout...

  29. #24
    DAUDET78

    Re : Alimentation

    Une grille de 5x8 c'est mieux ..... Les µC adorent les trucs par 8 !
    Tu alimentes en pulsé les LEDs d' une ligne de 8 photocoupleurs
    Tu viens lire les 8 phototransistors

    Il faut un transistor de commande par ligne de 8 LED (donc 5 transistors)
    J'aime pas le Grec

  30. Publicité
  31. #25
    Janosch

    Re : Alimentation

    Merci pour ta réponse, ça m'aide beaucoup déjà!

    Je vais réaliser un petit shéma, mais là je bosse(jsuis pas chez moi), je posterai ça ce soir.

  32. #26
    Janosch

    Re : Alimentation

    J'essaye de réaliser mon circuit là, et j'ai, ducoup, plusieurs question:

    1: De multiplexer tout ça veut dire que mon Arduino va tout alimenter (certes en pulsé)? et ducoup je met une résistance par Led?
    2: Dois je rajouter des résistances pull-up sur les phototransistors?
    3: Du côté Led, quelle patte doit se retrouver sur la "grille" du multiplexage? (je sais pas si c'est clair).

  33. #27
    DAUDET78

    Re : Alimentation

    Tu disposes de 17V DC filtré non régulé ?
    J'aime pas le Grec

  34. #28
    Janosch

    Re : Alimentation

    Tu disposes de 17V DC filtré non régulé ?
    Je comprends pas trop ta question.
    Tu veux en venir où?

    sur mon µC tu veux dire?
    dans ce cas non...

  35. #29
    DAUDET78

    Re : Alimentation

    Citation Envoyé par Janosch Voir le message
    Je comprends pas trop ta question.
    Tu veux en venir où?
    Où je pense ....
    Ton 12V DC est fait comment ? avec un 7812 ? Alimenté par quoi ?
    J'aime pas le Grec

  36. #30
    Janosch

    Re : Alimentation


Sur le même thème :

Page 1 sur 2 1 DernièreDernière

Discussions similaires

  1. alimentation CB, Alimentation PC, et parasites !
    Par 14bds75_cb dans le forum Électronique
    Réponses: 16
    Dernier message: 16/05/2012, 15h29
  2. Transformer une Alimentation Atx en Alimentation de Laboratoire
    Par Alex-physiká dans le forum Électronique
    Réponses: 4
    Dernier message: 17/10/2011, 19h12
  3. Alimentation fixe -> alimentation variable
    Par adouabiola dans le forum Électronique
    Réponses: 5
    Dernier message: 24/11/2010, 17h32
  4. alimentation linéaire+alimentation a découpage
    Par anoucha dans le forum Électronique
    Réponses: 3
    Dernier message: 13/12/2008, 18h46
  5. [Projet] Alimentation symetrique et alimentation 5A évolutile
    Par azertylr dans le forum Électronique
    Réponses: 21
    Dernier message: 14/04/2006, 19h18
Découvrez nos comparatifs produits sur l'informatique et les technologies.