Répondre à la discussion
Affichage des résultats 1 à 24 sur 24

probleme de simulation de aop



  1. #1
    fertanov

    probleme de simulation de aop


    ------

    Bjr tt le monde,
    J'ai un problème à propos le aop LM258 et sa simulation sur isis proteus. En fait je veux réalisé un convertisseur courant tension 0-20mA à 0-5V . C'est un circuit simple. Mais lors de la simulation , je n'ai pas obtenu ce que je voulais. SVP aidez moi. La capture écran résume le disfonctionnement. Le VCC dans la capture est 5V.

    -----
    Images attachées Images attachées  

  2. Publicité
  3. #2
    gcortex

    Re : probleme de simulation de aop

    ton ampli est inverseur ! La tension ne pouvant être négative, elle reste pas loin de zéro.
    Par ailleurs, si tu veux 5V il faut au moins 6.5V de tension d'alim ou remplacer par un TS922.

  4. #3
    terriblement

    Re : probleme de simulation de aop

    Salut,

    met ta R1 entre la broche - et la masse, et non entre la broche - et la sortie.
    ca devrait déjà mieux fonctionner
    et encore, tu as du gain qui vaudrait -1, montage à revoir

    edit:le simlateur prends en compte le fait que l'amplificateur n'est pas rail to rail ?
    Dernière modification par terriblement ; 12/05/2014 à 10h35.

  5. #4
    PIXEL

    Re : probleme de simulation de aop

    +1.... c'est toujours galère que de fonctionner au voisinage de l'alim...

    curieux que les profs ne signakent pas ce fait

    autre soluce : un rail négatif pour faire "respirer" l'aop

    les aop "rail-to-rail" bof , bof , d'expérience
    Dernière modification par PIXEL ; 12/05/2014 à 10h37.

  6. A voir en vidéo sur Futura
  7. #5
    futhier9178

    Re : probleme de simulation de aop

    Citation Envoyé par terriblement Voir le message
    Salut,

    met ta R1 entre la broche - et la masse, et non entre la broche - et la sortie.
    ca devrait déjà mieux fonctionner
    et encore, tu as du gain qui vaudrait -1, montage à revoir

    edit:le simlateur prends en compte le fait que l'amplificateur n'est pas rail to rail ?
    Je pense pas car la broche + est reliée à la masse.

  8. #6
    PIXEL

    Re : probleme de simulation de aop

    Citation Envoyé par futhier9178 Voir le message
    Je pense pas car la broche + est reliée à la masse.
    ce qui fait "travailler" l'aop dans un régime de mode commun insupportable....

    ça manque de bases tout ça

  9. Publicité
  10. #7
    terriblement

    Re : probleme de simulation de aop

    on a pas le droit de relier la borne + à la masse ?

  11. #8
    futhier9178

    Re : probleme de simulation de aop

    Citation Envoyé par terriblement Voir le message
    on a pas le droit de relier la borne + à la masse ?
    J'ai pas dit ça

  12. #9
    PIXEL

    Re : probleme de simulation de aop

    on a tout les droits SI on respecte les règles d'utilisation des aop.

    dans ce cas , un rail d'alim négatif est indispensable

  13. #10
    futhier9178

    Re : probleme de simulation de aop

    Citation Envoyé par futhier9178 Voir le message
    Je pense pas car la broche + est reliée à la masse.
    Autant pour moi j'avais mal analysé le schéma.

  14. #11
    terriblement

    Re : probleme de simulation de aop

    Donc on ne peut relier une broche au V- alim que si rail to rail ( et encore) ?
    idem pour V+ ?

  15. #12
    PIXEL

    Re : probleme de simulation de aop

    voui , et encore.... beaucoup d'aop n'apprécient pas un mode commun aussi brutal.

    revois les principes

  16. Publicité
  17. #13
    terriblement

    Re : probleme de simulation de aop

    tu as un lien ou un mot clé ?

    Parce que "principes" ne me dis rien

  18. #14
    PIXEL

    Re : probleme de simulation de aop

    ça ne sont pas les cours sur les aop qui manquent ....

    http://www.elektronique.fr/cours/AOP/aop-cours.php

  19. #15
    futhier9178

    Re : probleme de simulation de aop


  20. #16
    PA5CAL

    Re : probleme de simulation de aop

    Bonjour
    Citation Envoyé par terriblement Voir le message
    Donc on ne peut relier une broche au V- alim que si rail to rail ( et encore) ?
    idem pour V+ ?
    Tout est relatif.

    Le fonctionnement en AOP n'est que théorique. En pratique, les caractéristiques présentées ne sont jamais parfaites, et c'est le concepteur du montage qui doit faire en sorte que les défauts du circuit ne perturbent pas le fonctionnement au-delà de la précision demandée.

    Les tensions d'entrée doivent rester dans une plage fixée (entre 0V et Vcc–2V pour le LM258), et la tension de sortie ne peut varier que dans une plage donnée, dépendante de la charge (typiquement entre 5mV à Vcc–2V pour une charge de 10kΩ, parfois pire).

    En fait, les limites de ces plages correspondent à une modification du fonctionnement des circuits internes, tels qu'une mise en saturation ou un défaut de polarisation d'un composant. Cette modification n'est pas brutale, et si l'AOP ne fonctionne plus au-delà de ces limites, on assiste à dégradation progressive de ses caractéristiques juste en-deçà.

    Ainsi, on pourrait dans certains cas faire fonctionner un LM258 avec une entrée reliée à l'alimentation négative, conformément aux spécifications. Mais alors il ne faut plus compter obtenir les performances indiquée (courants de fuite, vitesse, ...).

    Par ailleurs, d'un point de vue théorique, l'AOP tend à régler sa tension de sortie de manière à maintenir ses deux entrées au même potentiel. Mais si ce potentiel celui de l'alimentation négative, alors c'est en pratique impossible à réaliser, sauf à disposer d'une source de tension extérieure encore plus négative que l'alimentation.


    Les amplis qualifiés de "rail-to-rail" ne sont pas capables de délivrer une tension de sortie exactement égale aux tensions d'alimentation (dès lors qu'il y a un courant de sortie, cela devient une impossibilité physique). Mais elle peut s'en approcher beaucoup plus près que dans le cas des AOP normaux (quelques millivolts sous une faible charge, au lieu de un à plusieurs volts).

    Pour les tensions d'entrée, certaines structures internes les autorisent à dépasser les tensions d'alimentation de quelques dixièmes de volts. Le qualificatif "rail-to-rail" est alors pleinement mérité. (Quand la structure interne des étages d'entrée peuvent fonctionnent lorsque les tensions dépassent de plusieurs volts celles de alimentations, on parle plutôt de "over-the-rail").
    Dernière modification par PA5CAL ; 12/05/2014 à 12h31.

  21. #17
    fertanov

    Re : probleme de simulation de aop

    Après qq essai, j'ai conclu que la tension de sortie dépend uniquement de la tension VCC et VSS. J'ai pas compris cela !!!! c'est bizarre !!

  22. #18
    PIXEL

    Re : probleme de simulation de aop

    c'est surtout anormal....

    le comportement d'un aop est indépendant de son alimentation , tant qu'elle reste
    dans le domaine des tensions de sortie demandées.

  23. Publicité
  24. #19
    futhier9178

    Re : probleme de simulation de aop

    Citation Envoyé par fertanov Voir le message
    Après qq essai, j'ai conclu que la tension de sortie dépend uniquement de la tension VCC et VSS. J'ai pas compris cela !!!! c'est bizarre !!
    Comment tu en conclus ça?

  25. #20
    PA5CAL

    Re : probleme de simulation de aop

    Citation Envoyé par fertanov Voir le message
    Après qq essai, j'ai conclu que la tension de sortie dépend uniquement de la tension VCC et VSS. J'ai pas compris cela !!!! c'est bizarre !!
    C'est probablement le signe que la sortie de l'AOP sature, parce que la tension qu'il est censé délivré est trop importante pour les valeurs de VCC ou VSS.

    Note qu'avec I1=20mA et R1=470Ω, la tension aux bornes de R1 doit être U1=R1·I1=9,4V !...

  26. #21
    fertanov

    Re : probleme de simulation de aop

    Exactement, mais moi j'obtient 0.49V meme si j'alimente le aop avec 12V

  27. #22
    PA5CAL

    Re : probleme de simulation de aop

    Dès le post #2, gcortex t'a indiqué que ton ampli était inverseur.

    Si tu veux pouvoir mesurer quelque chose de pertinent, il faut mettre VSS à –12V, et non pas à la masse. Et là, tu devrais normalement obtenir –9,4V en sortie.

    Nom : aop.png
Affichages : 17
Taille : 13,2 Ko
    Dernière modification par PA5CAL ; 12/05/2014 à 18h53.

  28. #23
    Zenertransil

    Re : probleme de simulation de aop

    Citation Envoyé par PIXEL Voir le message
    les aop "rail-to-rail" bof , bof , d'expérience
    Ca m'intéresse! En fait, je n'en ai jamais utilisé. J'ai toujours fait sans, en mettant à disposition une alim symétrique au moment du design pour ne pas taper la butée basse, et/ou en étendant la plage de tension d'alimentation pour ne pas taper la butée haute! Cela dit il y a sans doute des cas où ce n'est pas possible... Lors d'une modification peut-être? Mais une pompe de charge, c'est pas bien volumineux, surtout pour alimenter un AOP moderne.

    Quelles raisons est-ce que tu as (subjectivement et par expérience, l'objectif et l'incontestable se trouvant dans les datasheet) de les trouver "en dessous du lot"? Merci!

  29. #24
    fertanov

    Re : probleme de simulation de aop

    PA5CAL un très grand merciiiii. J'ai trouvé ce que je cherchais depuis pas mal du temps. Aussi, grand MERCI à vous tous )

  30. Publicité

Discussions similaires

  1. Problème de simulation et de RDM
    Par pouil77 dans le forum Physique
    Réponses: 9
    Dernier message: 28/05/2011, 21h32
  2. probleme simulation xilinx
    Par moussa97 dans le forum Électronique
    Réponses: 0
    Dernier message: 12/04/2010, 00h20
  3. Réponses: 11
    Dernier message: 24/03/2010, 19h30
  4. probleme se simulation
    Par zahira86 dans le forum Électronique
    Réponses: 1
    Dernier message: 30/11/2008, 01h20
  5. problème de simulation informatique
    Par bobbyfischer dans le forum TPE / TIPE et autres travaux
    Réponses: 1
    Dernier message: 29/01/2006, 21h49
Découvrez nos comparatifs produits sur l'informatique et les technologies.