Répondre à la discussion
Affichage des résultats 1 à 17 sur 17

Problème acquisition température à base de PT100



  1. #1
    extremgear

    Problème acquisition température à base de PT100


    ------

    Bonjour,

    Je souhaite mesurer des températures à l'aide de sondes PT100 , pour cela je me suis inspiré du montage de la figure 4 de cette application note :

    http://www.ti.com/lit/an/slyt442/slyt442.pdf

    j'ai modifié la valeur des résistances (voir schéma) pour avoir une plage de mesure de température -40 (0V) -> +100 ° (5V), en sortie de l'aop j'ai un banal pic avec ADC 10bits .
    Pour le choix de la valeur des résistances je me suis aidé du fichier excel fourni dans l'application note .
    Toutes les résistances sont des 0.1%

    Avec cette configuration le gain est d'environ 90.

    j'ai fait des essais avec 3 aops avec le même schéma:

    http://www.ti.com/lit/ds/symlink/opa277.pdf = ne fonctionne pas , n'est pas "single supply"

    http://cds.linear.com/docs/en/datasheet/10789fe.pdf = n'est pas rail to rail , je ne peux pas mesurer sur toute la plage de température -40-100° mais ça je m'en fou un peu.

    http://ww1.microchip.com/downloads/e...Doc/21685d.pdf = rail to rail mais semble moin bon car la tension d'offset est supérieure au précédent ?

    les soucis rencontrés :

    -sur une platine d'essai "bréleborde"avec le schéma ci dessous la température est à peu près cohérente à +-2° ( ce qui n'est dèjà pas très acceptable pour une pt100...), la température ne semble dèjà pas très stable.

    -sur un autre montage incluant un afficheur en plus du schéma précédent ça devient n'importe quoi la tension de sortie de l'aop varie selon si l'afficheur est alimenté ou non .

    je ne sais pas trop ce qui cloche à part le fait que l'aop utilisé n'est pas celui utilisé dans l'application note() , je galère pas mal à décoder les informations données dans les datasheet .

    Les aop présentés au dessus peuvent ils être utilisés en modifiant mon schéma ?

    Merci pour votre aide .


    Le schéma :

    -----
    Images attachées Images attachées  

  2. #2
    DAUDET78

    Re : Problème acquisition température à base de PT100

    je sais pas, mais une PT100 pour une mesure de température ??? Alors qu'il y a des capteurs en interface SPI , I²C ou OneWire ....
    http://pdf.datasheetcatalog.com/data...xim/DS1920.pdf
    J'aime pas le Grec

  3. #3
    extremgear

    Re : Problème acquisition température à base de PT100

    j'ai récupéré un lot de pt100 et je souhaitais m'en servir.

  4. #4
    DAUDET78

    Re : Problème acquisition température à base de PT100

    Citation Envoyé par extremgear Voir le message
    j'ai récupéré un lot de pt100 et je souhaitais m'en servir.
    On utilise un produit en fonction de l'application .... pas l'inverse !
    Si maintenant, tu persistes, c'est ton problème, plus le mien .
    J'aime pas le Grec

  5. A voir en vidéo sur Futura
  6. #5
    extremgear

    Re : Problème acquisition température à base de PT100

    je souhaiterais mesurer jusqu'a 8 températures , les capteurs en liaison I2C ou autre sont assez cher et ont parfois une précision annoncée moindre que ce que j'ai actuellement .
    du coup je me demande si un simple montage avec aop ne ferait pas mieux l'affaire ?
    je souhaite une précision +-1°


    Je persiste
    Images attachées Images attachées  

  7. #6
    extremgear

    Re : Problème acquisition température à base de PT100

    ce machin la semble acceptable mais cher ...
    http://www.farnell.com/datasheets/1647364.pdf

  8. #7
    DAUDET78

    Re : Problème acquisition température à base de PT100

    Citation Envoyé par extremgear Voir le message
    ce machin la semble acceptable mais cher ...
    http://www.farnell.com/datasheets/1647364.pdf
    C'est le genre de celui que je t'ai proposé en #2
    Cher ? ta PT100 , avec l'ampliOP et les résistances de précision, tu calcules très mal !

    Surtout que tu veux mesurer 8 températures ...... Tu mets 8 capteurs sur le même bus OneWire et basta !
    Avec tes PT100, tu fais comment ?
    J'aime pas le Grec

  9. #8
    gienas
    Modérateur

    Re : Problème acquisition température à base de PT100

    Bonjour à tous

    Je n'irai pas me "battre" contre DAUDET78 qui sait de quoi il parle.

    J'ai juste quelques remarques à ajouter.


    Citation Envoyé par extremgear Voir le message
    ... je souhaite une précision +-1° ...
    La PT100 nécessite obligatoirement un "traitement" du signal pour disposer d'un signal exploitable.

    +/- 1 degré n'a pas de sens si l'on ne définit pas une gamme de variation. Là, nous n'en avons pas la moindre idée.

    Nous ne savons rien non plus de la "qualité" des PT100 "en stock". Elles disposent de garanties absolues dépendantes du prix et de la présentation. Un ajustement d'origine est probablement indispensable une fois pour toute. Il est lié à chacune des sondes. Le traitement doit être fait et ajusté unitairement et ne bougera plus.

    Si des instabilités sont constatées, il faut déterminer si elles sont dues à l'électronique instable ou à la température qui évolue effectivement. Ce n'est pas toujours facile.

    Un "truc" commode. Pour faire la part des choses: prendre une résistance de précision correspondant à la valeur de PT100 à la température de l'essai en lieu et place de la sonde. On est sûr que "sa température" ne bougera pas.

    Si la sortie signal dérive, je te laisse deviner d'où vient le problème.

  10. #9
    gienas
    Modérateur

    Re : Problème acquisition température à base de PT100

    Citation Envoyé par extremgear Voir le message
    ce machin la semble acceptable mais cher ...
    Il me semble que c'est Henry Ford qui disait:

    Si tu as besoin de quelque chose mais que tu ne l'achètes pas, tu le payes quand même.

    À méditer.

  11. #10
    DAUDET78

    Re : Problème acquisition température à base de PT100

    Citation Envoyé par gienas Voir le message
    Je n'irai pas me "battre" contre DAUDET78 qui sait de quoi il parle.
    Faut jamais se battre ... sinon avec des idées !
    +/- 1 degré n'a pas de sens si l'on ne définit pas une gamme de variation. Là, nous n'en avons pas la moindre idée.
    On sait la gamme de mesure demandée
    Citation Envoyé par extremgear Voir le message
    pour avoir une plage de mesure de température -40 (0V) -> +100 ° (5V),
    Par contre j'aimerai bien savoir à quoi ça sert .... curieuse cette plage de température. C'est pas un moteur, pas un frigo , pas une station météo ... peut être un panneau solaire ?
    J'aime pas le Grec

  12. #11
    paulfjujo

    Re : Problème acquisition température à base de PT100

    bonjour,

    pourquoi y a t-il une reaction positive sur cet ampli ?
    ce n'est pas un gage de stabilite.

    de plus le courant traversant la pt100 me semble bien faiblard.
    Il faudrait envisager une solution alim a courant constant de
    la pt100...qui pourait permettre un aiguillage plus facile
    vers tes 8 capteurs.

  13. #12
    DAUDET78

    Re : Problème acquisition température à base de PT100

    Citation Envoyé par paulfjujo Voir le message
    pourquoi y a t-il une reaction positive sur cet ampli ?
    A mon humble avis, c'est un montage générateur de courant dans la PT100 ( si les résistances sont bien calculées) . Par contre la sortie sur l'ampliOP, c'est pas du 0 à 5V
    de plus le courant traversant la pt100 me semble bien faiblard.
    Bof, environ 1mA, c'est pas anormal ( il est déconseillé de dépasser 2mA pour cause d’auto-échauffement )
    J'aime pas le Grec

  14. #13
    extremgear

    Re : Problème acquisition température à base de PT100

    Merci pour toutes vos réponses .

    Citation Envoyé par gienas Voir le message
    Bonjour à tous

    Je n'irai pas me "battre" contre DAUDET78 qui sait de quoi il parle.

    J'ai juste quelques remarques à ajouter.




    La PT100 nécessite obligatoirement un "traitement" du signal pour disposer d'un signal exploitable.

    +/- 1 degré n'a pas de sens si l'on ne définit pas une gamme de variation. Là, nous n'en avons pas la moindre idée.

    Nous ne savons rien non plus de la "qualité" des PT100 "en stock". Elles disposent de garanties absolues dépendantes du prix et de la présentation. Un ajustement d'origine est probablement indispensable une fois pour toute. Il est lié à chacune des sondes. Le traitement doit être fait et ajusté unitairement et ne bougera plus.

    Si des instabilités sont constatées, il faut déterminer si elles sont dues à l'électronique instable ou à la température qui évolue effectivement. Ce n'est pas toujours facile.

    Un "truc" commode. Pour faire la part des choses: prendre une résistance de précision correspondant à la valeur de PT100 à la température de l'essai en lieu et place de la sonde. On est sûr que "sa température" ne bougera pas.

    Si la sortie signal dérive, je te laisse deviner d'où vient le problème.
    arf pour la pt 100 je ne sais pas du tout de quel type/modèle il s'agit.
    je vais essayer de chercher des infos la dessus.
    Pour le test avec une résistance " étalon " ça me parait intéressant .

    Citation Envoyé par gienas Voir le message
    Il me semble que c'est Henry Ford qui disait:

    Si tu as besoin de quelque chose mais que tu ne l'achètes pas, tu le payes quand même.

    À méditer.


    Citation Envoyé par DAUDET78 Voir le message
    Faut jamais se battre ... sinon avec des idées !On sait la gamme de mesure demandée Par contre j'aimerai bien savoir à quoi ça sert .... curieuse cette plage de température. C'est pas un moteur, pas un frigo , pas une station météo ... peut être un panneau solaire ?
    non non rien de tout ça , certaines sondes mesureront des températures "ambiante" , d'autres extérieures.
    et je souhaite 2 sondes pour mesurer la température de mes radiateurs(départ/retour eau) .
    Voila pourquoi une tel plage .

    La plupart des sondes seront à moin d'1M de lieu d'acquisition.

    Citation Envoyé par paulfjujo Voir le message
    bonjour,

    pourquoi y a t-il une reaction positive sur cet ampli ?
    ce n'est pas un gage de stabilite.

    de plus le courant traversant la pt100 me semble bien faiblard.
    Il faudrait envisager une solution alim a courant constant de
    la pt100...qui pourait permettre un aiguillage plus facile
    vers tes 8 capteurs.
    ah ouais c'était bien écrit dans l'application note en plus:
    The use of positive feedback might raise
    the concern of possible circuit instability
    cette contre réaction sert à "linéariser" la sonde si j'ai bien compris , du fait de ne pas avoir fait un montage avec courant constant , si j'ai bien compris.
    mais je me demande si une linéarisation "soft" ne serait pas mieux , je vais faire des essais !!

    Citation Envoyé par DAUDET78 Voir le message
    A mon humble avis, c'est un montage générateur de courant dans la PT100 ( si les résistances sont bien calculées) . Par contre la sortie sur l'ampliOP, c'est pas du 0 à 5V Bof, environ 1mA, c'est pas anormal ( il est déconseillé de dépasser 2mA pour cause d’auto-échauffement )
    oui voila 1mA pour le courant d'exitation de la sonde , courant qui ne sera pas constant en fonction de la température du fait de ce montage simpliste .
    la sortie ne sera pas 0-5 V , du fait que l'ampli ne soit pas rail to rail ?
    bof plus qu'a espérer que l'hiver ne soit pas trop rude

  15. #14
    DAUDET78

    Re : Problème acquisition température à base de PT100

    Je viens de faire une simulation ....
    Citation Envoyé par DAUDET78 Voir le message
    A mon humble avis, c'est un montage générateur de courant dans la PT100
    Effectivement de -40° à 100° ( PT100=84,27 à PT100=138,51), Le courant PT100 varie de 0,985mA à 1,006mA .
    Par contre la sortie sur l'ampliOP, c'est pas du 0 à 5V
    C'est pas vrai ! Errare Humanum est
    La tension varie de 0,057V à 5,078V
    du fait que l'ampli ne soit pas rail to rail
    J'ai pas vérifié si ton ampli était RtoR ..... Mais il faut qu'il le soit ( A moins de l'alimenter en plus que 5V)

    PS : Au prix des résistance à 0,5% ..... tu fais monter les couts !
    Dernière modification par DAUDET78 ; 13/12/2014 à 11h00.
    J'aime pas le Grec

  16. #15
    DAUDET78

    Re : Problème acquisition température à base de PT100

    Citation Envoyé par DAUDET78 Voir le message
    J'ai pas vérifié si ton ampli était RtoR .....
    Il est RtoR en entrée et en sortie
    http://pdf.datasheetcatalog.com/data...hip/21685b.pdf
    J'aime pas le Grec

  17. #16
    extremgear

    Re : Problème acquisition température à base de PT100

    En faite j'ai testé avec les 2 aop à ma disposition celui dont tu montres la datasheet et celui la :

    http://cds.linear.com/docs/en/datasheet/10789fe.pdf

    il semble plus précis ( tension d'offset inférieure ?)
    dans les 2 cas la température ambiante est identique .

  18. #17
    gienas
    Modérateur

    Re : Problème acquisition température à base de PT100

    Citation Envoyé par extremgear Voir le message
    ... cette ... réaction sert à "linéariser" la sonde si j'ai bien compris , du fait de ne pas avoir fait un montage avec courant constant , si j'ai bien compris.
    mais je me demande si une linéarisation "soft" ne serait pas mieux ...
    Il est exact qu'une technique de modification de la tension d'alimentation du pont de Weatstone existe pour linéariser la réponse, mais c'était bon il y a trente ans quand rien d'autre n'existait. Soft est bien plus souple en 2015 (demain)

    Noter cependant que même à courant constant, la réponse n'est pas linéaire.

Discussions similaires

  1. capteur de température PT100
    Par cris-abdel dans le forum Électronique
    Réponses: 17
    Dernier message: 08/03/2013, 15h59
  2. Régulation température PT100 1/10 de degré
    Par ROM42 dans le forum Électronique
    Réponses: 18
    Dernier message: 13/06/2012, 13h39
  3. Mesure température PT100
    Par Pilou81 dans le forum Électronique
    Réponses: 11
    Dernier message: 05/04/2010, 09h16
  4. enregistrement affichage temperature avec PT100 ou thermocouple
    Par patrick85340 dans le forum Électronique
    Réponses: 12
    Dernier message: 05/01/2010, 17h24
  5. Sonde PT100,Conversion Température/Tension
    Par djaiii dans le forum Électronique
    Réponses: 43
    Dernier message: 10/05/2008, 12h22
Découvrez nos comparatifs produits sur l'informatique et les technologies.