Répondre à la discussion
Affichage des résultats 1 à 4 sur 4

Problème arduino Mega



  1. #1
    Elzaidir

    Problème arduino Mega


    ------

    Bonjour à tous,
    j'utilise des arduino (me frappez pas) mega et un nano pour tester un transmetteur sans fil via l'ISP.
    Le problème c'est que tout à coup mon mega ne réagissait pas quand j'envoyais le programme. Les temoins de communication série ne s'allumait pas.
    J'ai donc regraver le bootloader avec un usbasp. Sauf que ça n'a pas marché. J'ai donc téléversé via le programmeur. Marche pas non plus, mais charge le programme et l'Atmega2560 accepte la programmation. J'ai donc de programmer en c avec atmel studio. Chose étrange, ça à marché.
    Je me demande donc d'où peux venir le problème. Avec atmel studio c'est bon mais pas arduino. Et la connexion USB est ok (il est détecté) mais le uC ne répond pas.
    Merci déjà pour vos réponses

    -----
    Dernière modification par Elzaidir ; 08/06/2015 à 20h29.

  2. #2
    picvert60

    Re : Problème arduino Mega

    bonjour
    c'est un probleme récurent du mega.
    pas trouvé de solution valable sur le web.
    à part tout debrancher et attendre qq minutes.
    je parierais que le tient accepte a nouveau
    la programmation sous arduino.

  3. #3
    Elzaidir

    Re : Problème arduino Mega

    Merci pour ta réponse, mais j'ai réessayé le jour suivant et ça n'a pas fonctionné

  4. #4
    Elzaidir

    Re : Problème arduino Mega

    Bonjour,

    je poste la solution que j'ai trouvé si un jour quelqu'un en a besoin:
    la version 1.6.x d'arduino bug quand on grave le bootloader. La methode consiste à télécharger la version officiel sur le site d'arduino puis de la graver manuellement, ou d'utiliser la version 1.0.x

Sur le même thème :

Discussions similaires

  1. Carte Arduino UNO R3 ou Arduino Mega 2560 R3 ?
    Par theoze dans le forum Électronique
    Réponses: 10
    Dernier message: 11/03/2015, 15h36
  2. Multitache arduino MEGA
    Par croco01 dans le forum Électronique
    Réponses: 7
    Dernier message: 30/06/2014, 10h40
  3. Probleme Arduino MEGA 1280
    Par croco01 dans le forum Électronique
    Réponses: 5
    Dernier message: 21/07/2013, 23h28
  4. Problème d'upload Arduino Mega 2560
    Par Chanis dans le forum Électronique
    Réponses: 2
    Dernier message: 21/08/2011, 18h04
  5. Arduino mega
    Par zener57 dans le forum Électronique
    Réponses: 0
    Dernier message: 14/09/2009, 17h55