Répondre à la discussion
Affichage des résultats 1 à 19 sur 19

amplifier signal avec ampli op



  1. #1
    robertt

    amplifier signal avec ampli op


    ------

    bonjour,

    je souhaiterai amplifier un signal audio sortant d'un lecteur mp3 de façon à obtenir un signal avec un offset de Vcc/2 et une amplitude de 2.5v
    donc avec une alim 9v le signal va osciller entre minimum 2v et maximum 7v avec un offset de 4.5v
    A l'oscilloscope le signal de sortie du baladeur possède une amplitude de 100mV.
    Donc on aurait besoin d'un gain de 25 afin d'obtenir le signal escompté

    je suis parti des calculs proposés dans un manuel ("Apprendre électronique en partant de zéro, tome2") dans lequel sont donnés :
    bande passante en kHz = 159 000 : (R3 kilohms x C2 en pF)
    en cherchant dans mes affaires j'ai trouvé des résistances R3 de 470k et des condos de 12pF
    donc en théorie je pourrai reproduire sans atténuation toute fréquence jusqu'à ~28khz

    puis une fois qu'on a déterminé R3 et le gain on cherche R2
    R2 = R3/gain
    R2 = 470000/25
    R2 = 18800, j'ai mis pour l'instant 18k

    une fois ces calculs faits j'ai réalisé un premier schéma sous LTspice (en pièce jointe)

    la simulation semble donner raison aux calculs (en pièce jointe)

    J'ai donc réalisé ce montage et là problème... à l'oscilloscope je n'obtiens absolument pas le résultat escompté...

    Pour comparaison une sonde de l'oscilloscope est placée sur la sortie du lecteur mp3 et l'autre sonde sur la sortie de l'aop.
    Le signal en sortie du lecteur mp3 est toujours là et ne semble pas être troublé par le montage.
    Pour ce qui est de la sortie de l'aop, après plusieurs essais (j'allume et j'éteins le circuit entre chaque test)
    soit j'obtiens un signal amplifié clippé à cause d'un offset largement au dessus du Vcc/2 attendu soit j'obtiens seulement
    une tension continue (toujours largement supérieure à Vcc/2)...

    J'ai beau vérifier et vérifier le montage je ne trouve pas d'où vient le problème, cela m'échappe. Au départ je pensais que peut être
    le lecteur mp3 s'écroulait parce que l'ampli op lui en demandait trop, mais si c'était le cas le signal en sortie du mp3 serait affecté or à l'oscillo il parait tout à fait normal... bref ce n'est pour l'instant pas de mon niveau, je préfère m'arrêter là plutôt que de dire des bêtises...

    Pour info le montage est réalisé sur une plaque breadboard avec alim régulée 9v et un seul ampli op LM324N

    merci !

    -----
    Images attachées Images attachées

  2. Publicité
  3. #2
    PIXEL

    Re : amplifier signal avec ampli op

    hello ,

    U4 est de trop.

    pour un seul aop , un pont diviseur suffira.

  4. #3
    DAUDET78

    Re : amplifier signal avec ampli op

    Voilà ton schéma corrigé :
    schema ampli .jpg
    Le LM324 est mal adapté car, alimenté en 9V, il ne peut pas sortir plus que 6,5V
    J'aime pas le Grec

  5. #4
    DAUDET78

    Re : amplifier signal avec ampli op

    Citation Envoyé par DAUDET78 Voir le message
    il ne peut pas sortir plus que 6,5V
    Soit un signal sinus de max 1,8VEFF
    J'aime pas le Grec

  6. A voir en vidéo sur Futura
  7. Comparatifs

    Gagnez du temps et de l'argent grâce à nos comparatifs de produits. Parmi nos sujets :
  8. #5
    robertt

    Re : amplifier signal avec ampli op

    hello ,

    U4 est de trop.

    pour un seul aop , un pont diviseur suffira.
    oui c'était seulement pour tester la combinaison aop et pont diviseur, il est vrai cela n'a pas trop d'utilité ici.

    Le LM324 est mal adapté car, alimenté en 9V, il ne peut pas sortir plus que 6,5V
    ah ceci m'a échappé effectivement merci de me le signaler

    Voilà ton schéma corrigé
    je viens d'effectuer la correction et cela ne résout malheureusement pas le problème... je constate que en enlevant le signal en entrée
    j'ai un voltage plus haut en sortie de l'aop qu'avec le signal. En d'autres termes sans la résistance de 100k j'obtiens l'équivalent de mon offset en sortie (4.5v) et avec la résistance cela monte nettement (~7v), je ne sais pas si c'est normal je suis un peu démuni là.
    J'ai également testé avec un autre lm324 du même lot et pareil...

  9. #6
    DAUDET78

    Re : amplifier signal avec ampli op

    Tu laisses la 100K
    Tu débranches le signal d'entrée V3.
    Tu as quelle tension DC en sortie de l'ampliOP ?
    J'aime pas le Grec

  10. Publicité
  11. #7
    robertt

    Re : amplifier signal avec ampli op

    Tu laisses la 100K
    Tu débranches le signal d'entrée V3.
    Tu as quelle tension DC en sortie de l'ampliOP ?
    à l'oscillo j'ai 7.8v, au cas où j'ai testé avec un multimètre c'est pareil.

  12. #8
    DAUDET78

    Re : amplifier signal avec ampli op

    - Soit C1 est monté à l'envers
    - Soit C1 est défectueux .
    Tu dois avoir 4,5V en sortie de l'ampliOP
    J'aime pas le Grec

  13. #9
    PIXEL

    Re : amplifier signal avec ampli op

    vue l'impédance d'entrée , un condo non polarisé est préférable

  14. #10
    robertt

    Re : amplifier signal avec ampli op

    vue l'impédance d'entrée , un condo non polarisé est préférable
    je n'en ai pas sous la main actuellement, j'essaierai !

    Soit C1 est monté à l'envers
    je me suis orienté par rapport à l'encoche opposée au gros point inscrit sur l'aop(voir photo jointe)
    le jack femelle audio carré est pour l'audio, l'autre est pour l'alim 9v
    l'encoche de l'aop n'est pas bien visible sur les photos jointes mais elle est bien orientée du côté du jack audio femelle carré.
    Images attachées Images attachées

  15. #11
    DAUDET78

    Re : amplifier signal avec ampli op

    J'ai bien l'impression qu'il y a une erreur de câblage .... où est C1 ?
    Si c'est le condensateur à coté du jack rond, il me semble en parallèle avec l'entrée et pas en série

    Bref, revérifie ton câblage .
    J'aime pas le Grec

  16. #12
    robertt

    Re : amplifier signal avec ampli op

    J'ai bien l'impression qu'il y a une erreur de câblage .... où est C1 ?
    C1 est à côté du jack carré noir, c'est le plus proche de l'ampli op.
    sur les photos on voit que C1 est relié à l'entrée inverseuse du LM324 par le biais de R2

    Si c'est le condensateur à coté du jack rond, il me semble en parallèle avec l'entrée et pas en série
    ce condensateur est C2 et il est en parallèle de l'alim (jack rond gris)

  17. Publicité
  18. #13
    DAUDET78

    Re : amplifier signal avec ampli op

    Citation Envoyé par robertt Voir le message
    C1 est à côté du jack carré noir, c'est le plus proche de l'ampli op.
    Et sa patte la plus proche de l'ampliOP, c'est bien la patte "+" ?
    J'aime pas le Grec

  19. #14
    robertt

    Re : amplifier signal avec ampli op

    Et sa patte la plus proche de l'ampliOP, c'est bien la patte "+" ?
    pfff effectivement, j'ai essayé dans les deux sens car je ne voyais pas d'amélioration mais là en le reessayant comme
    tu me l'avais précisé dans le schéma (le moins côté signal) ça fonctionne !!! ce qui m'a induit en erreur je pense c'est qu'il y une latence
    de quelques secondes à l'oscilloscope entre le moment où j'alimente l'aop et l'affichage de la trace, je n'étais pas assez patient.

    par contre je ne comprends absolument pas pourquoi cela marche maintenant et surtout avec un condensateur branché à l'inverse de ce que
    j'ai pu voir jusqu'à présent dans des manuels... cela va à l'inverse de ce que j'ai intégré jusqu'à présent... je pensais que ce condensateur
    servait simplement à enlever la composante continu et je pensais comme acquis qu'il fallait toujours le brancher côté +

    j'ai essayé à nouveau en branchant le côté + du condo côté signal et là ça marche aussi par moment mais avec un offset bien supérieur...
    en branchant côté - du condo côté signal comme tu l'as préconisé ça fonctionne parfaitement et avec la bonne tension d'offset.

    je suis ravi que cela fonctionne mais si quelqu'un avait la patience de m'expliquer les relations entre le sens de branchement du condensateur et le résultat
    ça serait parfait parce que là je suis un peu perdu...

  20. #15
    DAUDET78

    Re : amplifier signal avec ampli op

    Citation Envoyé par robertt Voir le message
    par contre je ne comprends absolument pas pourquoi cela marche maintenant et surtout avec un condensateur branché à l'inverse de ce que
    j'ai pu voir jusqu'à présent dans des manuels... cela va à l'inverse de ce que j'ai intégré jusqu'à présent...
    Faut pas penser, faut pas lire, faut pas imaginer !
    Faut comprendre la règle du jeu et l'appliquer !

    Le condensateur sert à éliminer la composante continue . Comment on la détermine ?
    - A droite, on a 4,5V (versus le 0V)
    - A gauche, on a 0V (versus le 0V) . La sortie d'un machin audio (bien fait) sort du 0V DC et confirmé par la 100K qu'on a rajouté (et uniquement pour ça !)

    Donc le condensateur doit avoir son "+" à droite


    Imaginons qu'à gauche on sorte sur un collecteur d'un NPN polarisé en DC à 9V
    - A droite, on a 4,5V (versus le 0V)
    - A gauche, on a 9V (versus le 0V) .

    Donc le condensateur doit avoir son "+" à gauche

    CQFD
    J'aime pas le Grec

  21. #16
    robertt

    Re : amplifier signal avec ampli op

    par contre je ne comprends absolument pas pourquoi cela marche maintenant et surtout avec un condensateur branché à l'inverse de ce que
    j'ai pu voir jusqu'à présent dans des manuels...
    je précise que quand je dis ça je pense à d'autres circuits de débutant que j'ai pu voir pour lesquels les condensateurs étaient branchés côté plus.
    Ceux ne sonr pas des circuits comme ici avec ampli op utilisé en ampli.

  22. #17
    DAUDET78

    Re : amplifier signal avec ampli op

    Citation Envoyé par robertt Voir le message
    je précise que quand je dis ça je pense à d'autres circuits de débutant que j'ai pu voir pour lesquels les condensateurs étaient branchés côté plus.
    Comprend la règle du jeu !
    Il faut évaluer la polarité de la tension DC aux bornes du condensateur
    Dernière modification par DAUDET78 ; 11/12/2015 à 12h24.
    J'aime pas le Grec

  23. #18
    robertt

    Re : amplifier signal avec ampli op

    merci beaucoup pour ta patience et le temps que tu donnes !

    leçon apprise c'est que l'on doit toujours placer un composant selon les différences de potentiel en jeu.
    Bêtement j'ai déplacé une façon de polariser un condensateur dans un circuit pour lequel ce n'était pas adapté...

  24. Publicité
  25. #19
    PIXEL

    Re : amplifier signal avec ampli op

    un condo chimique sur le chemin d'un signal est toujours à utiliser "avec des pincettes"

    c'est le métier qui rentre

Discussions similaires

  1. Amplifier un signal continu avec une tension d'alim variable
    Par Genjixkan dans le forum Électronique
    Réponses: 7
    Dernier message: 27/06/2012, 08h28
  2. amplifier fm avec ampli audio
    Par fregeal dans le forum Électronique
    Réponses: 2
    Dernier message: 13/02/2011, 12h56
  3. amplifier un signal avec un LM386...
    Par jaro975 dans le forum Électronique
    Réponses: 2
    Dernier message: 17/03/2010, 16h16
  4. ecreter un signal avec ampli op.
    Par Scopyright dans le forum Électronique
    Réponses: 2
    Dernier message: 27/06/2008, 17h10
  5. amplifier le signal
    Par lhattana dans le forum Électronique
    Réponses: 3
    Dernier message: 19/06/2008, 15h05
Découvrez nos comparatifs produits sur l'informatique et les technologies.