Répondre à la discussion
Affichage des résultats 1 à 10 sur 10

question sur le p16f877a



  1. #1
    cobra34

    question sur le p16f877a


    ------

    Bonjour jai une petite question au sujet du pic 16f877a
    je suis l'heureux proprietaire d'un easy pic3 et j'apprend a programmer avec mikrobasic mais led led ra4 allume pas avec le programme joint"
    program essai
    main:
    dim a as byte
    dim b as byte
    while true
    a=0

    trisa=0
    trisb=0
    trisc=0
    trisd=0

    porta=%00000001
    portb=%00000001
    portc=%00000001
    portd=%00000001

    while true
    a=a+1

    porta =a
    portb =a
    portc =a
    portd =a

    delay_ms(50)

    wend
    wend
    end.

    est-ce normale ou cest un defaut de fabrication, elle allume lorsque j'appuis sur je bouton ra4 en pull up!

    merci j'espere avoir ete assez clair .

    -----

  2. Publicité
  3. #2
    cobra34

    Re : question sur le p16f877a

    J'ai vraiment l'impression de me faire mettre de coté
    je suis pourtant pas le seul proprio du easypic 3 !!!!

  4. #3
    Gérard

    Re : question sur le p16f877a

    Un peu de patience, je viens de lire ton post et je te réponds, tu n'es pas le "vilain petit canard".

    Le port A est par défaut en entrées ana, pour le mettre en numérique, il faut écrire dans l'initialisation :
    ADCON1 = 7
    en plus c'est dans la doc.
    Gérard.

  5. #4
    cobra34

    Re : question sur le p16f877a

    merci Gerard ! tu est un sauveur dans ce forum lolll

  6. A voir en vidéo sur Futura
  7. Comparatifs

    Gagnez du temps et de l'argent grâce à nos comparatifs de produits. Parmi nos sujets :
  8. #5
    Gérard

    Re : question sur le p16f877a

    Citation Envoyé par cobra34
    merci Gerard ! tu est un sauveur dans ce forum lolll
    Il ne faut pas exagérer, je vais rougir.
    Ce truc m'est arrivé et j'ai cherché 2 jours avant de trouver.
    Je pense que c'est trop con de perdre son temps pour çà alors quand j'ai vu la question, j'y ai tout de suite pensé.

    Au fait, ça marche ?
    Gérard.

  9. #6
    cobra34

    Re : question sur le p16f877a

    j'ai rajouter la commande mais ra4 n allume toujours pas
    ;(

    program essai


    main:
    dim a as byte
    dim b as byte
    while true
    a=0
    adcon1=7
    trisa=0
    trisb=0
    trisc=0
    trisd=0

    porta=%00000001
    portb=%00000001
    portc=%00000001
    portd=%00000001

    while true
    a=a+1

    porta =a
    portb =a
    portc =a
    portd =a

    delay_ms(150)

    wend
    wend
    end.

  10. Publicité
  11. #7
    Gérard

    Re : question sur le p16f877a

    Comment as-tu cablé la sortie RA4 ?
    C'est une sortie à drain ouvert cad qu'elle ne peut que relier la sortie à la masse.
    Tu dois cabler : +, LED, résistance, RA4
    (l'anode vers le +, la cathode vers la résistance)
    dans ce cas, la LED s'allumera pour un état 0 sur RA4.

    Dans ton prochain post, la réponse attendue est : "çà marche".

    Gérard.
    Dernière modification par Gérard ; 25/04/2006 à 21h22.

  12. #8
    cobra34

    Re : question sur le p16f877a

    Citation Envoyé par Gérard
    Dans ton prochun post, la réponse attendue est : "çà marche".
    Gérard.
    ses vrai jai vue sa dans la doc du 877a mais j'aurais penser quelle aurais ete brancher en consequence sur le easypic 3!!!

  13. #9
    Gérard

    Re : question sur le p16f877a

    Et alors, çà marche ?
    Gérard.

  14. #10
    cobra34

    Re : question sur le p16f877a

    Citation Envoyé par Gérard
    Et alors, çà marche ?
    Gérard.
    oui merci!

Discussions similaires

  1. Réponses: 4
    Dernier message: 21/12/2010, 19h12
  2. Ptite question sur une question de géo3D : Asie 06
    Par anonymus dans le forum Mathématiques du collège et du lycée
    Réponses: 2
    Dernier message: 01/06/2007, 13h51
  3. Question sur une question ( algèbre lin.)
    Par xMrDibbsx dans le forum Mathématiques du supérieur
    Réponses: 1
    Dernier message: 13/10/2006, 23h39
  4. Question sur VCO dans ce schéma (et autre question)
    Par freesbeep dans le forum Électronique
    Réponses: 0
    Dernier message: 08/12/2005, 22h01
  5. Question sur la mise en place de liens sur page web
    Par dada180 dans le forum Internet - Réseau - Sécurité générale
    Réponses: 2
    Dernier message: 20/12/2003, 10h42
Découvrez nos comparatifs produits sur l'informatique et les technologies.