Répondre à la discussion
Affichage des résultats 1 à 6 sur 6

problem avec RA4 !!



  1. #1
    bimo

    Question problem avec RA4 !!


    ------

    re les gars
    je ne sais pas si je suis le seul qui a ce genre de problem ou c commun....bon j'ai progrmme mon PIC16F84A pour que toutes les broches du portA clignottent (clignottent c'est pour les leds branchees sur le portA )a la fois a une frequence de mon choix mais le probleme est que seule les broche " RA0 RA1 RA2 RA3 " qui marchent j'ai lu dans la datasheet que cette broche (RA4)est une broche d'interruption, est ce que ce la a une relation avec ce problem ? si oui comment la desactiver et la configurer comme sortie comme les autres broche du portA.
    voila mon programme :

    set_trisa ( 0x00);

    while(1)
    {
    output_a(0xFF);
    dealy_ms(500);
    output_a(0x00);
    delay_ms(500);
    }

    merci d'avance pour vos reponses

    -----
    Dernière modification par bimo ; 14/06/2006 à 18h58.

  2. Publicité
  3. #2
    umfred

    Re : problem avec RA4 !!

    je crois que c'est la fameuse broche sur laquelle il faut mettre une résistance de pull-up car il s'agit d'une sortie à drain ouvert.

    t'en fais pas , je crois qu'on est tous tomber dans le piège au moin une fois

  4. #3
    bimo

    Thumbs up Re : problem avec RA4 !!

    ahhh oui....i missed it in the datasheet
    merci beaucoup pour votre aide.....
    ahhh oui..sacre piege
    a+

  5. #4
    Gérard

    Re : problem avec RA4 !!

    Il faut brancher dans l'ordre : + alim, résistance, LED (anode vers R, cathode vers PIC), RA4.
    Cette LED s'allumera pour un niveau 0 sur RA4.
    Gérard.

  6. A voir en vidéo sur Futura
  7. #5
    bimo

    Thumbs up Re : problem avec RA4 !!

    merci Gerard pour l'explication

  8. #6
    Gérard

    Re : problem avec RA4 !!

    De rien.
    Gérard.

  9. Publicité

Discussions similaires

  1. problem avec tv sony
    Par shrale dans le forum Dépannage
    Réponses: 8
    Dernier message: 31/08/2007, 07h24
  2. problem avec PIC!!!
    Par bimo dans le forum Électronique
    Réponses: 4
    Dernier message: 19/06/2006, 20h47
  3. problem avec un DM d'elec
    Par spitfireman dans le forum Électronique
    Réponses: 3
    Dernier message: 05/11/2005, 17h01
  4. problem avec ma parabole
    Par fafa72 dans le forum Dépannage
    Réponses: 1
    Dernier message: 05/11/2005, 12h13
  5. problem/commande avec n.Mozilla, paiement avec IE
    Par Cornemuse dans le forum Internet - Réseau - Sécurité générale
    Réponses: 3
    Dernier message: 30/03/2005, 14h55
Découvrez nos comparatifs produits sur l'informatique et les technologies.