Répondre à la discussion
Affichage des résultats 1 à 29 sur 29

Fuite courant d'un chargeur universel avant la mise en marche!



  1. #1
    Sonny25

    Fuite courant d'un chargeur universel avant la mise en marche!


    ------

    Bonjour à tous.
    J'ai un chargeur universel qui fonctionne presque bien sauf un petit problème: quand je branche le prise du chargeur et avant même d'appuyer sur le bouton "On", j'obtient une tension d'une trentaine de volt et qui descend doucement jusqu'à 0 (regardez la vidéo : https://youtu.be/Ss-Khpe9Fno). Si par malheur j'oublie et je branche d'abord un appareil sur le chargeur et après je branche le chargeur je risque de cramé l'appareil branché(ça m'avait arrivé plus d'une fois).
    Est il possible de corriger ce problème?
    Merci d'avance

    -----
    Images attachées Images attachées

  2. Publicité
  3. #2
    ark89

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    c'est quoi en blanc sur le condensateur ???

  4. #3
    Sonny25

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Je crois c'est du Silicone
    Images attachées Images attachées  

  5. #4
    ark89

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    le condo a rien, tu l'a testé ?

  6. A voir en vidéo sur Futura
  7. #5
    Sonny25

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Les condensateurs n'ont aucune dégradation apparente.
    J'ai ajouté 2 résistances de décharge sur les 3 condensateurs parallèles, ce qui m'a permit de réduire le temps de décharge de plusieurs minutes à moins de 5 secondes. Mais ça n'a pas résolu le problème.
    apparement la sortie du courant est pilotée par le dernier Mosfet K80A08K3 dont la source est connectée à la masse, le Drain à la sortie - et Gate à un IC LM358.
    En branchant la prise j'ai vu que le mosfet devient passant pendant plusieurs secondes avec une tension Vgs= 11v puis elle chute à 0.
    Images attachées Images attachées

  8. #6
    ark89

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Je suis pas assez calé pour t'aider, attends les pros, salut !

  9. Publicité
  10. #7
    Sonny25

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Merci quand même, salut

  11. #8
    gienas
    Modérateur

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Bonjour Sonny25 et tout le groupe

    Citation Envoyé par Sonny25 Voir le message
    ... J'ai ajouté 2 résistances de décharge sur les 3 condensateurs parallèles, ce qui m'a permit de réduire le temps de décharge de plusieurs minutes à moins de 5 secondes ... En branchant la prise j'ai vu que le mosfet devient passant pendant plusieurs secondes avec une tension Vgs= 11v puis elle chute à 0.
    Il est évident que tes résistances sur les condensateurs de "filtrage" n’a aucun effet sur la sortie.

    Il ne faut pas oublier qu’un chargeur n’est pas fait pour rester à vide.

    Si le chargeur est connecté hors tension secteur, il est probable que le défaut n’existera pas.

    Pour essayer de s’en convaincre, il faudrait charger la sortie, et trouver la valeur qui ne provoque plus le "défaut".

    Suivant le cas, cette charge pourra rester définitivement. Si elle doit être trop faible, il faudra prévoir un relais, piloté par un transistor qui coupera cette charge (en fait une décharge) quand la batterie commencera elle, sa charge.

  12. #9
    lutshur

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Bonjour,
    quand je branche le prise du chargeur et avant même d'appuyer sur le bouton "On", j'obtient une tension d'une trentaine de volt et qui descend doucement jusqu'à 0
    2 hypothèses :
    - pas de soft start
    - constante de temps trop importante dans le lissage du feedback
    Pour résoudre le problème, il faut déjà connaitre le schéma

  13. #10
    Antoane
    Responsable technique

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Bonsoir,
    Sil s'agit d'un chargeur universel, ce pic de tension ne pourrait il pas être intentionnel et servir a caractériser la batterie connectée en sortie ?
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  14. #11
    Sonny25

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Bonjour Gienas, lutshur,
    Effectivement, quand je l'utilise en tant que chargeur, plus de problème car la batterie absorbe le surplus du courant du démarrage. Mais le problème c'est quand je l'utilise comme adaptateur pour faire fonctionner d'autres appareils, et c'est souvent le cas.

    Sinon, Je viens de tester l'ajout d'une charge à la sortie comme tu l'a dit, j'ai essayé plusieurs valeur de 1k à 100ohm. Avec la résistance de 100 ohm j'ai pu avoir des bons résultats, j'ai obtenu une tension maximale de 5v pendant 0.5 s. Dèja c'est pas mal, et ça peut être une solution. Par contre l'ajout d'un relais et transitor , je ne vois pas comment, le but c'est bien de faire fonctionner la charge que pendant les premieres secondes puis l'arrêter, en plus la tension de sortie est variable, de 0.1v à 60v. Moi j'ai pensé à une thermistance CTP, je ne sais ce que vous en pensez, moi je ne connais pas, c'est une résistance variable, faible au début puis augmente ou coupe lorsque la temperature augmente. j'ai pensé à la mettre en parallèle avec la sortie ou la mettre entre la Source et Gate du transistor qui control la sortie. Je devrais les recevoir demain pour les tester, voici le lien : https://www.ebay.fr/itm/191837260677

    - pour le soft start je ne connais pas mais à part ça le chargeur fonctionne très bien: on choisit la tension et l'ampérage et on appuie sur le bouton "On" et ça marche, ça c'est en mode manuel. sinon en mode automatique il suffit de choisir le type de batterie (acide, NH, lipo ...), donc le soft me parait fonctionne.

    - pour le schéma j'ai déja contacté le vendeur, il ne l'a pas et j'ai rien trouvé sur le net.

    - J'ai pensé aussi à installer un interrupteur sur la sortie, ce qui me permet de contrôler manuellement la sortie. mais je n'ai pas trouver de mini interrupteur qui s'ouvre tout seul quand j'enlève la prise. car il ne doit pas rester fermé quand je branche la prise.

  15. #12
    Sonny25

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Citation Envoyé par Antoane Voir le message
    Bonsoir,
    Sil s'agit d'un chargeur universel, ce pic de tension ne pourrait il pas être intentionnel et servir a caractériser la batterie connectée en sortie ?
    Bonsoir Antoane,
    Personnellement je ne crois pas que c'est pour la detection de la batterie, car on le trouve seulement lorsque on branche la prise, mais quand on démarre le chargeur avec le bouton "ON", il y ai pas.
    Si ce pic apparaiterait à chaque fois qu'on appuie sur le bouton ON ça serais surement comme tu l'a dit.
    Je crois qu'en branchant la prise tous les condensateurs se charge avant que le soft prend le controle et restent chargées.
    Avant d'jouter les 2 résistances de décharge, les condensateurs coté secondaire reste chargé pendant plusieurs minutes.

  16. Publicité
  17. #13
    gienas
    Modérateur

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Citation Envoyé par Sonny25 Voir le message
    ... le problème c'est quand je l'utilise comme adaptateur pour faire fonctionner d'autres appareils, et c'est souvent le cas ...
    Je pense que c'est là l'erreur.

    Un chargeur doit rester un chargeur (qu'il est) et pas s'en servir comme une alimentation qui doit garantir une tension fixe connue, et, le cas échéant, permettre de limiter le courant débité.

    Si tu tiens à utiliser ton chargeur dans ce but, il faut mettre derrière les fonctions de régulation de tension, et, pour pas beaucoup plus cher, de quoi limiter le courant avec un ajustement des deux.

  18. #14
    annjy

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Bsr,

    et si on avait la référence du chargeur ???
    si c'est un bon, c'est peut-être un générateur de courant (contrôlé) et pas un générateur de tension......

    cdlt,
    JY
    A+

  19. #15
    Sonny25

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Citation Envoyé par annjy Voir le message
    Bsr,

    et si on avait la référence du chargeur ???
    si c'est un bon, c'est peut-être un générateur de courant (contrôlé) et pas un générateur de tension......

    cdlt,
    JY
    C'est HGJI 1608 Chargeur adaptateur électrique réglable, 3V-60V, 150W : https://fr.aliexpress.com/item/1005001397693866.html

  20. #16
    antek

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Avec les appellations fantaisistes qui sèment la confusion . . . pour une fois on a affaire à un "vrai" chargeur.
    Au branchement d'un élément il cherche à envoyer un courant (fonction peut-être des réglages possibles).
    Ce n'est donc pas utilisable en source de tension.
    KIS - keep it short

  21. #17
    Sonny25

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Même si il fait chargeur seulement, je ne trouve pas normal qu'il livre une tension de 30v au départ. si je veux charger une petite pile par exemple, une tension de 30v peut faire des dégâts. à mon avis c'est un défaut de conception, car j'ai déja essayé de débrancher la carte de contrôle (photo joint) et j'ai eu le même comportement.

    Regardez sur cette vidéo: https://youtu.be/YradyAuiJlE , je l'ai mis en mode Li-ion batterie avec une tension de 3.7v et un courant max de 0.5A. même en appuyant sur le bouton start, il délivre une tension nettement supérieur qui baisse doucement avec la décharge des condensateurs jusqu'à arrivé à la tension demandé. Et même après avoir enlever la prise, elle reste une tension sur la sortie (la vidéo est faite avant que je rajoute les résistances de décharge sur les condos).
    Images attachées Images attachées  

  22. #18
    gienas
    Modérateur

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Bonjour à tous

    Citation Envoyé par Sonny25 Voir le message
    Même si il fait chargeur seulement, je ne trouve pas normal qu'il livre une tension de 30v au départ. si je veux charger une petite pile par exemple, une tension de 30v peut faire des dégâts. à mon avis c'est un défaut de conception ...
    Comment peut-on "discuter" avec quelqu’un qui refuse d’entendre les explications qui sont données?

    Un chargeur est fait pour charger et comporte une procédure pour le fonctionnement.

    Nous ne savons rien de la possibilité de débit de ce que tu appelles "surtension", débit qui sera un fifrelin pour la batterie branchée dessus.

    Merci de ne pas mélanger les fonctions d’autant que, comme déjà annoncé, la tension de sortie ne doit pas être fixée, passée la surtension.

    Si tu veux détourner l’objet de son utilisation conçue et vendue pour, tu dois t’adapter ou changer d’appareil. Une alimentation "de laboratoire" se règle en tension et peut comporter un réglage d’intensité pour éviter les surintensités pour le cas où elles "voudraient" se produire.

  23. Publicité
  24. #19
    lutshur

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Bonjour,
    Vu le mode d'emploi, je ne vois pas pourquoi l'appareil aurait besoin d'envoyer une tension de test. Et ce, avant même la mise en marche. Ce n'est pas un truc "intelligent".
    Nom : Sans titre 1.jpg
Affichages : 87
Taille : 210,0 Ko
    On peut tout supposer sans schéma.
    Peut-être que le datasheet du circuit pilote du découpage permettrait de se faire une idée...
    Dernière modification par lutshur ; 26/04/2021 à 10h08.

  25. #20
    Sonny25

    Re : Fuite courant d'un chargeur universel avant la mise en marche!!!

    Citation Envoyé par lutshur Voir le message
    Bonjour,
    Vu le mode d'emploi, je ne vois pas pourquoi l'appareil aurait besoin d'envoyer une tension de test. Et ce, avant même la mise en marche. Ce n'est pas un truc "intelligent".
    Pièce jointe 437973
    On peut tout supposer sans schéma.
    Peut-être que le datasheet du circuit pilote du découpage permettrait de se faire une idée...
    Voici quelques références :
    Nom : IMG_1257.jpg
Affichages : 71
Taille : 186,2 Ko

  26. #21
    Sonny25

    Re : Fuite courant d'un chargeur universel avant la mise en marche!

    Photos montrent les références:
    Images attachées Images attachées

  27. #22
    lutshur

    Re : Fuite courant d'un chargeur universel avant la mise en marche!

    Nom : Capture d’écran_2021-04-26_17-49-05.png
Affichages : 65
Taille : 53,0 Ko
    Dans le datashet du LD7575, il n'est nulle mention de soft start (démarrage en douceur). Donc c'est plein pot dès l'application du 230Vac, jusqu'à la charge de C2 (vide au départ).
    Entre en jeu aussi le mode de régulation au secondaire de ton chargeur dont on ne sait rien. Pour que le circuit effacé soit fonctionnel (supposé être le coeur du système), il y a peut-être besoin d'un laps de temps, très court, pendant lequel la tension de sortie atteint son pic.
    si je veux charger une petite pile par exemple, une tension de 30v peut faire des dégâts. à mon avis c'est un défaut de conception
    Pas vraiment, l'accu encaissera sans problème, le pic ne dure pas suffisamment longtemps. Et comme l'ont souligné les autres contributeurs, c'est un chargeur, pas une alim.
    Si tu veux l'utiliser autrement, il faudra trouver un moyen d'isoler la sortie jusqu'à disparition de la surtension.

  28. #23
    Sonny25

    Re : Fuite courant d'un chargeur universel avant la mise en marche!

    Merci lutshur pour ces informations précieuses.
    isoler la sortie jusqu'à la disparition de la surtension c'est exactement ce que je veux. ça me permet de l'utiliser en tant que adaptateur sans risque, sachant que je l'utilise déja en faisant attention à chaque fois, à le brancher d'abord, le mettre en mode manuel, choisir la tension et l'ampérage, l'activer et attendre quelques secondes pour que la tension se stabilise puis brancher l'appareil que je veux tester.

    J'ai fais plusieurs essaies mais j'ai finis par lacher l'affaire. ça devient trop compliqué et ça ne vaut pas le cout:
    - j'ai mis une thermistance sur le mosfet qui controle la sortie, elle est de 0.5ohm ce qui rend le mosfet en régime de coupure Vgs<3v. Elle se ferme au bout de 4 secondes si le courant dépasse 1A et rendra le mosfet passant, et ça permet d'éviter le pic des premières secondes. Mais malheureusement ça n'a pas marché. Le courant qui traverse la thermistance était 0.1A, donc elle est resté passante et aucune tension qui sort du chargeur.

    - J'ai remplacé la thermistance par un condensateur: le condensateur pendant qu'il charge empêchera le mosfet d'etre passant, mais le problème c'est que le condos se charge trop vite. J'ai essayé plusieurs combinaisons, la plus efficace s'était : 3 condos de 16v 1000uf en parallèle avec une résistance de 100 ohm en série et une résistance de 500 en parallèle avec le tout( cette dernière pour baisser le Vgs fournie par la carte de 11v à 3.6v) et une charge de 1K ohm en sortie. avec ce montage j'ai pu obtenir un pic moins de 1V. C'est pas mal mais c'est beaucoup, pas assez de place solution trop lourde.

    - sinon en mettant seulement une charge en sortie:
    - Une résistance de 100 ohm : donne un pic de moins de 1v, mais elle chauffe trop
    - Une résistance de 270 ohm : donne un pic de moins de 2v, mais elle chauffe beaucoup aussi
    - Une résistance de 500 ohm : donne un pic de moins de 5v
    - Une résistance de 1k ohm : donne un pic de moins de 8v

    Je crois je vais mettre juste une résistance de 500 ohm sur la sortie à l'extérieure, une résistance amovible, je l'enlève que je l'utilise comme chargeur car j'ai peur qu'elle fausse l'algorithme de charge.
    J'arrète sur ça, merci à tout le monde pour votre aide, j'ai appris beaucoup de choses

    Cordialement

  29. #24
    lutshur

    Re : Fuite courant d'un chargeur universel avant la mise en marche!

    Bonjour,
    Un petit schéma ?
    Parce que si j'ai bien compris, en amont du Mosfet il y a 60V ?
    Son refroidissement me parait un peu léger.

    Sinon, j'aurais plutôt travaillé sur la patte COMP du LD7575

  30. Publicité
  31. #25
    lutshur

    Re : Fuite courant d'un chargeur universel avant la mise en marche!

    Comme ceci, par exemple. Mais pas sûr que ça fonctionne.
    Nom : Sans titre 1.jpg
Affichages : 49
Taille : 107,8 Ko

  32. #26
    lutshur

    Re : Fuite courant d'un chargeur universel avant la mise en marche!

    Une petite explication.
    Le condensateur additionnel va se charger par la circuiterie interne du LD7575. La tension sur COMP va monter plus progressivement qu'avec le montage originel. Une fois le condo chargé, il n'intervient plus.
    Lorsqu'on coupe le secteur, il se décharge via les 7V, qui vont disparaitre aussi. Pourquoi 7V ? parce que le datasheet indique que c'est la limite supérieure de la tension sur COMP. On pourrait prendre une tension plus élevée, ça ne ferait que retarder le moment où le condo commence à se décharger.
    Dernière modification par lutshur ; 27/04/2021 à 09h29.

  33. #27
    jiherve

    Re : Fuite courant d'un chargeur universel avant la mise en marche!

    bonjour,
    Comme déjà dit par d'autres si c'est un chargeur serieux il fonctionnera en source de courant (compliance élevée sans doute s'il est "universel"), la régulation de celui ci demande qu'il y ait une charge en sortie, en l'absence de charge le chargeur passe en régulation/limitation de tension ce qui induit le fonctionnement constaté.
    et bis repetita :
    un chargeur n'est pas un adaptateur secteur , l'inverse étant également vrai,
    pour utiliser des clous => marteau
    pour utiliser des vis => tournevis.
    JR
    l'électronique c'est pas du vaudou!

  34. #28
    gienas
    Modérateur

    Re : Fuite courant d'un chargeur universel avant la mise en marche!

    Bonjour à tous

    Citation Envoyé par jiherve Voir le message
    ... un chargeur n'est pas un adaptateur secteur , l'inverse étant également vrai,
    pour utiliser des clous => marteau
    pour utiliser des vis => tournevis ...
    Merci d’enfoncer le clou.

    J’ai peur, malheureusement, qu’il n’y ait pire sourd que celui qui ne veut rien entendre.

  35. #29
    lutshur

    Re : Fuite courant d'un chargeur universel avant la mise en marche!

    Bonjour,
    Bientôt sur vos écrans, en provenance de Chine, le martovisseur qui règlera la question. Vous pourrez alors charger vos batteries avec une alimentation limitée en courant

Discussions similaires

  1. Réponses: 2
    Dernier message: 06/04/2018, 11h24
  2. Mise à la terre et courant de fuite
    Par david210 dans le forum Bricolage et décoration
    Réponses: 11
    Dernier message: 13/07/2012, 20h57
  3. chargeur universel
    Par atcatc dans le forum Électronique
    Réponses: 10
    Dernier message: 14/05/2008, 18h01
  4. Réponses: 2
    Dernier message: 15/12/2007, 18h00
  5. Chargeur universel
    Par supergamerj dans le forum Électronique
    Réponses: 6
    Dernier message: 20/11/2003, 17h54
Découvrez nos comparatifs produits sur l'informatique et les technologies.