Répondre à la discussion
Affichage des résultats 1 à 26 sur 26

Linux : Plantages fréquents :(



  1. #1
    gizmo2937

    Unhappy Linux : Plantages fréquents :(


    ------

    Bonsoir !

    J'ai installé depuis peu (lundi dernier pour être plus précis ) Mandriva 2009.0 sur mon pc.

    J'ai des problèmes de plantage au démarrage de l'interface graphique (Gnome 2.24). J'ai mis deux photos d'écran pour vous montrer à quels moments.

    Le chargement de Mandriva est assez long (environ 3 à 5 min) et il m'affiche un message : "ata5 : link is slow to respond, please be patient (ready = 0)" suivi de pleins d'autres lignes toujours pour ata5 puis ensuite pareil avec ata6
    J'ai mis une petite image montrant l'écran à ce moment là.

    A votre avis par ou je commencer à chercher pour trouver la source de mon problème ?
    Je suis encore débutant complet sous Linux et je ne sais pas trop quoi vérifier.

    A l'écran de choix de l'OS, j'ai plusieurs choix pour Mandriva :
    Amorcer Mandriva Linux 2009
    Amorcer Mandriva Linux 2009 (mode dégradé)
    Amorcer Microsoft Windows
    Linux avec le noyaux 2.6.27-desktop586rc8-2mb
    desktop586 2.6.27.19-1mb


    Pour les trois premières lignes pas de problème, mais à quoi se rapportent les deux dernières ?
    Est-ce que je dois lancer Linux avec une de celle-là ?

    Merci de votre aide

    -----
    Images attachées Images attachées
    Dernière modification par gizmo2937 ; 22/04/2009 à 18h52. Motif: manquait un mot -_-'

  2. #2
    lou_ibmix_xi

    Re : Linux : Plantages fréquents :(

    Salut
    Ces messages sont inquiétants, tu as un problème avec le disque dur ou son controleur...
    As-tu des problèmes sous Windows?
    Quel est le modèle exact de ton PC, si il est fait maison quel est le modèle de la carte mère?

    Au cas où ton problème n'aurait rien à voir avec le disque dur, désactive compiz ou beryl (les artifices 3D) pour voir si cela améliore la stabilité du système...
    As tu installé les pilotes propriétaires de ta carte graphique?

    Pour les trois premières lignes pas de problème, mais à quoi se rapportent les deux dernières ?
    Est-ce que je dois lancer Linux avec une de celle-là ?
    la pénultième (j'adore ce mot) correspond certainenement à un autre noyau installé suite à une mise à jour (mais c'est peut-être l'ancien et pas le nouveau). La dernière je ne sais pas. En tout cas tu ne risques rien à les essayer et voir si ça améliore, auquel cela pourrait nous donner une pistes.

    Courage, tu as la malchance d'être tomber sur une config qui ne marche pas tout de suite, pour des milliers qui marchent...

  3. #3
    invite765732342432
    Invité

    Re : Linux : Plantages fréquents :(

    Citation Envoyé par lou_ibmix_xi Voir le message
    la pénultième (j'adore ce mot) correspond certainenement à un autre noyau installé suite à une mise à jour (mais c'est peut-être l'ancien et pas le nouveau).
    Je remarque que cette ligne mentionne un noyau en RC... Alors, il y a peut-être d'autres composants non-stables...

  4. #4
    Arius

    Re : Linux : Plantages fréquents :(

    Citation Envoyé par gizmo2937 Voir le message
    Est-ce que je dois lancer Linux avec une de celle-là ?

    Merci de votre aide
    Non tu dois amorcer les premiers. La dernière est le noyau de base me semble-t-il mais il faudrait que je passe sous Mandriva pour te le confirmer
    Comme l'a dit lou_ibmix_xi l'avant dernière est une mise à jour du noyau.

    . Tu remarqueras qu'a chaque mise à jour que tu fais, cela s'ajoutera dans la liste

  5. A voir en vidéo sur Futura
  6. #5
    gizmo2937

    Re : Linux : Plantages fréquents :(

    Merci de ta réponse !

    Non pas de problème rencontré sous Windows (Vista édition 64). Le démarrage se fait normalement.

    J'ai une carte Gigabyte GA-EP45-DS5 avec la dernière version de BIOS.

    Une fois le système lancé par contre, je n'ai aucun plantage. Si il y a plantage c'est uniquement au démarrage de l'interface graphique (je t'écris de Linux d'ailleurs).

    Je n'ai activé ni Metisse ni Compiz ... j'aime bien l'interface sans effet.
    Pour les pilotes de la carte graphique, je me suis contenté des mises à jours proposées via le gestionnaire de paquets.

    Je suis en train de télécharger un cd d'installation de Mandriva 2009 (je n'ai qu'un liveCD pour l'instant). Comme ça je pourrai tenter une réparation du système en bootant sur le cd.
    Est-ce que tu penses que ça peut résoudre le problème ?

    Ne t'en fais pas Il m'en faudra bien plus pour me décourager d'utiliser Linux (je suis assez têtu ).

    Merci de ton aide.

  7. #6
    gizmo2937

    Re : Linux : Plantages fréquents :(

    Merci à tous les deux Faith et Arius !

    J'ai toujours utilisé le premier choix pour l'instant.
    je vais peut-être essayer avec le dernier. Si il s'agit de l'ancien noyaux et que je n'ai pas de plantage avec celui-ci je saurai d'ou vient mon problème.

    Ne me restera plus qu'à régler le soucis de démarrage

  8. #7
    Arius

    Re : Linux : Plantages fréquents :(

    Citation Envoyé par gizmo2937 Voir le message

    Une fois le système lancé par contre, je n'ai aucun plantage. Si il y a plantage c'est uniquement au démarrage de l'interface graphique (je t'écris de Linux d'ailleurs).
    Certaines mises à jours peuvent corriger cela


    Je suis en train de télécharger un cd d'installation de Mandriva 2009 (je n'ai qu'un liveCD pour l'instant). Comme ça je pourrai tenter une réparation du système en bootant sur le cd.
    Est-ce que tu penses que ça peut résoudre le problème ?
    Pas sûr..

    Je vais faire un tour du coté de la communauté, voir si il n'y a pas des antécédents.

  9. #8
    MaliciaR

    Re : Linux : Plantages fréquents :(

    Salut,

    Fais un
    Code:
     uname -a
    dans chaque cas. Je me demande si ton Linux mystérieux en 4e position n'est pas ce que j'avais comme équivalent de memTest86 ou un truc dans le genre dans le cadre d'un dual boot Ubuntu-Windows XP.
    La version la plus récente du kernel est la 2.6.29, si l'on croit ce site On saura laquelle tu as sur ta Mandriva quand t'auras posté le résultat de la commande ci-dessus (version moins verbeuse avec l'option -r).
    An expert is one who knows more and more about less and less.

  10. #9
    gizmo2937

    Re : Linux : Plantages fréquents :(

    Merci MaliciaR !

    Voici le résultat pour uname -a :

    Linux localhost 2.6.27.19-desktop586-1mnb #1 SMP Wed Mar 4 23:49:24 EST 2009 i686 Intel(R) Core(TM)2 Duo CPU E7200 @ 2.53GHz GNU/Linux

    Le gestionnaire de paquets ne me propose pas de mises à jour actuellement.
    Je cherche dans les forums Mandriva mais ça ne donne rien pour l'instant

  11. #10
    Arius

    Re : Linux : Plantages fréquents :(

    Citation Envoyé par Faith Voir le message
    Je remarque que cette ligne mentionne un noyau en RC... Alors, il y a peut-être d'autres composants non-stables...
    Possible en effet, mais il y aurait eu un message d'erreur du noyau, si il aurait détecter cela au boot

    Je continue les recherches et de contacter deux trois membres de la communauté. Mais cette erreur me semble bien rare.

    Sinon le plan C serait d'installer une version antérieure de Mandriva et de faire une mise à jour.

    Edit : Petite question, tu as bien pris l'édition 64bits ?

  12. #11
    gizmo2937

    Re : Linux : Plantages fréquents :(

    Euhhhh ... Non j'ai l'édition 32 bits
    Comme je débutai j'ai choisi une édition One avec les pilotes tout prêt.
    Je pensai pas que ça pouvait poser problème d'utiliser une version 32bits (i586) avec un proc 64 bits.

    Tu crois que ça peut venir de là? J'ai lancé le téléchargement d'un iso de x86-64 et si vous pensez que ça peut être ça je l'installerai.

  13. #12
    invite26295292

    Re : Linux : Plantages fréquents :(

    Personnellement, je ne pense pas que le fait d'utiliser une version 32 bits sur un proc 64 bits soit un facteur d'instabilité. (ça fait plus de 4 mois que je tourne avec Ubuntu 32 bits sur mon proc à 64...)

    Malheureusement, je ne saurais pas te dire d'où peut venir le problème, ne connaissant que très peu Mandriva.

  14. #13
    Arius

    Re : Linux : Plantages fréquents :(

    Citation Envoyé par gizmo2937 Voir le message
    Euhhhh ... Non j'ai l'édition 32 bits
    Comme je débutai j'ai choisi une édition One avec les pilotes tout prêt.
    Je pensai pas que ça pouvait poser problème d'utiliser une version 32bits (i586) avec un proc 64 bits.

    Tu crois que ça peut venir de là? J'ai lancé le téléchargement d'un iso de x86-64 et si vous pensez que ça peut être ça je l'installerai.
    Bah vu que ton erreur me parait assez rare, j'ai fouillé le forum de fond en comble, etc. Maintenant comme tu as une Màj avec un noyau RC, c'est peut-être cela qui a causé le problème (=compatibilité ?)

    Maintenant Dunatotatos n'a pas tort non plus, j'ai moi même utilisé une version 32bits sur un 64bits sans problèmes.
    Mais comme on dit, tout est possible, le meilleur moyen est de testé.

  15. #14
    gizmo2937

    Re : Linux : Plantages fréquents :(

    Je vais essayer demain !

    Est-ce qu'il vaut mieux que je supprime mes partitions et que reparte de zéro pour l'installation, ou une mise à niveau après avoir booté sur le dvd free x86-64 est faisable ?

    Merci de votre aide.

  16. #15
    ph11

    Re : Linux : Plantages fréquents :(

    Citation Envoyé par Faith Voir le message
    Je remarque que cette ligne mentionne un noyau en RC... Alors, il y a peut-être d'autres composants non-stables...
    2.6.27 en rc ? Ça me semble vachtement bizarre.
    Il faudrait peut-être simplement mettre le système à jour.

  17. #16
    ph11

    Re : Linux : Plantages fréquents :(

    Tu pourrais dire ce que tu as comme matériel ? Surtout au niveau disque dur, cd/dvd ? S'ils sont en SATA ou IDE ?
    Il se peut qu'il y ait un problème avec ça.

    Regarde aussi dans le bios note ce qui a un rapport avec ide, ata, sata, ahci, raid.
    Ou fais une photo de ce sous-menu.

    Un petit
    Code:
    sudo fdisk -l
    pourrait aider.
    et aussi
    Code:
    lspci
    ou
    Code:
    lshw
    , si ce dernier paquet est installé...

  18. #17
    gizmo2937

    Re : Linux : Plantages fréquents :(

    Pour la commande 'su fdisk -l' j'ai comme réponse : l'usager fdisk n'existe pas
    J'ai été dans le gestionnaire de logiciels mais fdsik il connait pas.

    Mon cd / dvd et mon disque dur sont en SATA.

    Pour lspci voilà ce que j'ai :

     Cliquez pour afficher


    Pour 'lshw' il est bien installé (Hardware lister v2.13) mais il ne connait pas la commande sous le terminal

  19. #18
    gizmo2937

    Re : Linux : Plantages fréquents :(

    Sinon pour les mises à jour, tout ce qui était proposé sous le gestionnaire de logiciels est fait donc à priori le système est à jour.

    Est-ce qu'il vaut mieux rechercher les mises à jours manuellement pour le noyaux ?

  20. #19
    Bruno

    Re : Linux : Plantages fréquents :(

    Citation Envoyé par gizmo2937 Voir le message
    Pour la commande 'su fdisk -l' j'ai comme réponse : l'usager fdisk n'existe pas
    sudo fidsk -l

  21. #20
    Arius

    Re : Linux : Plantages fréquents :(

    Citation Envoyé par gizmo2937 Voir le message
    Sinon pour les mises à jour, tout ce qui était proposé sous le gestionnaire de logiciels est fait donc à priori le système est à jour.

    Est-ce qu'il vaut mieux rechercher les mises à jours manuellement pour le noyaux ?
    Non, moi c'est automaitque et je n'ai pas de problèmes..

    Est-ce qu'il vaut mieux que je supprime mes partitions et que reparte de zéro pour l'installation, ou une mise à niveau après avoir booté sur le dvd free x86-64 est faisable ?
    Une mise à niveau est faisable

    As-tu déjà utilisé la version antérieure de mandriva (sans avoir eu ce prob.) ? Si oui, en l'installant et en faisant l'update vers la dernière, il y a moyen que cela résous le problème, car lors qu'une mise à niveau certains paramètres sont préservés. Il y a donc une chance

  22. #21
    gizmo2937

    Re : Linux : Plantages fréquents :(

    Voilà Bruno ! Je m'en suis sorti avec fdisk !!
    J'ai pas réussi avec la commande sudo ... j'ai installé le paquet puis essayé de modifié le fichier sudoers comme expliqué dans un forum mais sans succés

    En me mettant en root j'ai pu lancer fdisk -l et voilà le résultat :
     Cliquez pour afficher


    En esperant que ça puisse aider

    J'ai télécharger Ubuntu 9.04 qui est sorti aujourd'hui !
    Donc si je réinstalle, pas de mise à niveau je partirai de zéro

  23. #22
    MaliciaR

    Re : Linux : Plantages fréquents :(

    Citation Envoyé par ph11
    2.6.27 en rc ? Ça me semble vachtement bizarre.
    Si, si, ça existe. Le développement du kernel est un peu spécial (pas de version alpha, bêta), mais des merge windows et (plein) de RC


    Citation Envoyé par gizmo2937 Voir le message
    En me mettant en root j'ai pu lancer fdisk -l et voilà le résultat
    Euh, c'était pour ça qu'on te disait de faire sudo :P


    J'ai télécharger Ubuntu 9.04 qui est sorti aujourd'hui !
    Donc si je réinstalle, pas de mise à niveau je partirai de zéro
    Je ne sais pas, ce ne serait ptet pas totalement débile que tu essaies la 8.10 et la 9.04 : on sait pas s'il y a pas des bugs dans la Jaunty. Même si ce n'est pas une bêta, qui sait si jamais un bug apparaissait chez toi, s'il serait dû à la Jaunty ou à ton souci matériel.
    Cela dit, ton pc a moins de 6 mois ou plus?
    An expert is one who knows more and more about less and less.

  24. #23
    ph11

    Re : Linux : Plantages fréquents :(

    Citation Envoyé par gizmo2937 Voir le message
    Périphérique Amorce Début Fin Blocs Id Système
    /dev/sda1 * 1 12749 102400000 7 HPFS/NTFS
    /dev/sda2 12750 19457 53882010 5 Extended
    /dev/sda5 12750 13425 5429938+ 83 Linux
    /dev/sda6 13426 13934 4088511 82 Linux swap / Solaris
    /dev/sda7 13935 14953 8185086 83 Linux
    /dev/sda8 14954 16953 16064968+ 83 Linux
    /dev/sda9 16954 18947 16016773+ 83 Linux
    /dev/sda10 18948 19457 4096543+ 83 Linux
    Y a un truc bizarre. Mis-à-part ta partition windows, toutes les autres sont des partitions logiques.
    Normalement, il faut que la partition dont le point de montage / ou /boot si celle ci existe, soit une partition primaire et amorçable. Ça m'étonne que grub accepte de booter dessus.

    Tu veux bien faire la commande
    Code:
    cat /etc/fstab
    et ensuite
    Code:
    df -h

  25. #24
    gizmo2937

    Re : Linux : Plantages fréquents :(

    Ma configuration a moins de 6 mois (elle est de février).
    Pour les partitions j'avais laissé faire l'utilitaire Mandriva lors de l'installation. Tout s'est fait automatiquement.

    J'ai installé Ubuntu 9.04 hier soir et je n'ai pas eu de plantage sur 7 démarrages

    Le démarrage est toujours très long par contre : 2m20 contre 22 sec pour mon frère qui n'a pas de périphériques SATA

    Voici le résultat de la commande cat /etc/fstab (attention les partitions n'ont plus rien à voir à celles sous Mandriva) :

     Cliquez pour afficher


    Voici le résultat pour df -h :

     Cliquez pour afficher


    J'ai fais un fdisk -l aussi (sur Ubuntu la commande sudo marche de base ) :

     Cliquez pour afficher


    Voilà ! J'espère que ça vous donne assez d'info pour comprendre ce qui se passe !
    J'avais pensé utiliser bootchart. Est-ce que ça peut apporter qqchose de nouveau ?

    Merci de votre aide

  26. #25
    ph11

    Re : Linux : Plantages fréquents :(

    Tu as fait le partitionnement automatique ou manuel ? /boot ne devrait pas être en /dev/sda7, mais sur une partition primaire et n'a pas besoin de tant de place, 100Mo suffisent très largement. tu n'as pas non plus besoin de 4Go de swap.

    Sinon, pour afficher toutes les infos de boot, du noyau, il y a la commande
    Code:
    dmesg

  27. #26
    gizmo2937

    Re : Linux : Plantages fréquents :(

    J'ai fait dmesg et voici ce que j'ai trouvé concernant mon problème :

    Code:
    [    1.092779] ata1: SATA max UDMA/133 abar m8192@0xea100000 port 0xea100100 irq 19
    [    1.092782] ata2: SATA max UDMA/133 abar m8192@0xea100000 port 0xea100180 irq 19
    [    7.400007] ata1: link is slow to respond, please be patient (ready=0)
    [   11.096007] ata1: softreset failed (device not ready)
    [   11.096056] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    [   11.096060] ata1: link online but device misclassified, retrying
    [   17.404010] ata1: link is slow to respond, please be patient (ready=0)
    [   21.100007] ata1: softreset failed (device not ready)
    [   21.100053] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    [   21.100058] ata1: link online but device misclassified, retrying
    [   27.408007] ata1: link is slow to respond, please be patient (ready=0)
    [   56.136007] ata1: softreset failed (device not ready)
    [   56.136053] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    [   56.136058] ata1: link online but device misclassified, retrying
    [   56.136061] ata1: limiting SATA link speed to 1.5 Gbps
    [   61.156007] ata1: softreset failed (device not ready)
    [   61.156053] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
    [   61.156058] ata1: link online but device misclassified, device detection might fail
    [   67.480008] ata2: link is slow to respond, please be patient (ready=0)
    [   71.176007] ata2: softreset failed (device not ready)
    [   71.176053] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    [   71.176058] ata2: link online but device misclassified, retrying
    [   77.484008] ata2: link is slow to respond, please be patient (ready=0)
    [   81.180007] ata2: softreset failed (device not ready)
    [   81.180053] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    [   81.180058] ata2: link online but device misclassified, retrying
    [   87.488008] ata2: link is slow to respond, please be patient (ready=0)
    [  116.216009] ata2: softreset failed (device not ready)
    [  116.216058] ata2: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
    [  116.216062] ata2: link online but device misclassified, retrying
    [  116.216066] ata2: limiting SATA link speed to 1.5 Gbps
    [  121.236007] ata2: softreset failed (device not ready)
    [  121.236054] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
    [  121.236058] ata2: link online but device misclassified, device detection might fail
    [  121.252086] ata_piix 0000:00:1f.2: version 2.12
    [  121.252097] ata_piix 0000:00:1f.2: PCI INT B -> GSI 19 (level, low) -> IRQ 19
    [  121.252100] ata_piix 0000:00:1f.2: MAP [ P0 P2 P1 P3 ]
    [  121.252132] ata_piix 0000:00:1f.2: setting latency timer to 64
    [  121.252191] scsi2 : ata_piix
    [  121.252235] scsi3 : ata_piix
    [  121.252725] ata3: SATA max UDMA/133 cmd 0x1f0 ctl 0x3f6 bmdma 0xf000 irq 14
    [  121.252729] ata4: SATA max UDMA/133 cmd 0x170 ctl 0x376 bmdma 0xf008 irq 15
    [  121.902612] ata3.00: SATA link down (SStatus 0 SControl 300)
    [  121.902619] ata3.01: SATA link down (SStatus 0 SControl 300)
    [  122.696052] ata4.00: SATA link down (SStatus 0 SControl 300)
    [  122.696063] ata4.01: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
    [  122.712190] ata4.01: ATAPI: TSSTcorp CDDVDW SH-S203D, SB00, max UDMA/100
    [  122.728196] ata4.01: configured for UDMA/100
    [  122.729284] scsi 3:0:1:0: CD-ROM            TSSTcorp CDDVDW SH-S203D  SB00 PQ: 0 ANSI: 5
    Est il possible de configurer manuellement le débit pour que les périphériques fonctionnent en 1.5Gbps? J'ai l'impression que le système essaie de les faire fonctionner en 3Gbps puis qu'il laisse tomber pour finalement passer en 1.5Gbps.
    Si il commençait directement par 1.5Gbps, il démarrerait beaucoup plus vite

    Voici deux autres lignes qui ont attirés mon attention :
    [ 1.077766] Driver 'sd' needs updating - please use bus_type methods
    [ 1.077772] Driver 'sr' needs updating - please use bus_type methods

    Apparemment il a besoin d'une mise à jour mais je ne sais pas de quoi

    Pour les partitions ... je ne pouvais pas utiliser le partitionnement automatique sinon il me virer aussi ma partition Windows (sur le même disque que Ubuntu).
    Pour les tailles c'est vrai que j'ai pris un peu au pif. Le SWAP j'ai repris la valeur qu'avait assigné Mandriva et le boot j'ai improvisé

    Merci

Discussions similaires

  1. Plantages fréquents et intempestifs sur XP pro
    Par elem dans le forum Logiciel - Software - Open Source
    Réponses: 12
    Dernier message: 28/04/2009, 08h17
  2. [Blanc] panne régrigérateur - arrêts fréquents
    Par el cascador dans le forum Dépannage
    Réponses: 2
    Dernier message: 25/10/2007, 20h03
  3. Plantages Futura Flash
    Par jc_m dans le forum Internet - Réseau - Sécurité générale
    Réponses: 1
    Dernier message: 26/05/2005, 20h27
  4. Problème de plantages successifs
    Par $t!cKy_F!Ng@Z dans le forum Matériel - Hardware
    Réponses: 6
    Dernier message: 12/06/2004, 19h18
  5. gros problème plantages
    Par chippie38 dans le forum Logiciel - Software - Open Source
    Réponses: 8
    Dernier message: 13/12/2003, 14h05
Découvrez nos comparatifs produits sur l'informatique et les technologies.