Répondre à la discussion
Affichage des résultats 1 à 3 sur 3

excel



  1. #1
    yakoo26

    excel


    ------

    bonjour,
    je voudrai mettre en evidence dans un tableau toutes les lignes avec 3 ou + données identiques qui se suivent.
    merci de votre aide

    -----

  2. #2
    danyvio

    Re : excel

    Citation Envoyé par yakoo26 Voir le message
    bonjour,
    je voudrai mettre en evidence dans un tableau toutes les lignes avec 3 ou + données identiques qui se suivent.
    merci de votre aide
    J'ai réduit le problème à la comparaison de deux colonnes consécutives.

    Dans mon tableau de test, je compare les colonnes A à G, en mettant le résultat dans la colonne H

    Ici, pour la ligne 1, dans la cellule H1 j'ai écrit la formule :


    =SI(OU(A1=B1;B1=C1;C1=D1;D1=E1 ;E1=F1;F1=G1);"=";"#")

    Si deux colonnes consécutives sont égales, H1 contiendra le signe =, sinon #

    La formule est copiée dans les lignes 2,3 etc.

    A toi d'adapter en fonction de tes besoins, notamment pour 3 colonnes consécutives, et en utilisant le résultat pour faire une mise en forme conditionnelle.
    On trouve des chercheurs qui cherchent ; on cherche des chercheurs qui trouvent !

  3. #3
    danyvio

    Re : excel

    Modif pour effectuer les comparaisons sur 3 colonnes consécutives

    =SI(OU(ET(A1=B1;B1=C1);ET(B1=C 1;C1=D1);ET(C1=D1;D1=E1);ET(D1 =E1;E1=F1);ET(E1=F1;F1=G1));"= ";"#")
    On trouve des chercheurs qui cherchent ; on cherche des chercheurs qui trouvent !

Discussions similaires

  1. Transfert Automatique de cellules Excel vers Excel
    Par deadog182 dans le forum Logiciel - Software - Open Source
    Réponses: 25
    Dernier message: 22/01/2018, 20h55
  2. Excel
    Par Ravaner dans le forum Logiciel - Software - Open Source
    Réponses: 3
    Dernier message: 24/05/2008, 06h00
  3. Problème conversion fichiers excel PC vers excel MAC
    Par Pallmall37 dans le forum Logiciel - Software - Open Source
    Réponses: 4
    Dernier message: 14/11/2007, 21h31
  4. Excel
    Par kuznik dans le forum Logiciel - Software - Open Source
    Réponses: 5
    Dernier message: 10/04/2007, 19h57
  5. Excel
    Par pimbolie dans le forum Logiciel - Software - Open Source
    Réponses: 9
    Dernier message: 25/11/2004, 11h19
Découvrez nos comparatifs produits sur l'informatique et les technologies.