Répondre à la discussion
Page 1 sur 2 1 DernièreDernière
Affichage des résultats 1 à 30 sur 52

petit problème sur un CD4017



  1. #1
    Danieldu54

    petit problème sur un CD4017


    ------

    Bonjour à tous

    peut-être que ma question semble idiote pour un confirmé que je ne suis pas en électronique, je veux faire une horloge à leds avec 60 leds pour les sec, 60 pour les min et 12 pour les heures. Je sais que ce sujet à déja été traité de nombreuse fois, et je sais déja comment la construire, là n'est pas le problème. Je veux la faire avec des compteur 4017 et mon soucis vient de là.

    Lorsque je câble un 4017 pour le tester, donc le minimum:
    +9V sur la broche 16, 0V sur la 8 et la 13, des leds sur les sorties avec une résistance, et j'envoie du +9 sur l'horloge borne 14.

    La sortie Q0 reste allumée et ne bouge pas, et lorsque je touche avec les doigts les bornes, ca compte quand sa veux.

    Est-ce que j'ai oublier de mettre autre chose ?

    -----

  2. Publicité
  3. #2
    DAUDET78

    Re : petit problème sur un CD4017

    un p'tit schéma vaut mieux que 100 discours !
    J'aime pas le Grec

  4. #3
    jiherve

    Re : petit problème sur un CD4017

    Bonsoir
    Un signal d'horloge c'est un signal périodique alternatif pas du continu!
    et il faut mettre la 15 (clear) à 0!
    JR

  5. #4
    Chimimic

    Re : petit problème sur un CD4017

    bonsoir,

    si l'entrée d'horloge est en borne 14, la borne 13 doit être cablée au +V.
    Ne pas oublier borne RAZ (MR, borne 15) à la masse !

    Exemple

    Cordialement.

  6. #5
    jiherve

    Re : petit problème sur un CD4017

    Citation Envoyé par Chimimic Voir le message
    bonsoir,

    si l'entrée d'horloge est en borne 14, la borne 13 doit être cablée au +V.


    Exemple

    Cordialement.
    Non la borne 13 c'est un NOT Clock enable !
    donc doit être à zero
    JR

  7. A voir en vidéo sur Futura
  8. #6
    Danieldu54

    Re : petit problème sur un CD4017

    oui bien sûr, le voilà.

    Dsl j'ai pas de logiciel de dessin.
    Images attachées Images attachées

  9. Publicité
  10. #7
    Chimimic

    Re : petit problème sur un CD4017

    Bonjour jiherve,

    tout à fait juste, merci de m'avoir corrigé.
    Le schéma proposé en lien est corrigé, c'est le seul où j'ai fait l'erreur, les autres sont corrects.

    Cordialement.

  11. #8
    Danieldu54

    Re : petit problème sur un CD4017

    donc la borne 15 à 0v en permanence ? sur le signal d'horloge je fait un contact 9V par intermitantce car j'ai pas encore fait mon circuit qui sort du 1hz

  12. #9
    Chimimic

    Re : petit problème sur un CD4017

    oui, comme dans l'exemple.

  13. #10
    Danieldu54

    Re : petit problème sur un CD4017

    bien donc est-ce que le schéma est juste ? et si oui pourquoi ne compte-t-il pas et compte dans tous les sens lorsque je touche les pattes avec mes doigts ?

  14. #11
    DAUDET78

    Re : petit problème sur un CD4017

    pin 15 à 0V
    Pin 14 relié au 0V par une capa de 0,1µF
    Pin 14 relié à une 100 ohms
    L'autre extrémité de la 100 ohm relié au VCC par 1K et relié aussi à un interrupteur
    L'autre extrémité de l'interrupteur au 0V
    et basta le comptage !
    J'aime pas le Grec

  15. #12
    Danieldu54

    Re : petit problème sur un CD4017

    ok j'essaye de suite

    Merci DAUDET78

  16. Publicité
  17. #13
    Danieldu54

    Re : petit problème sur un CD4017

    si j'ai bien compris ça donne ça ? en tout cas ça ne marche toujours pas.
    Images attachées Images attachées

  18. #14
    Danieldu54

    Re : petit problème sur un CD4017

    j'ai oublié la 15 à 0V

  19. #15
    DAUDET78

    Re : petit problème sur un CD4017

    sur le schéma non validé? mais ça marche avec pin 15 à 0V?
    J'aime pas le Grec

  20. #16
    Danieldu54

    Re : petit problème sur un CD4017

    sur le schéma2. ça ne marche pas la borne 15 0V ou pas. J'ai mis les valeurs des composants que j'ai: 100 Ohm remplacée par 330 et le condo de 0.1µ par u 1 µ. Ou peut tu faire un schéma si le mien est faux ?

  21. #17
    DAUDET78

    Re : petit problème sur un CD4017

    J'attend de voir ton schéma qui n'est toujours pas validé ....
    J'aime pas le Grec

  22. #18
    Danieldu54

    Re : petit problème sur un CD4017

    ok pour faire mon horloge, je compte reprendre le signal d'une autre horloge (celle dans Electronique pratique N°282) http://www.electroniquepratique.com/...idMg=29&id=297
    il sort par la borne Q22 d'un CD4521 (1Hz). Comment récupérer ce signal sans perturber le reste du circuit ? (là j'ai pas de quoi copier le schéma dsl).

    Mais ma préoccupation principale c'est le 4017.

  23. Publicité
  24. #19
    Danieldu54

    Re : petit problème sur un CD4017

    Voilà le schéma où je souaite reprendre le signal du 1Hz ...

    Désolé, un schéma issu d'une revue ne peut pas être diffusé sur un forum public, à cause des droits d'auteur.
    Le cas échéant tu peux te mettre en relation avec un membre pour lui transmettre le document par MP.
    Cordialement.
    Dernière modification par HULK28 ; 15/11/2007 à 15h41. Motif: suppression pièce jointe (schéma issu d'une revue)

  25. #20
    Chimimic

    Re : petit problème sur un CD4017

    Bonjour Daniel,

    chaque chose en son temps. Faisons déjà fonctionner le compteur, puis ensuite on regardera l'horloge.
    Sur cette page Chenillard 001, tu trouveras un schéma qui fonctionne. Compares-le avec le tien, et tiens-nous informé.

    Cordialement.

  26. #21
    Danieldu54

    Re : petit problème sur un CD4017

    ok, dès que je rentre chez moi je l'essaye, merci.

  27. #22
    maxitec

    Re : petit problème sur un CD4017

    Avec 470Ω seulement pour R1 sous +9v (Schéma précedent), le 4017 risque de passer des moments terribles.

  28. #23
    DAUDET78

    Re : petit problème sur un CD4017

    Y a pas que ça Maxitec ! Le bouton poussoir qui se prend un court circuit sur la capacité C1, c'est pas bon (faut une 220 ohm en série avec le poussoir). Quand au 4017 sur LED et 470 ohm, il donnera ce qu'il peut, il meurt pas, mais ça brille pas terrible.
    Le problème, sur le WEB, on trouve des tas de schéma qui respecte rien, même pas les spécifications. Le gars se fait un montage, ça tombe en marche et il le met sur son site!
    J'aime pas le Grec

  29. #24
    maxitec

    Re : petit problème sur un CD4017

    Le bouton poussoir qui se prend un court circuit sur la capacité C1, c'est pas bon (faut une 220 ohm en série avec le poussoir).
    D'accord avec DAUDET78 : Les rebonds d'un poussoir c'est sérieux.

  30. Publicité
  31. #25
    Chimimic

    Re : petit problème sur un CD4017

    Bonjour (...),

    Quand au 4017 sur LED et 470 ohm, il donnera ce qu'il peut, il meurt pas, mais ça brille pas terrible.
    Tout à fait d'accord. Le 4017 ne grille pas et la led ne brille pas beaucoup, sauf si cette dernière brille bien sous 3 à 5 mA. Avez-vous essayé avec plusieurs types de leds ? Moi oui.

    e bouton poussoir qui se prend un court circuit sur la capacité C1, c'est pas bon (faut une 220 ohm en série avec le poussoir)
    Mon dieu, c'est tout à fait vrai, je n'y avais jamais pensé. Il me semble avoir oublié de préciser que les montages proposés ne sont pas destinés à une production industrielle...
    Hum... Daudet parlait du courant circulant dans le poussoir, pas des rebonds qui sont ici suffisement absorbés par C1 et R2.

    J'ai toujours tenu à ce que les débutants découvrent des choses par eux mêmes, ça implique une gymnastique de l'esprit qui n'est pas la même que celle que l'on acquière avec un montage où tout est cuit d'avance.

    Montages sur le net : on trouve de tout, c'est ce qui fait la richesse. Il y a du bon, il y a du mauvais, et il y a entre les deux, ça c'est sûr. Notez que jamais je n'ai essayé de me positionner dans telle ou telle catégorie. Les gens qui fouinent savent trouver et garder ce qu'ils veulent, et si le montage qu'il trouvent comporte une erreur mais que l'explication de texte leur permet de la trouver, ce n'est pas forcement un grand mal.

    Dernière chose : contrairement à certains, j'admet sans aucune difficulté mes erreurs. Ceux qui me lisent le savent.

    SVP, ne lisez pas ce post comme un post agressif, il ne l'est pas. C'est juste un "repositionnement", pas une défense.

    Bien cordialement,
    et bonne journée à tous.

  32. #26
    Chimimic

    Re : petit problème sur un CD4017

    ceci dit, je suis entièrement d'accord avec Daudet concernant la présence d'une petite résistance en série avec le poussoir pour limiter le courant de décharge de la capa.
    Je n'ai pas dit que j'étais contre

  33. #27
    maxitec

    Re : petit problème sur un CD4017

    Citation Envoyé par Chimimic Voir le message
    Bonjour (...),
    Hum... Daudet parlait du courant circulant dans le poussoir, pas des rebonds qui sont ici suffisement absorbés par C1 et R2.
    Bonjour ;
    le poussoir ne court aucun risque:
    - la quantité d'électricité emmagasinée par 0,22F sous 9v est très minime.
    - l' "autre courent" circulant dans le poussoir est rendu négligeable à l’infini (R2 de 220k en série).
    De ce côté-là, aucun problème donc..
    Ma remarque s’est portée sur les rebonds et j’insiste.
    Déjà au plein, C1 n’aura plus de "place" pour absorber rien que ce soit..
    Un « vrai » anti rebonds est toujours préférable. C’est un avis personnel..

  34. #28
    DAUDET78

    Re : petit problème sur un CD4017

    Citation Envoyé par maxitec Voir le message
    la quantité d'électricité emmagasinée par 0,22F sous 9v est très minime.
    Une charge minime avec une résistance de court-circuit nulle donne (théoriquement) un courant infini.
    1/ ce qui, à la longue, risque de détériorer le contact du bouton poussoir
    2/ ce qui risque de provoquer des courants de circulation important et des parasitages

    Pourquoi se créer des problèmes ...... il y en a assez naturellement!

    PS: le 4017 est un des rares compteurs avec une entrée trigger de Schmitt, donc pas de problème de rebond avec un réseau RC
    J'aime pas le Grec

  35. #29
    Danieldu54

    Re : petit problème sur un CD4017

    bonsoir tout le monde. J'ai fait le montage du chenillard 001 et ça fonctionne à merveille. Donc les cd 4017 fonctionnent, mais à présent je souhaite que les leds précédentes restent allumées. Donc comment faire ???

  36. #30
    Danieldu54

    Re : petit problème sur un CD4017

    je précise aussi que mon condo c'est un 0.1µF et ma résistance une 330Ohms.

Sur le même thème :

Page 1 sur 2 1 DernièreDernière

Discussions similaires

  1. petit probleme sur mplab
    Par casou dans le forum Électronique
    Réponses: 7
    Dernier message: 23/12/2008, 13h40
  2. cd4017 avec moteur
    Par carxmaster dans le forum Électronique
    Réponses: 2
    Dernier message: 12/12/2006, 13h35
  3. Petit problème sur le phosphore...
    Par verbatim74 dans le forum Chimie
    Réponses: 2
    Dernier message: 02/11/2006, 11h49
  4. petit problème sur l'isomérie Z ou E
    Par vevli dans le forum Chimie
    Réponses: 2
    Dernier message: 01/05/2006, 20h05
  5. Petit problème sur la radioactivité
    Par Misaki013 dans le forum Physique
    Réponses: 1
    Dernier message: 04/02/2005, 20h01
Découvrez nos comparatifs produits sur l'informatique et les technologies.