Répondre à la discussion
Affichage des résultats 1 à 19 sur 19

probleme de reception du capteur CNY70



  1. #1
    jo-electrons

    probleme de reception du capteur CNY70


    ------

    Bonjour, j'avais réalisé un montage avec un capteur (CNY70) monté avec un comparateur inverseur mais j'ai des problemes de reception au niveau de l'emmeteur du phtototransistor ! montage tout droit paru de l'électronique pratique .
    J'ai bau passer un papier de couleur clair(blanc) et foncé(noir) devant il ne réagis pa à part la tension presque inexistante de sa tension de saturation de 0.2V qui n'est pa assez pour que le comparateur bascule !
    Le collecteur étant relié au VCC(5V) bien sur .

    J'ai du passer genre 6h dessus mais la je suis a cour d'idée vraiment e pourtant c'été marqué que ce capteur s'adaptait bien a la situation.

    Merci d'avance

    -----

  2. Publicité
  3. #2
    DAUDET78

    Re : probleme de reception du capteur CNY70

    Je ne peux pas imaginer ton montage. Donc tu donnes un p'tit schéma avec toutes les valeurs des composants et alimentations.
    J'aime pas le Grec

  4. #3
    jo-electrons

    Re : probleme de reception du capteur CNY70

    voila mais ne tient pa compte des 1 ou 0.... la led rouge est relié au CI 16F84A...
    Images attachées Images attachées

  5. #4
    maximilien

    Re : probleme de reception du capteur CNY70

    EP N° 282 avril 2004
    serrure a code-barres?

  6. #5
    jo-electrons

    Re : probleme de reception du capteur CNY70

    page 28 oui c'est celui la

  7. A voir en vidéo sur Futura
  8. #6
    DAUDET78

    Re : probleme de reception du capteur CNY70

    Schéma #3
    Si tu mets un voltmètre aux bornes de R6 tu dois "voir" ton papier blanc ou noir

    Il ne peut pas fonctionner avec un 741
    Utilise un LM324
    J'aime pas le Grec

  9. Publicité
  10. #7
    jo-electrons

    Re : probleme de reception du capteur CNY70

    ah d'accord je vais regarder sa mai bon alors a tension ne va pa sur le 741 mais va a la masse alors?

  11. #8
    DAUDET78

    Re : probleme de reception du capteur CNY70

    Le 741 ne peut pas traiter des informations qui arrivent avec une valeur voisine de sa tension d'alimentation la plus négative (borne ground sur ton schéma)
    J'aime pas le Grec

  12. #9
    jo-electrons

    Re : probleme de reception du capteur CNY70

    oui mais il semble que la tension qu'il devrais avoir a cette patte doit avoisiner les 2 ou 3 volt d'apres ce qu'a dit le constructeur du schema donc je ne sais pa trop...

  13. #10
    DAUDET78

    Re : probleme de reception du capteur CNY70

    Tu mesures QUOI sans réflecteur et avec réflecteur ? On s'en contre-balance du concepteur du schéma! Il est très mauvais pour avoir utilisé un 741 .....
    J'aime pas le Grec

  14. #11
    jo-electrons

    Re : probleme de reception du capteur CNY70

    j'identifie un code barre avec ce schema!!!!!mais un petit détail je n'ai jamais eu 5V sur la patte 2 du 741 ou meme 2 ou 3 V je n'ai que 0.2V!

  15. #12
    DAUDET78

    Re : probleme de reception du capteur CNY70

    Tu retires ton 741 et tu réponds à ma question 10
    Par contre travaille avec une surface noir ou blanche. Lire un code barre avec le CNY70, il y a intérêt à avoir des grosses barres
    J'aime pas le Grec

  16. Publicité
  17. #13
    jo-electrons

    Re : probleme de reception du capteur CNY70

    On m'a donné un TL082 alimentation +5 -5 et comment je peux faire avec des piles de 9V suivie par un regulateur?(2 bien sur)

  18. #14
    DAUDET78

    Re : probleme de reception du capteur CNY70

    Citation Envoyé par jo-electrons Voir le message
    On m'a donné un TL082 alimentation +5 -5 et comment je peux faire avec des piles de 9V suivie par un regulateur?(2 bien sur)
    Comme tu répond pas à ma question #10, je laisse tomber.
    PS Le TLO82 est aussi pire que le 741 dans ce montage
    J'aime pas le Grec

  19. #15
    jo-electrons

    Re : probleme de reception du capteur CNY70

    le probleme est que l'alimentation du CI est de -5 a +5 V et que je n'ai que 5V en tension pour mon circuit .

    Comment pourrais-je avoir +5V -5V chez moi?(sans alimentation acheté...)

    J'ai testé le capteur avec le TL082(ce que j'avais sous la main avant d'aller acheter un LM324) j'ai obtenu 1.5V sur surface claire et noir 0V qui je pense est normal mis pa assez .

    Le probleme pour moi n'est qu'une question d'alimentation du montage étant alimenté à 5V.

  20. #16
    DAUDET78

    Re : probleme de reception du capteur CNY70

    Citation Envoyé par jo-electrons Voir le message
    j'ai obtenu 1.5V sur surface claire et noir 0V qui je pense est normal mis pa assez .
    Mais suffisant pour un LM324 alimenté en 5V
    J'aime pas le Grec

  21. #17
    jo-electrons

    Re : probleme de reception du capteur CNY70

    le LM324 doit s'alimenter en +5 -5V non? parce que dans les datasheets il y a V+ et V-.
    Je comprend pa la

  22. #18
    jo-electrons

    Re : probleme de reception du capteur CNY70

    Ok , j'ai testé le CI en 5volts sa marche seulement maintenant j'ai un autre probleme c'est que la temporisation par rapport au cI 471 n'est je pense plus la meme car par la suite la detecion des lignes de mon code barre passe par un PIC16F84 qui déclanche un relais.
    Pour cela il doit detecter un certain temps entre chaque passe de ces lignes.
    Tres compliqué comme circuit ...moi qui croyais qu'il était simple

  23. Publicité
  24. #19
    just-a-man-but

    Re : probleme de reception du capteur CNY70

    salut.
    jo-electrons je serai trop content si vous postez le schéma complète de votre montage avec tout les valeur des composants et le PIC16F84 et son programme car j'en ai vraiment besoin et c'est urgent

Discussions similaires

  1. aide ppe robot suiveur de ligne:fonctionement capteur CNY70
    Par furstyle dans le forum TPE / TIPE et autres travaux
    Réponses: 15
    Dernier message: 18/02/2013, 23h36
  2. [Brun] probleme reception tv
    Par tbird900 dans le forum Dépannage
    Réponses: 0
    Dernier message: 18/10/2007, 18h52
  3. [Brun] probleme de reception tv
    Par hansol dans le forum Dépannage
    Réponses: 5
    Dernier message: 09/08/2007, 21h02
  4. [PPE] montage avec cny70
    Par domnox dans le forum TPE / TIPE et autres travaux
    Réponses: 7
    Dernier message: 13/05/2007, 13h50
  5. Cny70
    Par DiabloSV dans le forum Électronique
    Réponses: 1
    Dernier message: 18/03/2005, 13h30
Découvrez nos comparatifs produits sur l'informatique et les technologies.