Répondre à la discussion
Page 1 sur 2 1 DernièreDernière
Affichage des résultats 1 à 30 sur 43

commande de relais qui détruit les uC



  1. #1
    Jeangouytch

    commande de relais qui détruit les uC

    Bonjour

    Je cherche a commander un relais avec un pic. Il s'agit d'un relais 5V dont la bobine à une resistance de 70ohm

    Dans un souci de compacité du circuit et de simplicité, je commande le relais directement avec les sorties du pics. J'ai donc mis 4 pattes du portB en parallele.

    A vide, tout a l'air de fonctionner correctement, mais si je met une charge sur la sortie du relais, le montage marche quelques temps puis le PIC crame ...

    Je pourrais comprendre que la maniere de commander le relais directement avec les sortie en parrallele puisse poser probleme, mais j'ai bcp de mal a saisir en quoi la présence ou non d'une charge sur le relais provoque le probleme...

    Merci d'avance pour vos lumieres

    -----


  2. Publicité
  3. #2
    alainav1

    Re : commande de relais qui détruit les uC

    bonjour,
    le relais commande t il un equipement qui prend la tension sur la même ailmentationdu pic ?
    as tu une diode de roue libre sur le relais?
    pourquoi ne pas utiliser un transistor sur une sortie
    les sorties en // c'est pas le top !
    cordialement
    Alain

  4. #3
    gienas

    Re : commande de relais qui détruit les uC

    Bonjour Jeangouytch et tout le groupe

    Citation Envoyé par Jeangouytch Voir le message
    ... Il s'agit d'un relais 5V dont la bobine à une resistance de 70ohm ...
    Ce qui fait un courant de 71 mA.

    Citation Envoyé par Jeangouytch Voir le message
    ... J'ai donc mis 4 pattes du portB en parallele ...
    Ce qui fait 18 mA par sortie, si c'est bien équilibré. Je doute qu'une sortie le permette.

    As-tu au moins mis la diode de roue libre indispensable? Sans elle, le relais ne fonctionnera qu'une fois

    Citation Envoyé par Jeangouytch Voir le message
    ... A vide, tout a l'air de fonctionner correctement, mais si je met une charge sur la sortie du relais, le montage marche quelques temps puis le PIC crame ...
    Moi non plus, mais qu'est ce que charge signifie? N'y a-t-il pas réinjection d'alimentation ou au contraire chute (ou modification) de l'alim?

    Je te suggère d'essayer de commander le relais en direct sur son alim, en déconnectant les 4 sorties, puis en simulant le relais par 70 ohms. Attention, la diode est là aussi obligatoire, si tu mets un interrupteur pour piloter manuellement le relais.


    Edit: grillé par alainav1 avec qui je suis d'accord

  5. #4
    chatelot16

    Re : commande de relais qui détruit les uC

    si tu a du mal a comprendre en voyant tout ton montage comment veux tu qu'on le devine si tu ne nous montre rien

    aditioner 4 sortie pour faire plus de courant c'est pas tres bon mais ca peu marcher , le courant dans une bobine de relais ne depand pas de la charge du relais

    mais quelle est la charge du relais ? quel est le circuit ? il y a certainement un retour de la charge vers l'alimentation du pic

  6. #5
    Ouk A Passi

    Re : commande de relais qui détruit les uC

    Bonjour,

    Dans un souci de compacité du circuit et de simplicité, je commande le relais directement avec les sorties du pics


    Dans un souci de simplicité, j'estime qu'il est préférable de n'utiliser qu'une seule
    sortie pour polariser la base d'un transistor tout à fait apte, lui, à supporter le courant
    de commande du relais.

  7. A voir en vidéo sur Futura
  8. #6
    Jeangouytch

    Re : commande de relais qui détruit les uC

    merci pour vos réponses

    J'ai bien mis une 4148 en roule libre aux bornes de la bobine du relais
    La charge que je commute est une simple ampoule 40W en 220V.

    la commande en direct sans le pic fait bien commuter le relais. Avec le pic, et en controllant au volmetre, sans charge, ca commute aussi sans probleme.

    D'apres mon datasheet (16f628), je peux tirer 25mA par sortie, donc je devrait etre dans les clous a priori.

    Ok, c'est pas tres propre et un transistor serait préférable. Je vais d'ailleurs refaire le montage, Mais j'aimerai tout de meme comprendre ce qui se passe.

    Que peux il se passer du coté de l'alim ? Comment pourrais je controller ?

    voici mes schémas, désolé c'est pas tres propre

    pjlch0jq.jpg

    tfcpc7r2.jpg


    Pour la durée de vie des images, pour éviter les pubs inutiles et les virus associés, il convient de placer les images sur le serveur. J'ai dû un peu réduire la taille du premier, pour satisfaire les exigences du serveur.
    Images attachées Images attachées
    Dernière modification par gienas ; 21/03/2008 à 18h27.

  9. Publicité
  10. #7
    Jeangouytch

    Re : commande de relais qui détruit les uC

    et voici le shéma d'implantation si cela peut vous eclairer :

    g6p8zlhb.jpg
    Images attachées Images attachées
    Dernière modification par gienas ; 21/03/2008 à 18h32. Motif: Même punition pour la PJ, réduite

  11. #8
    gienas

    Re : commande de relais qui détruit les uC

    Citation Envoyé par Jeangouytch Voir le message
    ... Mais j'aimerai tout de meme comprendre ce qui se passe ...
    Je trouve gonflé (le mot est faible), de faire ainsi cohabiter le 230V avec les pattes du CI. Sans compter qu'on ne sait pas ce qui se passe, pour de vrai, du côté des tripes du relais.

    La prudence, c'est de mettre une interface, bien moins fragile, pour faire le "travail".


    Edit: un minimum, fut-ce pour le sentiment du devoir accompli, eut été de mettre une piste de masse, entre les fils secteur et les pattes di CI. Mais là, je n'aurais pas osé.

  12. #9
    Jeangouytch

    Re : commande de relais qui détruit les uC

    Je suis désolé, je suis un grand débutant en electronique, je ne comprend pas la remarque ...
    C'est la distance qui est trop courte ?

    Le relais est donnée pour 7A à 230V

    Quel est le probleme avec le 220 ? Comment aurais-je du m'y prendre ?

  13. #10
    gienas

    Re : commande de relais qui détruit les uC

    Citation Envoyé par Jeangouytch Voir le message
    ... Quel est le probleme avec le 220 ? ...
    Déjà, c'est plus 220, depuis longtemps, mais 230.

    Le secteur, c'est dangereux, c'est de la "dynamite", avec plein de parasites, qui ne demandent qu'à amorcer.

    Un PIC, avant de démarrer, est à considérer comme "rien que des entrées haute impédance". La mise en service du secteur peut, par couplage capacitif, faire apparaître des tensions destructives avant de démarrer.

    Citation Envoyé par Jeangouytch Voir le message
    ... Comment aurais-je du m'y prendre ?
    J'ai déjà répondu.

    1- bien séparer les circuits BT et HT, et utiliser un transistor pour commander le relais.

    2- mettre de la distance entre le secteur et les pattes, et intercaler une piste à la masse, qui va "récolter" les parasites, et les écouler à la masse.

    3- 1 + 2 ci-dessus, c'est le top.

  14. #11
    Jeangouytch

    Re : commande de relais qui détruit les uC

    ok merci

    Les parasites en question peuvent ils etre responsables de la destruction du controlleur ?

    Un plan de masse sur la partie BT pourrait il aider avec ce probleme ?

    EDIt : ta remarque vaut pour les probleme de perturbation, c'est ok niveau sécurité sinon ? tu m'as fait peur
    Dernière modification par Jeangouytch ; 21/03/2008 à 19h00.

  15. #12
    gienas

    Re : commande de relais qui détruit les uC

    Citation Envoyé par Jeangouytch Voir le message
    ... Les parasites en question peuvent ils etre responsables de la destruction du controlleur ? ...
    Je ne sais pas ce qui détruit. Il se peut qu'il y ait une autre "communauté", non apparente sur les schémas, qui ne sont qu'en 2D, alors que le montage fonctionne en 3D

    Citation Envoyé par Jeangouytch Voir le message
    ... Un plan de masse sur la partie BT pourrait il aider avec ce probleme ? ...
    Je ne pense pas. Ce qu'il faut, c'est séparer tout ce qui touche au PIC, (la BT), des fils du secteur, potentiellement dangereux, c'est le cas de le dire: c'est le loup dans la bergerie.

    La piste séparatrice, qui n'est qu'en 2D, crée un blindage.

    Citation Envoyé par Jeangouytch Voir le message
    ... ta remarque vaut pour les probleme de perturbation, c'est ok niveau sécurité sinon ? ...
    Si le fonctionnement est assuré, pourquoi pas. Je me méfie,cependant. Un relais, c'est fait pour commuter. Y a-t-il des commutations pendant le fonctionnement? Si oui, quels sont les charges commutées? Si elles sont selfiques, qu'il y a des étincelles, preuve de HT, c'est une source de parasites violents trop proches. Peut-être faut-il ajouter des antiparasites RC sur le contact. Mais là, nous ne savons rien.

    Citation Envoyé par Jeangouytch Voir le message
    ... tu m'as fait peur
    Heu, toi aussi

  16. Publicité
  17. #13
    jiherve

    Re : commande de relais qui détruit les uC

    Citation Envoyé par Jeangouytch Voir le message
    Bonjour

    Je cherche a commander un relais avec un pic. Il s'agit d'un relais 5V dont la bobine à une resistance de 70ohm

    Dans un souci de compacité du circuit et de simplicité, je commande le relais directement avec les sorties du pics. J'ai donc mis 4 pattes du portB en parallele.

    A vide, tout a l'air de fonctionner correctement, mais si je met une charge sur la sortie du relais, le montage marche quelques temps puis le PIC crame ...

    Je pourrais comprendre que la maniere de commander le relais directement avec les sortie en parrallele puisse poser probleme, mais j'ai bcp de mal a saisir en quoi la présence ou non d'une charge sur le relais provoque le probleme...

    Merci d'avance pour vos lumieres
    Bonsoir
    Tout ceci mérite le bûcher tellement c'est hérétique !
    1 : on ne commande JAMAIS un relais avec la sortie d'un µ ni avec un groupe de sorties, toujours isoler le cerveau des muscles.
    2 : Une 1N 4148 c'est une diode de signal non adaptée à l'usage qui en est fait il faut une 1N4004 ou équivalent.
    3 : on ne connecte pas en // des sortie logiques à moins qu'elles ne soient configurées en open drain et même là c'est olé olé!
    4 : comme il n'y a aucune protection ni écran entre le pauvre pic et le secteur il y a fort à parier que des courants de surface issus de la zone 220 viennent le chatouiller et il en meurt de rire.
    JR
    PS : CI bien fait et c'est en forgeant que l'on devient forgeron !

  18. #14
    Toufinet

    Re : commande de relais qui détruit les uC

    Citation Envoyé par gienas Voir le message
    Bonjour Jeangouytch et tout le groupe

    Ce qui fait un courant de 71 mA.

    Ce qui fait 18 mA par sortie, si c'est bien équilibré. Je doute qu'une sortie le permette.
    << je fais confiance à gienas pour les calculs >>

    Pour moi ça fait nul doute que le problème vient de là.
    1° t'es en limite des ABSOLUTE maximum rating
    2° chaque sortie n'est sans doute pas équivalente, et la moindre différence de tension de sortie entre les 4 pins peut engendrer très facilement un courant supérieur à 20mA sur une des 4 pins ...

    PS : j'ai pas regardé la datasheet, mais je suppose que ton PIC possède les mêmes caractéristiques que "tous" les autres, à savoir un courant absolument maximal de 20mA sur une pin en sortie.

  19. #15
    Jeangouytch

    Re : commande de relais qui détruit les uC

    Citation Envoyé par jiherve Voir le message
    Bonsoir
    Tout ceci mérite le bûcher tellement c'est hérétique !
    1 : on ne commande JAMAIS un relais avec la sortie d'un µ ni avec un groupe de sorties, toujours isoler le cerveau des muscles.
    2 : Une 1N 4148 c'est une diode de signal non adaptée à l'usage qui en est fait il faut une 1N4004 ou équivalent.
    JR
    PS : CI bien fait et c'est en forgeant que l'on devient forgeron !
    Je viens de constater que la 4148 était effectivement cramée ...
    J'ai remplacée par une 1N5819 et tout fonctionne maintenant ..
    La 4004 que tu propose n'est elle pas trop "lente" pour cette utilisation ?


    En tout cas, ça aura été l'occasion d'apprendre des choses. Merci a tous

  20. #16
    gienas

    Re : commande de relais qui détruit les uC

    Citation Envoyé par Jeangouytch Voir le message
    Je viens de constater que la 4148 était effectivement cramée ...
    Cramée, ici, doit vouloir dire coupée. C'est vrai que c'est très imprudent, mais, pour de telles intensités, non répétitives, cela devrait tenir un peu. Je soupçonne une destruction au montage ou accidentelle, plutôt qu'une coupure due au courant, fut-il d'extrarupture, égal au courant antérieur.

    Citation Envoyé par Jeangouytch Voir le message
    ... La 4004 que tu propose n'est elle pas trop "lente" pour cette utilisation ? ...
    Elle y a fait ses preuves

    Citation Envoyé par Jeangouytch Voir le message
    ... En tout cas, ça aura été l'occasion d'apprendre des choses ...
    Ce n'est qu'un début, la liste sera longue

  21. #17
    chatelot16

    Re : commande de relais qui détruit les uC

    La 4004 que tu propose n'est elle pas trop "lente" pour cette utilisation ?
    pourquoi aurai tu besoin de vitesse , depuis quand un relais est un truc plus rapide que n'importe quelle diode

    ce qui m'inquiete c'est que la 1N4148 grille aussi : elle est faible mais devrais tenir : c'est bien le signe qu'il se passe quelque chose coté 220 qui revient coté basse tension

    il y a de la capacité parasite a l'interieur d'un relais : ca peut donc envoyer des pointe de courant non limité en tension , l'impedance inductive de la bobine de relais n'empeche pas la tension , ca ne fait pas peur a la sortie d'un transistor , ca peut etre trop pour une sortie de pic

    en plus si il faut commander quelque chose en mettant plusieur sortie en // il vaut mieux mettre la bobine au + et commander par les sortie qui tirent au - : les transistor au - des sortie sont plus solides

  22. #18
    gienas

    Re : commande de relais qui détruit les uC

    Citation Envoyé par chatelot16 Voir le message
    pourquoi aurai tu besoin de vitesse , depuis quand un relais est un truc plus rapide que n'importe quelle diode ...
    Je crois avoir compris que la crainte de Jeangouytch ne portait pas sur le temps de réponse du relais, que la diode n'influence pas, mais sur le temps de réponse de la protection, lors de l'inversion de tension, qui pourrait occasionner une surtension intolérable.

    Le montage est-il unique, ou y at-il plusieurs exemplaires, présentant le même défaut, la même coupure de 1n4148? (à laquelle je ne crois pas trop).

  23. Publicité
  24. #19
    chatelot16

    Re : commande de relais qui détruit les uC

    une diode meme lente n'a pas de temps de retard a la conduction donc protege aussi bien

    la lenteur d'une diode c'est le temps de recouvrement : quand la diode est mise en inverse elle continue a conduire un certain temps a l'envers avant de se bloquer : c'est tres nuisible pour une alim a decoupage , c'est negligable pour un relais ou un redressement 50hz

  25. #20
    Jeangouytch

    Re : commande de relais qui détruit les uC

    Oui, c'est bien cela. J'avais cru comprendre que les diodes de redressement secteur commutaient lentement et que ca pouvait etre génant pour absorber une extra rupture de courant ...

    En tout cas, avec la shottky que j'ai mise a la place de la 1N4148, ca marche depuis une heure ...

  26. #21
    Ouk A Passi

    Re : commande de relais qui détruit les uC

    Bonjour,

    ca marche depuis une heure
    Techniquement parlant, cela ne me semble toujours pas être la meilleure solution!

  27. #22
    Jeangouytch

    Re : commande de relais qui détruit les uC

    Citation Envoyé par Ouk A Passi Voir le message
    Bonjour,



    Techniquement parlant, cela ne me semble toujours pas être la meilleure solution!
    Pas d'inquietude, le message est bien passé :
    transistor et blindage ... mais je suis content d'avoir compris pourquoi je claquais les circuit à la chaine

  28. #23
    gienas

    Re : commande de relais qui détruit les uC

    Bonjour Jeangouytch et tout le groupe

    Citation Envoyé par Jeangouytch Voir le message
    ... mais je suis content d'avoir compris pourquoi je claquais les circuit à la chaine
    Hum! Je suis un peu plus partagé, et moi, je ne m'explique pas, en me référant à tes constatations.

    La diode est indispensable, pour la coupure du relais. Son absence, est généralement mortelle, à la première coupure du courant de la bobine.

    Or, je crois avoir noté que tout se passait bien, en apparence, tant que le secteur n'était pas présent sur la carte. Sans que l'on sache s'il y avait eu ou non des commutations de la bobine, qui auraient été mortelles, sans la diode.

    L'apparition de ce secteur entraînait une surchauffe du circuit, qui, si je suis bien, finissait par rendre l'âme. A moins que ce soit la présence du secteur qui amorce les commutations du relais, je ne vois pas en quoi, le rétablissement seul de la protection par la diode, permet le fonctionnement.

    Si j'ai mal compris, merci de me rétablir dans la vérité, ou de compléter par une information qui manque.

  29. #24
    Ouk A Passi

    Re : commande de relais qui détruit les uC

    Bonjour,

    Pensez-vous que quatre sorties d'un pic puissent être rendues simultanément passantes?
    (par simultanément, j'entends une duré inférieure à la milli-seconde, ou même µs)

  30. Publicité
  31. #25
    maxitec

    Re : commande de relais qui détruit les uC

    Bonjour,
    Ce qui est sûr gienas, c'est que la commutation par relais, d'une charge importante reliée au 230v secteur, perturbe le fonctionnement des circuits logiques (cmos et ttl).

  32. #26
    annjy

    Re : commande de relais qui détruit les uC

    Bonjour,
    mais pourquoi diable refuser de mettre un transistor pour commander le relais ????
    c'est tout de même assez simple ! (même pour les calculs....)
    et beaucoup moins risqué que 4 sorties en parallèle!!!!

    A+,
    JY

  33. #27
    freepicbasic

    Re : commande de relais qui détruit les uC

    un moc3041 et un triac couterait sans doute moins cher et le montage serait parfaitement sécurisé...

    Enfin, chacun fait ce qu'il lui plait.
    A+, pat

  34. #28
    daripo38

    Re : commande de relais qui détruit les uC

    Il y a un oubli dans ce schema, c'est une capacité de découplage sur le 5V !!!!
    Et le plus proche des broches d'alim du PIC (5 et 14 je crois).

    Et effectivement un transistor pour commander le relais 12V alimenté par C3 serait beacoup mieux, ca eviterait de chauffer inutilement le regulateur série 7805.

    Pour la proximité du secteur, il faut normalement respecter une distance minimal de 6.4mm pour être conforme aux norme de sécurité entre tout potentiel coté secteur et tout potentiel coté secondaire du transformateur (IEC 950 isolation renforcé) si quelqu'un peut toucher le secondaire. Si le montage est dans une boite fermé, une isolation fonctionnelle de 2mm suffit largement.

  35. #29
    Jeangouytch

    Re : commande de relais qui détruit les uC

    ALors, pour justifier mon choix, je n'ai pas de formation en électronique. C'est un loisir que je pratique en autodidacte ... ca m'ammene donc a tester naivement des trucs qui vous font peut être dresser les cheveux sur la tête.

    bref.

    Pour répondre a Genias. C'est pas la présence du secteur qui pose probleme mais bien celle de la charge. Je pense que ca a fonctionné jusqu'au claquage de la diode et qu'ensuite j'ai cramé le proc.

    Ce qui est etrange, c'est que sans charge et sans diode ca passe, mais que sans diode et avec la charge ca claque ...

    Finalement, avec charge et avec une diode adaptée ca fonctionne très bien (depuis 12h maintenant)

    Enfin, pour répondre a Ouk A Passi, mes 4 sortie appartient au meme port. Elles sont donc commutée par la meme instruction. Avec un proc a 4Mhz, l'idée d'une synchro a la milliseconde ne me parait pas choquante ..
    Dernière modification par Jeangouytch ; 22/03/2008 à 17h27.

  36. #30
    gienas

    Re : commande de relais qui détruit les uC

    Citation Envoyé par Jeangouytch Voir le message
    ALors, pour justifier mon choix, je n'ai pas de formation en électronique ...
    Ceci explique tes "mauvais choix", et j'ai bien noté que tu t'engageais à tenir compte des excellents conseils qui ont été donnés ici

    Citation Envoyé par Jeangouytch Voir le message
    ... Pour répondre a Genias ...
    Tes réponses sont "un peu" incomplètes

    Citation Envoyé par Jeangouytch Voir le message
    ... C'est pas la présence du secteur qui pose probleme mais bien celle de la charge ...
    Il faudrait donc en savoir un peu plus:

    1- quelle nature ? (inductive ou non)

    2- son intensité.

    3- la fréquence des commutations.

    4- ces commutations ont-elles lieu sans la charge?

    Je n'arrive pas à croire que des commutations de la bobine soient sans conséquence, s'il n'y a pas de diode. Donc, je réfute un fonctionnement (normal, sans destruction) sans charge, avec des commutations, qui devraient être mortelles à chaque coupure.

    Je conclus que ce n'est pas la présence du secteur qui nuit, mais des parasites générés sur le contact (étincelles, mais peut-être invisibles si relais opaque). Un antiparasitage serait peut-être bienvenu. Le problème n'existerait pas avec un MOC à détection de zéro.

    Par contre, je suis un peu sec sur le "miracle" de la diode davantage indispensable avec la charge. Je n'ai pas d'idée

Sur le même thème :

Page 1 sur 2 1 DernièreDernière

Discussions similaires

  1. commande relais
    Par benou.1 dans le forum Électronique
    Réponses: 5
    Dernier message: 03/03/2008, 14h04
  2. Commande de relais !!!
    Par darkmen dans le forum Électronique
    Réponses: 1
    Dernier message: 08/11/2007, 21h05
  3. commande relais
    Par nonoff89 dans le forum Électronique
    Réponses: 11
    Dernier message: 29/05/2006, 22h07
  4. relais commandé
    Par gwendoline dans le forum Électronique
    Réponses: 6
    Dernier message: 14/07/2005, 12h54
  5. Commande de relais. (Help)
    Par Monsieur-Patate dans le forum Électronique
    Réponses: 6
    Dernier message: 23/03/2004, 13h48