Répondre à la discussion
Affichage des résultats 1 à 2 sur 2

Problème en simulation sous MPLAB!



  1. #1
    darkmall

    Exclamation Problème en simulation sous MPLAB!


    ------

    Bonjour à tous

    Voilà j'ai un soucis en prog. j'obtiens quelque chose de bizard quand je simule mon programme.

    Avant de rentré dans mon sous programme "aff_valeur" je place dans W la valeur que je souhaite afficher, mais le problème c'est que quand j'ai trouvé la valeur à afficher mon programme par dans les chou et ce retrouve en plein milieu de mon sous-programme d'interruption..!?!?

    Voili les images: sur l'image "prob_mplab" on voit ou je fais la soustraction et sur l'image "prob_mplab1" c'est ou je me retrouve à l'instruction d'après....

    Tout ce que je veux c'est une fois que j'ai trouvé ma valeur a afficher je vais à Aff_x.

    Ne vous inquieter pas le sous-programme "aff_valeur" n'est pas terminé donc normal qu'il n'y ai pas la gestion du cas ou la valeur n'est ni 1ni2 ni3!

    C'est uniquement la soustraction de 2 qui embête car le programme test correctement les autres valeurs. Mais si j'ai 4 dans W mon programme plante arriver à sublw .4,temp:!??!'

    Merci beaucoup de votre aide, je ne vois pas pk il m'arrive cela!?

    A+

    -----
    Images attachées Images attachées

  2. #2
    darkmall

    Re : Problème en simulation sous MPLAB!

    J'ai trouvé!

    c'est fait ca :

    movwf nb_save
    sublw .9 ; Es que la valeur a afficher est 9?
    btfsc STATUS,Z
    goto aff_9 ; oui
    movf nb_save,W
    sublw .8 ; Es que la valeur a afficher est 8?
    btfsc STATUS,Z
    goto aff_8 ; oui
    .
    .
    .
    .
    etc....

    Je pense que vous vous enfoutez mais on sais jamais, peut être que quelqu'un en aura besoin....un jour!

    A+

Discussions similaires

  1. Pb MPLAB Simulation
    Par jorg1n dans le forum Électronique
    Réponses: 3
    Dernier message: 27/07/2010, 08h15
  2. Créer un programme en multi-fichiers sous MPLAB?
    Par darkmall dans le forum Électronique
    Réponses: 13
    Dernier message: 06/09/2008, 19h59
  3. simulation sous proteus (probleme dans mon montage ?)
    Par black templar dans le forum Électronique
    Réponses: 9
    Dernier message: 05/05/2008, 21h54
  4. simulation changement d'état sur entrée MPLAB
    Par arzew dans le forum Électronique
    Réponses: 0
    Dernier message: 18/03/2008, 17h08
  5. Problème de simulation sous simulink
    Par Liun971 dans le forum Électronique
    Réponses: 10
    Dernier message: 18/05/2006, 22h03
Découvrez nos comparatifs produits sur l'informatique et les technologies.