Répondre à la discussion
Affichage des résultats 1 à 10 sur 10

Apparition d'un offset en sortie de mon AOP



  1. #1
    kylexy

    Apparition d'un offset en sortie de mon AOP

    Bonjour,

    Je n'arrive pas à comprendre ce comportement étrange. J'utilise un AOP en mode linéaire pour amplifier un signal mais en sortie j'ai l'apparition d'un offset en plus de mon signal amplifié. J'ai tenté de simuler ma structure sur Proteus mais sa sature... Bref : vous êtes les seuls qui peuvent me dire pourquoi un offset apparait.

    Voici mon schema simplifié (comme on travail en haute fréquence, j'ai remplacé les condensateurs par des fils) :


    Mon signal Vsin est une tension sinusoïdale d'amplitude 100mV et de fréquence 21kHz.
    Mon signal Vs est une tension sinusoïdale d'amplitude 5,1V et a un offset de 7,5V. Et c'est l'apparition de cette offset qui me dérange !

    Merci.

    -----


  2. Publicité
  3. #2
    Jack

    Re : Apparition d'un offset en sortie de mon AOP

    Avant de se lancer, je ne vois pas comment tu vas amplifier du sinusoidal avec un ampli alimenté en unipolaire.

    Pour les futurs schéma, merci de respecter ceci:
    http://forums.futura-sciences.com/el...-sabonner.html

    A+

  4. #3
    kylexy

    Re : Apparition d'un offset en sortie de mon AOP

    Bonjour,

    D'accord pour les images. J'avais pensé que c'était une bonne idée de faire sa car l'autre jour mon image avait pris du temps avant d'être publiée et les visiteurs ne la voient pas pendant ce temps.

    Sinon, pour l'alimentation de mon AOP c'est bien une alimentation unipolaire avec la présence d'un condensateur de découplage.

    Et le pire c'est qu'en condition réel (j'ai pris une capture) cela fonctionne ! Mais il y a un offset qui se rajoute.

  5. #4
    Jack

    Re : Apparition d'un offset en sortie de mon AOP

    J'avais pensé que c'était une bonne idée de faire sa car l'autre jour mon image avait pris du temps avant d'être publiée et les visiteurs ne la voient pas pendant ce temps.
    Tu as raison, mais de cette manière le fil peut être relu à tout moment puisque les images restent conservées, ce qui n'est pas garanti avec les serveurs d'image

    Sinon, pour l'alimentation de mon AOP c'est bien une alimentation unipolaire avec la présence d'un condensateur de découplage.
    Faudrait voir comment est connecté ce condo. S'il est simplement en série avec R3, il y aura un problème car il ne pourra pas se charger en raison de la grande impédance d'entrée de l'ampli.

    A+

  6. #5
    kylexy

    Re : Apparition d'un offset en sortie de mon AOP

    Merci pour ton aide.

    Ci-dessous, l'image du montage complet (sa sera surement plus simple en ayant toutes les informations) :
    schema-aop.gif

    Donc, tu peut remarquer le condensateur C1 qui est un condensateur de découplage placé aux bornes de l'alimentation de l'AOP.

    Sinon, je viens de tester cette structure complète et par simulation sa ne sature plus du tout ! Sa fonctionne comme en condition réel sauf que l'offset est ici de 6V environ.

    Donc ce ne serait pas l'AOP qui ajoute un offset mais ma structure a coté ? Car on peut remarquer que la tension aux bornes de R8 devrait être de 6V (12V/2). Mais bon, d'après mon le TP que j'ai fait, sa tension devrait être de 0V puisque l'on considère un condensateur en haute fréquence comme un fil.

    Merci.

  7. A voir en vidéo sur Futura
  8. #6
    Jack

    Re : Apparition d'un offset en sortie de mon AOP

    R8 et R9 créent un point milieu de 6V afin de pouvoir superposer l'alternatif. C'est comme si l'ampli était alimenté en +/-6V par rapport à ce point milieu. Pas étonnant que la sortie soit centrée autour de 6V.

    Heureusement d'ailleurs, car comment voulais-tu obtenir les alternances négatives en sortie de l'ampli.

    A+

  9. Publicité
  10. #7
    kylexy

    Re : Apparition d'un offset en sortie de mon AOP

    Merci, c'est exact !

    Ah : les hypothèses dans les TPs. lol

  11. #8
    louloute/Qc

    Re : Apparition d'un offset en sortie de mon AOP

    Vu que l’entrée inverseuse de ton AOP est découplée, tu ne devrais lire ne sortie que l’offset d’entrée, même pas amplifié par ton gain en tension de 50.

    Malgré tout, à l’offset des entrées s’additionne la perte dans la 100k du courant de polarisation d’entrée (900nA), ce qui donne tout de même 90mV.
    男人不坏,女人不爱

  12. #9
    Jack

    Re : Apparition d'un offset en sortie de mon AOP

    Mais vs est bien centrée autour de 6V, d'où "l'offset".

    A+

  13. #10
    louloute/Qc

    Re : Apparition d'un offset en sortie de mon AOP

    Correction sur mon post précécent:

    en y regardant de plus près le courant moyen d’entrée se compense du fait de R7 = R2; seul l’offset en courant provoque une différence avec le 6V nominal de 100k x 120nA = 12mV, pour être pessimiste on peut y ajouter les Je lis dans les 0,6mV d’offset en entrée pour un grand total de 12,6mV d’offset max en sortie.
    男人不坏,女人不爱

Sur le même thème :

Discussions similaires

  1. Courant de sortie d'un AOP
    Par la frite dans le forum Physique
    Réponses: 7
    Dernier message: 13/09/2008, 15h22
  2. sortie d'un AOP soustracteur
    Par fly91 dans le forum Électronique
    Réponses: 9
    Dernier message: 08/09/2008, 14h28
  3. Sortie d'un AOP cable en suiveur
    Par Nikko485 dans le forum Électronique
    Réponses: 3
    Dernier message: 11/03/2008, 20h21
  4. impédance de sortie d'un AOP
    Par bair75 dans le forum Électronique
    Réponses: 6
    Dernier message: 09/02/2007, 09h56
  5. offset AOP de 11v !!!
    Par Jraf78 dans le forum Électronique
    Réponses: 5
    Dernier message: 05/08/2006, 12h39