Répondre à la discussion
Affichage des résultats 1 à 14 sur 14

dspic: fonctionnement avec pickit mais pas alim externe



  1. #1
    olver62

    dspic: fonctionnement avec pickit mais pas alim externe


    ------

    bonjour,
    j'ai réalisé un montage avec un dspic33FJ12MC201, le code a été réalisé avec pic C compiler, programmé avec pickit2.
    Dès que je clique sur "on" dans le logiciel du pickit, tout fonctionne normalement, mais lorsque je retire le pickit2 et met une alimentation extérieur (5V régulée en 3.3 pour le dspic) rien ne se passe.
    Le quartz n'oscille pas mais les tensions mesurées sont les même qu'avec le pickit (alim, MCLR) donc je ne vois pas d'où vient le problème...
    quelqu'un aurait une solution?

    merci d'avance
    Olivier

    -----

  2. Publicité
  3. #2
    olver62

    Re : dspic: fonctionnement avec pickit mais pas alim externe

    personne n'a jammais eu le tour...?
    pensant à un problème au niveau du quartz, j'ai reprogrammé avec l'oscillateur interne, mais le problème persiste lorsque je retire le pickit...
    je voulais aussi dire que je n'ai pas mis le condensateur de 0.1µF comme l'indique le site de microship (au niveau du MCLR) car je n'en avais pas sous la main. J'ai essayé avec une capacité plus grande, plus rien ne fonctionnait, et une plus petite n'améliorait pas le fonctionnement...

    merci d'avance
    Olivier

  4. #3
    olver62

    Re : dspic: fonctionnement avec pickit mais pas alim externe

    personne....???

  5. #4
    Qristoff
    Animateur Électronique

    Re : dspic: fonctionnement avec pickit mais pas alim externe

    Bonsoir,
    le MCLR est il tiré au 3,3V avec une résistance de pull-up ?(independamment de la capacité)
    Tout existe, il suffit de le trouver...!

  6. A voir en vidéo sur Futura
  7. #5
    olver62

    Re : dspic: fonctionnement avec pickit mais pas alim externe

    Bonsoir, merci d'avoir répondu!!

    le MCLR est tirré au 3.3V avec une resistance de pull up (1Kohm) une capacité de 100nF relie aussi le MCLR à la masse (j'en ai trouvé une, mais il n'y a aucun changement).
    j'ai aussi supposé un problème dans la programmation, une mauvaise déclaration d'un fusibles peut provoquer ce genre de disfonctionnement? (sachant que le programme tourne avec le pickit cela m'étonnerais...)
    sinon j'ai bien testé toute les pates, les soudures sont bonnes et j'ai les bonnes tensions (3.28V) le regulateur interne du dspic donne bien du 2.5V.

    merci
    Olivier

  8. #6
    Qristoff
    Animateur Électronique

    Re : dspic: fonctionnement avec pickit mais pas alim externe

    Le Pickit ne fournit pas du 5V à la carte cible normalement ?
    Tout existe, il suffit de le trouver...!

  9. Publicité
  10. #7
    olver62

    Re : dspic: fonctionnement avec pickit mais pas alim externe

    La tension de sortie du pickit peut être réglée entre 0 et 5V avec une précision de 0.1V (après étalonage). J'ai réglé mon pickit pour qu'il envoie du 3.3V au montage. Pour les tests, laisser le pickit branché ne me gène pas, mais dans mon projet, il y aurra 3 cartes identiques, donc impossible d'utiliser 3 pickits... lol
    j'avais programmé un pic 16F876A avec ce pickit, et tout fonctionnait normalement. Je suis en manque d'idée pour trouver ce qui ne va pas...
    petite question en passant, si la mise sous tension n'est pas franche, le pic demarre quand même?

    Merci
    Olivier

  11. #8
    Qristoff
    Animateur Électronique

    Re : dspic: fonctionnement avec pickit mais pas alim externe

    si la mise sous tension n'est pas franche, le pic demarre quand même?
    oui, ça peut effectivement créer des états bizarres
    Tout existe, il suffit de le trouver...!

  12. #9
    Qristoff
    Animateur Électronique

    Re : dspic: fonctionnement avec pickit mais pas alim externe

    Tu peux me montrer le schéma de ton régulateur avec les valeurs de condensateur et de l'interface programmation pour être sûr qu'il n'y a pas de coquille ?
    Tout existe, il suffit de le trouver...!

  13. #10
    olver62

    Re : dspic: fonctionnement avec pickit mais pas alim externe

    voici le schémas en pièce jointe. si vous voulez plus précisions, je suis à votre disposition
    merci
    Olivier
    Images attachées Images attachées  

  14. #11
    olver62

    Re : dspic: fonctionnement avec pickit mais pas alim externe

    le connecteur du pickit est le J4.
    pour les test, le regulateur LM317 GT n'est pas mis, une tension de 12V est apliqué à l'entrée des deux regulateurs (7805 et le 3,3).
    Merci
    Olivier

  15. #12
    Qristoff
    Animateur Électronique

    Re : dspic: fonctionnement avec pickit mais pas alim externe

    Maintenant que le fichier est visible, c'est mieux !
    Il n'y a AUCUN condensateur de découplage sur tes alims !
    Il faut au moins quelques microfarad en sortie des deux régulateurs 7805 et NCP, place des condensateurs tantales de 3,3µF en paralléles avec 100nF sur l'alimentation du dsPIC.
    Avec le pickit connecté, il est probable que le filtrage était fait par le pickit et non pas par ta carte !
    Tout existe, il suffit de le trouver...!

  16. Publicité
  17. #13
    olver62

    Re : dspic: fonctionnement avec pickit mais pas alim externe

    Je n'ai qu'une chose à dire, merci beaucoup!!
    La carte fonctionne avec la capa que j'ai rajouté (220µ car je n'avais que ca sous la main) je n'avais pas mis de condensateur à la sortie des regulteurs car dans la datasheet du dspic il était indiqué qu'il possède un regulateur interne et que la tension d'entrée ne devait pas forcement être filtrée. Mais bon, mieux vaut en mêtre un, ca ne fait de mal à personne...

    Pour le regulateur 7805, il est retiré du montage, le 3.3V suffit.

    encore merci et bonne soirée
    Olivier

  18. #14
    Qristoff
    Animateur Électronique

    Re : dspic: fonctionnement avec pickit mais pas alim externe

    Il faut toujours mettre un condensateur en sortie d'un régulateur lineaire (220µF c'est un peu trop pour ton montage !) car un régulateur est un systéme asservi, et le condensateur permet de stabiliser la boucle de régulation, on a déja vu des régulateurs partir en oscillation et tuer tout ce qu'il y avait derriére ! PIC compris..

    Donc, je te conseille d'en mettre sur les deux régulateurs ! 10µF c'est bien
    Tout existe, il suffit de le trouver...!

Discussions similaires

  1. [Brun] TV Plasma SAMSUNG ne s'allume pas ! mais carte alim nickel !
    Par Fox5150 dans le forum Dépannage
    Réponses: 37
    Dernier message: 10/04/2009, 01h59
  2. Probleme étrange avec PicKit
    Par McCorwin dans le forum Électronique
    Réponses: 12
    Dernier message: 19/08/2008, 23h05
  3. Ventilo d'ordinateur problème avec alim externe
    Par invite9876423294 dans le forum Électronique
    Réponses: 4
    Dernier message: 01/07/2008, 23h44
  4. memoire externe sur dsPIC
    Par 85julien dans le forum Électronique
    Réponses: 0
    Dernier message: 27/02/2008, 15h38
  5. DD externe detecté, mais je le trouve pas!!!
    Par Sauron dans le forum Matériel - Hardware
    Réponses: 6
    Dernier message: 02/10/2004, 02h33
Découvrez nos comparatifs produits sur l'informatique et les technologies.