Répondre à la discussion
Affichage des résultats 1 à 2 sur 2

Problème modèle LTSpice



  1. #1
    katmai

    Arrow Problème modèle LTSpice


    ------

    Bonsoir,

    J'ai un petit problème avec un modèle trouvé ici.

    *
    *
    * Schmitt-inverter gate
    * tpd 41n/15n/12n
    * tr 19n/7n/6n
    * VT+ 1.18/2.38/3.14
    * VT- 0.52/1.4/1.89
    .SUBCKT 74HC14 A Y VCC VGND vcc1={vcc} speed1={speed} tripdt1={tripdt}
    .param td1=1e-9*(15-3-3)*4.0/({vcc1}-0.5)*{speed1}
    *
    XIN A Ai VCC VGND 74HC_IN_S_1 vcc2={vcc1} speed2={speed1} tripdt2={tripdt1}
    *
    A1 Ai 0 0 0 0 Yi 0 0 BUF tripdt={tripdt1} td={td1}
    *
    XOUT Yi Y VCC VGND 74HC_OUT_1X vcc2={vcc1} speed2={speed1} tripdt2={tripdt1}
    .ends
    *
    Je copie et colle le texte dans LTSpice. J'ai fais un symbole avec quatres broches nommées A Y VCC VGND et je choisie spice model : 74HC14. Mais quand je lance la simulation il me dit A1 Missing node.

    Quelqu'un a une idée pour faire fonctionner ce modèle ?

    Merci d'avance A+

    -----

  2. #2
    yvon59

    Re : Problème modèle LTSpice

    modele spice du 74HC14
    qui fonctionne
    inclure le texte de cette libraire dans celle appelée par le schéma etcréer le symbole 74HC14 (a 3 broches dans l'ordre entree alimentation sortie )

    * Copyright © Yvon.Tollens
    * Librairie pour Swcad3
    *la connection de masse est implicite
    *la connection de masse est realisée par defaut dans le modele
    ****************************** ****************************** *****************
    *Inverseur triggé CMOS idéalisé description par modeles
    *
    * e al s
    .subckt 74HC14 e al s
    ri e 1 200
    ci 1 0 10p
    d1 1 al Din
    d2 0 1 Din
    r1 1 al 100meg
    r2 1 0 100meg
    ral1 al ref 100k
    ral2 ref 0 100k
    cref ref 0 10p
    A1 N001 0 0 0 0 N003 0 0 SCHMITT Vt= 0.38 Vh = 0.098
    B1 N001 0 V=(0.999*V(e)/V(al))
    es 3 0 value = { V(al)*V(n003)}
    rs 3 s 100
    .MODEL Din D (IS=210E-9 CJO=1E-09 BV=450)
    .ends 74HC14
    ****************************** ****************************** *****************
    yvon59

Discussions similaires

  1. LTSpice & OTA
    Par bouly94 dans le forum Électronique
    Réponses: 22
    Dernier message: 29/05/2014, 11h50
  2. LTspice
    Par morpheus87 dans le forum Électronique
    Réponses: 6
    Dernier message: 05/02/2009, 18h26
  3. Simulation sous LTSPICE.
    Par katmai dans le forum Électronique
    Réponses: 5
    Dernier message: 12/10/2008, 09h40
  4. composanrs LTspice
    Par duc_onlajoy dans le forum Électronique
    Réponses: 1
    Dernier message: 09/12/2007, 08h55
  5. Ltspice/swcadiii
    Par curieuxdenature dans le forum Électronique
    Réponses: 3
    Dernier message: 05/10/2005, 15h58
Découvrez nos comparatifs produits sur l'informatique et les technologies.