Répondre à la discussion
Affichage des résultats 1 à 12 sur 12

Problème de simulation sous ISIS 7.4



  1. #1
    Che57

    Problème de simulation sous ISIS 7.4


    ------

    Bonsoir,

    Je dois réaliser un analyseur de spectre à balayage de fréquence dans le cadre d'un mini-projet.
    J'ai pour cela dans un premier, conçu chaque bloc du circuit. Ils fonctionnent tous indépendamment les un des autres.
    Cependant, lorsque que je branche les blocs entre eux, là ça ne fonctionne pas, j'ai l'erreur dont le screenshot est en pièce jointe.
    J'ai essayé de détecter l'origine de cette erreur et je pense qu'il provient du circuit mélangeur AD633. Lorsque que je l'exclue de la simulation, je n'ai pas d'erreurs.

    Comment puis-je y remédier ?

    Je vous remercie d'avance.

    Che57

    -----
    Images attachées Images attachées

  2. Publicité
  3. #2
    Che57

    Re : Problème de simulation sous ISIS 7.4

    Personne pour m'aider ?

  4. #3
    amoniaque

    Re : Problème de simulation sous ISIS 7.4

    Salut Damien ,

    Oups désolé j'ai lu tout le chemin de dossier dans ton erreur d'isis

    Je n'ai pas proteus sous la main mais déjà tu peux de modifier les valeurs des temps sous les paramètres de pro spice (on voit que TRAN a une valeur trop faible pour U1 et Q1) donc essais de voir si cette valeur est modifiable.

    A++

  5. #4
    invite39886733

    Re : Problème de simulation sous ISIS 7.4

    poste ton schema en piece jointe

  6. A voir en vidéo sur Futura
  7. Comparatifs

    Gagnez du temps et de l'argent grâce à nos comparatifs de produits. Parmi nos sujets :
  8. #5
    amoniaque

    Re : Problème de simulation sous ISIS 7.4

    Citation Envoyé par hulk69 Voir le message
    poste ton schema en piece jointe
    +1 pour Hulk et si tu pouvais poster le fichier dsn ce serait un plus (voir si la simulation plante uniquement chez toi ou non).

  9. #6
    Che57

    Re : Problème de simulation sous ISIS 7.4

    Bonjour,

    Je vous ai mis le fichiers en pièce jointe.

    Le problème actuel et que je n'arrive pas simuler le générateur de rampes (NE555) dans ce fichier : soit j'ai un "timestep too small" lorsque je lance la simulation en appuyant sur le bouton lecture, soit PROSPICE reste bloqué à 0% (et je suis obligé de tuer le processus) lorsque je simule dans une fenêtre ANALOGUE ANALYSIS.

    Du coup, je suis bloqué et je ne peux pas simuler l'AD633J (mélangeur).

    Autrement, le VCO fonctionne correctement lorsque je l'attaque avec un générateur d'impulsions (réglé en rampes), tout comme les filtres.

    @amoniaque : à quoi correspond ce TRAN justement ?

    En vous remerciant d'avance.
    Fichiers attachés Fichiers attachés

  10. Publicité
  11. #7
    Che57

    Re : Problème de simulation sous ISIS 7.4

    J'ai vraiment du mal à comprendre un truc : lorsque je teste le générateur de rampes tout seul dans un fichier, il fonctionne normalement. Puis lorsque je l'incorpore dans mon projet, soit la simu plante, soit j'ai des erreurs. Et le plus drôle est que les erreurs proviennent des autres blocs qui fonctionnent eux aussi indépendamment les uns des autres !

  12. #8
    Che57

    Re : Problème de simulation sous ISIS 7.4

    Il y a vraiment personne qui peut me donner un petit coup de pouce ?

  13. #9
    bertrandbd

    Re : Problème de simulation sous ISIS 7.4

    Bonsoir

    Que l'outil de verification des régles electriques (tool => electrical rules check)

  14. #10
    Che57

    Re : Problème de simulation sous ISIS 7.4

    Voilà ce que j'obtiens :

    ELECTRICAL RULES CHECK REPORT
    =============================
    Design: C:\Users\Damien\Desktop\ANALYS EUR_DE_SPECTRE\ANALYSEUR_DE_SP ECTRE.DSN
    Doc. no.: <NONE>
    Revision: <NONE>
    Author: <NONE>
    Created: 11/04/11
    Modified: 12/04/11

    #I:Compiling design 'C:\Users\Damien\Desktop\ANALY SEUR_DE_SPECTRE\ANALYSEUR_DE_S PECTRE.DSN'.
    %C=0002,00000003
    #W:Pin '1' does not exist on child sheet.
    %S=C3
    %L=7
    #W:Pin '2' does not exist on child sheet.
    %S=C3
    %L=7

    UNDRIVEN: U3,COMPIN (Input)
    UNDRIVEN: U3,SIGIN (Input)
    UNDRIVEN: U3,ZENER (Input)
    UNDRIVEN: VP15,<TERM> (Output); U4,VS+ (Power Pin); U1,V+ (Power Pin); U5,V+ (Power Pin)
    UNDRIVEN: VM15,<TERM> (Output); U4,VS- (Power Pin); U1,V- (Power Pin); U5,V- (Power Pin)
    UNDRIVEN: RAMPES2,<TERM> (Output)

    Netlist generated OK.
    ERC errors found.

  15. #11
    ouss76

    Re : Problème de simulation sous ISIS 7.4

    Salut

    sans chercher, j'ai remplacé ton TL081 par un autre modèle de la librairie et plus d'erreurs dessus. (il restait une erreur sur C3 mais j'ai pas regardé)
    Je suis nul en électronique.non! ce n'est pas de la modestie je suis réaliste

  16. #12
    bertrandbd

    Re : Problème de simulation sous ISIS 7.4

    Bonsoir

    Sur C3, quabd tu édites le composant tu enlèves l'option attach hierarchy module. Les options undriven des TLO existent à cause des signaux non connectés

    A+

  17. Publicité

Discussions similaires

  1. simulation sous Isis
    Par Slimounet45 dans le forum Électronique
    Réponses: 14
    Dernier message: 27/03/2011, 14h35
  2. Probleme de simulation sous ISIS
    Par dibboss dans le forum Électronique
    Réponses: 1
    Dernier message: 13/06/2010, 15h35
  3. simulation spice sous isis (proteus)
    Par alexmomo dans le forum Électronique
    Réponses: 1
    Dernier message: 04/02/2010, 16h33
  4. simulation AD620 sous ISIS
    Par Graam dans le forum Électronique
    Réponses: 7
    Dernier message: 05/04/2009, 10h45
  5. Simulation sous ISIS bizarre?
    Par abracadabra75 dans le forum Électronique
    Réponses: 8
    Dernier message: 24/06/2007, 19h07
Découvrez nos comparatifs produits sur l'informatique et les technologies.