Répondre à la discussion
Affichage des résultats 1 à 20 sur 20

Probleme avec proteus



  1. #1
    nounouENGELEN

    Probleme avec proteus


    ------

    bsr ts le monde, j'ai redessiné un schéma sur proteus mais lors du routage il m'a affiché la liste de mais composants mais avec beaucoup de "missing" dont je ne comprend pas, ya t-il quelqu'un qui maitrise bien ce logiciele?

    -----

  2. Publicité
  3. #2
    Pierrre

    Re : Probleme avec proteus

    Bonjour

    es tu sur que tous les composants du schema ISIS ont bien leur empreinte sous ARES ?
    sous ISIS, selectionner composant, clic D, "montrer affectation de package"

    A+

  4. #3
    nounouENGELEN

    Re : Probleme avec proteus

    D sur le clavier? ca ne m'avance pas,c'est la première fois que je travaille avec ISIS, toute orientation le sera utile. peut-il que mon programme ne fonctionne pas bien?

  5. #4
    nounouENGELEN

    Re : Probleme avec proteus

    voila le programme; son principe est le suivant:
    un pic 16F877 doit mesurer la tension d'une batterie solaire et la comparer à deux seuils: 14,4 et 10,8V; si elle est sup à 14,4V il doit ouvrir un interrupteur (mosfet entre panneau et batterie) en générant un PWM. si elle est inf à 10,8V il doit ouvrier un deuxieme interrupteur (mosfet entre bat et consommation). sinon il ferme les 2interrupteurs

    Code:
    #include "16F877A.h"
    #fuses HS,
    #DEVICE ADC=8
    #use delay(clock = 20000000)
    
    //float moyenne ;
    //long mesure;
    int i;
    int16 moyenne;
    
    void main ()
    {
       setup_ccp1(ccp_pwm);
       set_pwm1_duty(0);
       setup_timer_2(T2_DIV_BY_4,250,1);
       
       setup_adc(ADC_CLOCK_INTERNAL); // ADC clock
       setup_adc_ports(ALL_ANALOG); // Input combination
       set_adc_channel(0);     
        delay_ms(1000);
        while(true)
          {
          moyenne= read_adc();
          moyenne=moyenne*24/255;
          if (moyenne>14) 
          {
          set_pwm1_duty(202);
          output_high(Pin_B1);
          output_LOW(pin_D2);
          output_low(Pin_d1); 
          output_HIGH(Pin_d0);
          }
          else if(moyenne<10)      
          {
    
          output_low(Pin_B1);
          set_pwm1_duty(25);
          output_high(pin_D2);
          output_low(Pin_d1); 
          output_low(Pin_d0);     
          }
         else
         {
          set_pwm1_duty(177);    
          output_high(Pin_B1);
          output_LOW(pin_D2);
          output_HIGH(Pin_d1); 
          output_low(Pin_d0);
          }
          
       
       delay_ms(100);
    }
    }
    Dernière modification par gienas ; 28/02/2013 à 19h22. Motif: Ajouté les balises cod, obligatoires pour les programmes

  6. A voir en vidéo sur Futura
  7. #5
    Pierrre

    Re : Probleme avec proteus

    clic D = clic droit de la souris

  8. #6
    nounouENGELEN

    Re : Probleme avec proteus

    j'ai cliqué sur un condo non polarisé, affectation du package, on m'a donné une liste de tous les condo 'missing'.ca veut dire quoi et est ce que ces composants serant présents sur le circuit imprimé? sinon qu'est ce que je dois faire alors?

  9. Publicité
  10. #7
    omar.STE

    Re : Probleme avec proteus

    Bonsoir,
    avant de passer à ARES (pour faire le routage) vous devez vous assurer que tous les composants ont un Package, sinon vous serez obligé de créer un Package pour chaque composant qui lui manque. Pour le faire suivez les étapes suivantes:
    1. Clic D sur le composant concerné
    2. Packaging Tools
    3. clic Add
    4. choisissez un Package convenable avec le composant
    5. Affectez les pins de Package aux pins du composant
    6. clic Assign Package
    7. Enjoy

    GooD LucK
    Dernière modification par omar.STE ; 28/02/2013 à 19h09.
    l'aide n'a aucun prix

  11. #8
    nounouENGELEN

    Re : Probleme avec proteus

    merci bcp, j pa trouvé packaging tools mais j'ai changé les parametres des composants de sorte qu'il aient leurs packages. ne me reste que les sources je ne trouve pas leurs packages. personne n'a vu mon programme?

  12. #9
    omar.STE

    Re : Probleme avec proteus

    pour les sources vous pouvez utiliser des connecteurs .
    pour le programme, vaut mieux le commenter pour qu'il devient lisible.
    @+
    l'aide n'a aucun prix

  13. #10
    nounouENGELEN

    Re : Probleme avec proteus

    bjr, j'ai pas compris, utiliser les connecteurs et garde la source 'sans package?

  14. #11
    nounouENGELEN

    Re : Probleme avec proteus

    Bjr, je veux remplacer un MOSFET IRFZ44 type "N" par un type "P" ?

  15. #12
    nounouENGELEN

    Re : Probleme avec proteus

    Please mot cle pour placer un connecteur deux pins sur proteus

  16. Publicité
  17. #13
    nounouENGELEN

    Re : Probleme avec proteus

    Slt, cmt proceder au routage automatique; je parviens pas à preciser la zone d'emplacement des composants svp.

  18. #14
    Jojop37

    Re : Probleme avec proteus

    Bonsoir à tous.
    Poour passer de Isis à Ares,il suffitde cliquer sur le sigle Ares dans le coin droit en haut.
    Ensuite,une fois sous Arès,1)exemple de chargements des composants:Q1 npn:cliquer sur "package et chercher le boitier correspondant (TO3);puis "OK",ainsi de suite pour tous les composants du montage.
    2)Délimiter les dimensions du circuit en sélectionnant le layer "board edge de couleur jaune",tracer le carré des dimensions voulues;3)Cliquer sur le placement automatique des composants,4) pour, le routage automatique,cliquer sur le symbole adapté (possibilité de choisir le type de piste,largeur,;....avant de lancer le routage
    Jojop37

  19. #15
    nounouENGELEN

    Re : Probleme avec proteus

    le probleme c'est que je trouve pas "board edge de couleur jaune".

  20. #16
    nounouENGELEN

    Re : Probleme avec proteus

    voila mon montage sur proteus, c'est un regulateur de charge de batterie. JE SAIS PAS CMT UTILISER LES CONNECTEURS ET JE TROUVE AUCUN PACKAGE POUR TRANSFORMATEUR,LED, et inductance. AIDEZ MOI SVP. AUSSI A ARES JE SAIS PLUS COMMENT FAIRE.
    Images attachées Images attachées  

  21. #17
    nounouENGELEN

    Re : Probleme avec proteus

    l'etage du transformateur est un aide à la commutation du mosfet Q1, le connecteur à gauche présente les bornes du panneau solaire, le connecteur à droite présente les bornes de la batterie,le PWM sort de la pin 17 et atque le Q1à travers la resistance de l'extreme gauche. la tension de la batterie est mesuré à travers le diviseur de tension et le Q2 est commandé à travers la PIN 39. j'ai ajouté les led pour indiqué l'état de charge de la batterie, comprise toujours entre 14,4 ET 10,8V, j'ai divisé cette intervalle sur 3 ET CHAQUE LED INDIQUE UNE VALEUR; est ce bon, et comment passer au circuit imprimé je vous prie aidez moi,svp.

  22. #18
    nounouENGELEN

    Re : Probleme avec proteus

    je me demande pourquoi personne ne réponde, meme si mes questions vous paraissent ridicule. je lis souvent des questions plus simple et moins détaillée et tous le monde participe. sauf si vous n'acceptez pas de femmes ici.

  23. Publicité
  24. #19
    Jojop37

    Re : Probleme avec proteus

    Bonjour à tous.
    Pour tracer le pourtour du circuit(board edge):
    1/Sélectionner le rectangle dans la barre d'outils 2D
    2/En bas dans les folios(layers) sélectionner celui qui porte le non de "board edge"
    3/Tracer le rectangle aux dimensions voulues
    4/passer à l'étape du placement des composants
    Jojop37

  25. #20
    nounouENGELEN

    Re : Probleme avec proteus

    merci, un aytre petit probleme; avant j'utilisait simplement les "power" et maintenant un msg d'erreur"no power supply in power rail configuration" . ou pourrai-je configurer mon alimentation et comment? c'est urgent svp.

Discussions similaires

  1. Petit problème de simulation avec proteus
    Par walid.fetouche dans le forum Électronique
    Réponses: 7
    Dernier message: 23/05/2011, 22h36
  2. problème NE 555 avec Proteus
    Par arzew dans le forum Électronique
    Réponses: 49
    Dernier message: 27/01/2011, 15h34
  3. le 3D avec proteus 6.9
    Par arzew dans le forum Électronique
    Réponses: 2
    Dernier message: 17/12/2008, 17h45
  4. probleme avec proteus
    Par bird12358 dans le forum Électronique
    Réponses: 3
    Dernier message: 27/10/2008, 22h17
  5. Problème avec proteus
    Par karim3181 dans le forum Électronique
    Réponses: 3
    Dernier message: 17/03/2006, 08h56
Découvrez nos comparatifs produits sur l'informatique et les technologies.