Répondre à la discussion
Affichage des résultats 1 à 12 sur 12

petit problème avec Ltspice



  1. #1
    cougar73

    petit problème avec Ltspice


    ------

    bonsoir

    j ai voulu simuler les caractéristiques d un njft, Ids en fonction de Vds dans le manuel, méthode et applications.
    Ids est négatif tandis que sur le livre il est en positif j ai bien regardé le schéma s est le même voir copie d ecrant

    NJT.jpg

    merci pour vos réponses bonne soirée

    -----

  2. Publicité
  3. #2
    Zenertransil

    Re : petit problème avec Ltspice

    Bonsoir,

    C'est parce que LTSpice choisit un sens "arbitraire" de circulation du courant, qui n'est pas forcément celui qui est logique pour nous! Je crois que les sources de tension positionnées à la verticale ont un sens de circulation normal vers le BAS, en convention récepteur donc, et non en convention générateur. Le courant négatif signifie que le courant sort de la source de tension: tout va bien... Pour rectifier le tracé des courbes, clic droit sur leur nom en haut de la fenêtre, et ajouter un signe "-" juste avant!

  4. #3
    Tropique

    Re : petit problème avec Ltspice

    Pour préciser ce qui est dit plus haut: ce que tu as plotté n'est pas Id, mais le courant d'une source de tension. Le fait est qu'elle n'alimente que Id, la valeur absolue devrait donc être identique mais le signe pourrait être arbitraire. C'est le cas pour un composant "neutre", comme une résistance: le sens du courant va changer selon la manière dont elle est dessinée. Par contre, pour tout ce qui est asymétrique, le sens n'est plus arbitraire: dans le cas d'une source de tension, le sens choisi est celui qui est compatible avec la conservation d'énergie, que LTspice respecte. Une source normale, avec une polarité normale fournit de l'énergie au système. Pour que le sens de courant reste cohérent avec celui absorbé par les récepteurs, il doit être inversé.
    Il faut pouvoir concilier un certain nombre de conventions contradictoires, qui sont normalement examinées séparément en analyse de circuit "classique" (manuelle) mais qui sont présentes simultanément dans une sim. Le choix qui a été fait est d'inverser le sens du courant dans les sources de tension, probablement parce qu'elles sont beaucoup moins nombreuses que les composants ordinaires.
    Si on plotte réellement Id, on retrouve les conventions habituelles:
    Cougar.png

    Cougar.asc.txt
    Pas de complexes: je suis comme toi. Juste mieux.

  5. #4
    cougar73

    Re : petit problème avec Ltspice

    bonsoir

    merci pour vos deux réponses, j ai une autre question comment faire la fonction Id en fonction de Vgs

    bonne soirée

  6. #5
    Tropique

    Re : petit problème avec Ltspice

    Il suffit d'inverser l'ordre d'énumération des sources dans la directive de simulation (ou d'éliminer le Vds du sweep si on n'est pas intéressé à le paramétrer).
    Exemple:

    Cougar1.png

    Cougar1.asc.txt
    Pas de complexes: je suis comme toi. Juste mieux.

  7. A voir en vidéo sur Futura
  8. #6
    cougar73

    Re : petit problème avec Ltspice

    bonsoir

    merci pour la réponse Tropique, j ai trouvé une autre méthode avec une seul valeur de Vds voici le http://bernard.decaestecker.free.fr/?p=2048.

    je vais pouvoir maintenant faire des mesure en simulation et en situation réel

    je reviendrais vers vous pour d autre question je pense

    bonne soirée

  9. Publicité
  10. #7
    Tropique

    Re : petit problème avec Ltspice

    Citation Envoyé par cougar73 Voir le message
    merci pour la réponse Tropique, j ai trouvé une autre méthode avec une seul valeur de Vds voici le http://bernard.decaestecker.free.fr/?p=2048.
    En fait, c'est exactement la deuxième option que j'ai proposée:
    Citation Envoyé par Tropique Voir le message
    (ou d'éliminer le Vds du sweep si on n'est pas intéressé à le paramétrer).
    Pas de complexes: je suis comme toi. Juste mieux.

  11. #8
    cougar73

    Re : petit problème avec Ltspice

    ok merci

    bonne soirée

  12. #9
    cougar73

    Re : petit problème avec Ltspice

    bonjour

    je ne trouve pas comment faire pour mettre les graphiques ids(vgs) a coté de ids(vds) sous ltspice si on peut le faire?

    merci bonne journée

  13. #10
    Tropique

    Re : petit problème avec Ltspice

    Tu veux avoir les deux précédents sur le même graphique? Curieuse idée, en tous cas si c'est ça, ça demanderait des acrobaties impossibles, il est bien plus simple d'employer un programme graphique quelconque pour les juxtaposer.
    Pas de complexes: je suis comme toi. Juste mieux.

  14. #11
    cougar73

    Re : petit problème avec Ltspice

    bonjour tropique

    je me demandé si s était possible avec ltspice, donc suffit de faire un copier coller de l ecran alor.

    merci pour la réponse

  15. #12
    Tropique

    Re : petit problème avec Ltspice

    A peu près rien n'est impossible quand on sait jouer avec toutes les subtilités et possibilités offertes, mais ça n'a pas beaucoup de sens de chercher deux heures, alors qu'avec un copier-coller c'est plié en moins de 30s.
    Pas de complexes: je suis comme toi. Juste mieux.

  16. Publicité

Sur le même thème :

Discussions similaires

  1. Pont en H avec LTSpice
    Par camifou dans le forum Électronique
    Réponses: 1
    Dernier message: 13/05/2013, 16h05
  2. Problème avec LTSpice: la simulation se s'arrête pas
    Par Canaillou2k5 dans le forum Électronique
    Réponses: 8
    Dernier message: 15/02/2011, 22h00
  3. Autospectre avec LTspice
    Par jlcms dans le forum Électronique
    Réponses: 3
    Dernier message: 02/02/2011, 08h01
  4. Modele LTspice transfo avec point milieu
    Par jlcms dans le forum Électronique
    Réponses: 1
    Dernier message: 16/12/2010, 15h01
  5. Simulation compteur avec LTspice
    Par Umbrack dans le forum Électronique
    Réponses: 4
    Dernier message: 15/04/2009, 15h03