Répondre à la discussion
Affichage des résultats 1 à 12 sur 12

Problème PIC




  1. #1
    lanim

    Question Problème PIC

    Aujourd’hui je me suis lancé dans la grande aventure de l’apprentissage des microcontrôleurs et en particulier les PIC. Et comme tout bon débutent j’ai commencé avec le fameux montage du « led-blinking » en suivent les instructions disponibles sur cette page https://electrosome.com/led-blinking-pic/

    Mais que le surcuit se comporte d’une façon inattendue que je n’arrive pas a expliqué alors j’ai fait une vidéo .

    -----


  2. Publicité
  3. #2
    penthode

    Re : Problème PIC

    hello

    un schéma de ton montage ?

    ce phénomène est typique d'une entrée "en l'air" qui ramasse donc les charges statiques environnantes

    AJOUT sauf erreur de ma part , je ne vois pas de découplage sur l'alim du µc
    Dernière modification par penthode ; 07/01/2019 à 19h03.
    là où le mensonge prolifère, la tyrannie s'annonce ou se perpétue (Albert Camus)

  4. #3
    penthode

    Re : Problème PIC

    AJOUT 2 : à quoi sert l'arduino ?????????????????????
    là où le mensonge prolifère, la tyrannie s'annonce ou se perpétue (Albert Camus)


  5. #4
    lanim

    Re : Problème PIC

    N’ai en pas une alimentation 5 volte sous la main j’utilise l’Arduino comme alimentation
    voici le schéma que j'ai suivie i.png
    et voici une photo de plus prêt de mon montage IMG_20190107_191919.jpg

  6. #5
    penthode

    Re : Problème PIC

    déjà , y'a pas de découplage de l'alim....

    comment peut-on afficher un schéma avec de telles âneries.

    l'électronique vue par les softeux est toujours un mystère pour moi
    là où le mensonge prolifère, la tyrannie s'annonce ou se perpétue (Albert Camus)

  7. A voir en vidéo sur Futura
  8. #6
    lanim

    Re : Problème PIC

    je sais je suis nul en Electronique je suis surtout attiré par la partie programmation

    Oh grand penthode éclaire nous par votre grands savoir

    pour alimenté un µc une simple alimentation 5V ne fait pas l'affaire ?

  9. #7
    paulfjujo

    Re : Problème PIC

    bonsoir,



    sur la photo Breadboard, je ne vois aucune liaison sur la pin 1 MCLR,
    il faut mettre une R de 4,7K à 10K tirée au +VCC
    et effectivement aucun decouplage par Condo de 100nF entre les pins VDD et VSS du PIC.

    Quand est -il du soft
    la config oscillateur est bien programmée pour un Quartz ?

  10. Publicité
  11. #8
    penthode

    Re : Problème PIC

    une simple pile plate !

    ça ne sont pas tes connaissances que je critique , mais celles de l'auteur du torchon


    et ça ne te dédouane pas de découpler ton alim
    là où le mensonge prolifère, la tyrannie s'annonce ou se perpétue (Albert Camus)

  12. #9
    Antoane

    Re : Problème PIC

    Bonsoir,

    Il me semble ne pas voir sur le proto la liaison entre le MCLR (Reset) du PIC et le Vcc.

    Il faudrait ajouter un "condensateur de découplage" : condensateur d'une centaine de nF entre le Vcc et le GND. Ce composant doit être aussi près que possible (<<1cm) du PIC.

    edit : grillé.
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  13. #10
    lanim

    Re : Problème PIC

    avent toute chose Je vous remercie pour votre aide.
    @paulfjujo : oui la config oscillateur est programmer a 8 MHz

    je vais étudier cette histoire de découplage


    encore une fois Merci a vous !

  14. #11
    paulfjujo

    Re : Problème PIC

    bonsoir,



    sur la photo Breadboard, je ne vois aucune liaison sur la pin 1 MCLR,
    il faut mettre une R de 4,7K à 10K tirée au +VCC
    et effectivement aucun decouplage par Condo de 100nF entre les pins VDD et VSS du PIC.

    Quand est -il du soft
    la config oscillateur est bien programmée pour un Quartz ?
    config en HS (High Speed)
    a essayer eventuellement , en XT si le quartz est recalcitrant

  15. #12
    lanim

    Re : Problème PIC

    @paulfjujo: ok je vais testé çà

    et merci !

Discussions similaires

  1. probleme pour configurer mes interfaces sur linux ( probleme assez théorique)
    Par docEmmettBrown dans le forum Internet - Réseau - Sécurité générale
    Réponses: 0
    Dernier message: 27/06/2017, 19h49
  2. probleme avec chaudiere Viessmann Vitocrossal 300 - probleme de sur-tension?
    Par apap dans le forum Habitat bioclimatique, isolation et chauffage
    Réponses: 0
    Dernier message: 19/04/2016, 22h52
  3. Problème de majoration - Discrétisation d'un problème de Dirichlet homogène pénalisé
    Par sknbernoussi dans le forum Mathématiques du supérieur
    Réponses: 0
    Dernier message: 30/01/2015, 09h13
  4. Réponses: 2
    Dernier message: 04/12/2012, 15h08