Répondre à la discussion
Affichage des résultats 1 à 11 sur 11

Probleme d'oscillation sur un ampli RF à fort gain




  1. #1
    Fortare

    Probleme d'oscillation sur un ampli RF à fort gain

    Bonjour,

    Mon projet actuel consiste à réaliser un amplificateur fonctionnant sur la gamme 1GHz-4GHz avec un gain variable.

    Pour ce faire, j'ai réalisé un PCB en technologie coplanaire CPW sur 4 couches (1 couche RF, 2 couches de masse et 1 couche alim avec un substrat FR4 ) où je cascade deux amplificateurs de 15 dB de gain avec option bypasse, un atténuateur variable commandé en SPI et enfin deux amplificateurs à 20 dB de gain.
    L'ampli peut avoir un gain de 30 à 60 dB. Cependant, une oscillation apparait à 6 GHz ( parfois à 4 et 5 GHz aussi) à partir de 50 dB de gain lorsque je place un circuit ouvert à l'entrée du circuit.

    Pour résoudre ce problème, plusieurs tentatives ont été mise en place :

    - Des bobines férites et capacités supplémentaires ont été placé sur les lignes d'alim pour améliorer le découplage et limiter des fuites RF dans l'alim. L’oscillation persiste.
    - Un capot métallique a été réalisé ( avec de l'absorbant ) et placé sur la partie supérieur du pcb à la masse. L’oscillation persiste et n'est pas du tout diminué. Cependant, l'oscillation disparait quand je touche le capot avec mes doigts. Je n'arrive pas à expliquer ce phénomène. Remarque : ce phénomène se produit quelques fois quand je touche la masse du circuit avec mes mes doigts.

    J'ai donc pensé à des oscillations du à des boucles de masse entre les couches mais si le problème vient de là, je ne sais pas comment résoudre ce problème ( peut être que je n'ai pas placé assez de trous métallisés).

    Merci d'avance pour votre aide.

    -----


  2. Publicité
  3. #2
    gienas

    Re : Probleme d'oscillation sur un ampli RF à fort gain

    Bonsoir Fortare et tout le groupe

    Bienvenue sur le forum.

    Citation Envoyé par Fortare Voir le message
    ... amplificateur fonctionnant sur la gamme 1GHz-4GHz avec un gain variable ...
    Hum. Déjà, ce n'est pas une réalisation à la portée d'un manchot.

    Citation Envoyé par Fortare Voir le message
    ... Cependant, l'oscillation disparait quand je touche le capot avec mes doigts. Je n'arrive pas à expliquer ce phénomène. Remarque : ce phénomène se produit quelques fois quand je touche la masse du circuit avec mes mes doigts ...
    Je suis tenté de penser que "la masse" n'est pas à la masse, et je me demande aussi comment est constatée l'oscillation. Est-ce une mesure? Avec quoi? Branché comment?

    Citation Envoyé par Fortare Voir le message
    ... Cependant, une oscillation apparait à 6 GHz ( parfois à 4 et 5 GHz aussi) à partir de 50 dB de gain lorsque je place un circuit ouvert à l'entrée du circuit ...
    Je ne suis pas spécialiste de ce genre de circuit, mais je ne comprends pas ce que tu entends par là. Il me semble que ni l’entrée ni la sortie ne doivent rester en l'air.

  4. #3
    gwgidaz

    Re : Probleme d'oscillation sur un ampli RF à fort gain

    Citation Envoyé par Fortare Voir le message
    Bonjour,

    Mon projet actuel consiste à réaliser un amplificateur fonctionnant sur la gamme 1GHz-4GHz avec un gain variable.

    Pour ce faire, j'ai réalisé un PCB en technologie coplanaire CPW sur 4 couches (1 couche RF, 2 couches de masse et 1 couche alim avec un substrat FR4 ) où je cascade deux amplificateurs de 15 dB de gain avec option bypasse, un atténuateur variable commandé en SPI et enfin deux amplificateurs à 20 dB de gain.
    L'ampli peut avoir un gain de 30 à 60 dB. Cependant, une oscillation apparait à 6 GHz ( parfois à 4 et 5 GHz aussi) à partir de 50 dB de gain lorsque je place un circuit ouvert à l'entrée du circuit.

    Pour résoudre ce problème, plusieurs tentatives ont été mise en place :

    - Des bobines férites et capacités supplémentaires ont été placé sur les lignes d'alim pour améliorer le découplage et limiter des fuites RF dans l'alim. L’oscillation persiste.

    - Un capot métallique a été réalisé ( avec de l'absorbant ) et placé sur la partie supérieur du pcb à la masse. L’oscillation persiste et n'est pas du tout diminué. Cependant, l'oscillation disparait quand je touche le capot avec mes doigts. Je n'arrive pas à expliquer ce phénomène. Remarque : ce phénomène se produit quelques fois quand je touche la masse du circuit avec mes mes doigts.

    J'ai donc pensé à des oscillations du à des boucles de masse entre les couches mais si le problème vient de là, je ne sais pas comment résoudre ce problème ( peut être que je n'ai pas placé assez de trous métallisés).

    Merci d'avance pour votre aide.
    Bonjour ,
    je vous conseille de voir le chapitre 8 de ce lien ( bases du routage des PCB en UHF...) http://pratique-rfcircuits.monsite-orange.fr/


    Notamment, questions à se poser :

    - Pourquoi 2 couches de masse ? En hyperfréquence, une seule suffit, les grandes surfaces de la deuxième créent des résonateurs incontrolés si on ne le relie pas partout avec des vias serrés.Tout au plus peut-on utiliser l'autre couche juste au dessus des lignes, pour faire des triplaques. mais il faut réaliser des vias masse -masse tout le long .

    -quel est l'ordre des couches ?

    - des pistes "non RF" cohabitent-elles sur la couche des pistes RF ?

    La couche de masse est-elle complète ( pas de fente !!...)

    - le PCB est-il fixé dans un boîtier ? si oui, distance entre le fixations. Si le contact n'est pas continu, l'espace entre le boîtier et le PCB constitue un résonateur lambda/2 entre deux fixations.

    - le blindage rajouté est-il mis à la masse par des points suffisamment proches?


    - épaisseur entre les pistes et le plan de masse ? A cs fréquences, les pistes rayonnent un peu et 60 dB, c'est vite rebouclé entre entrée et sortie. On peut -uniquement là- utiliser une deuxième couche pour la masse , mais uniquement au dessus des lignes, pour faire des triplaques.

    -dimensions des blindages? Ne font-ils pas un guide TM ou TE si leur largeur s'approche de la demi-onde de la fréquence haute? si oui, il faudra une paroi dans le blindage.

    L'effet en touchant le capot montre que vous avez un point chaud de résonance sur le capot . Si vous touchez le bas du capot , et que le phénomène subsiste, c'est la carte complète qui résonne: voir les points précédents.
    Une photo ou un dessin serait bienvenu.


  5. #4
    Fortare

    Re : Probleme d'oscillation sur un ampli RF à fort gain

    Bonsoir et merci gienas ,

    Est-ce une mesure? Avec quoi? Branché comment?
    => La mesure de l'oscillation se fait avec un analyseur de spectre. En entrée, je branche un circuit ouvert et en sortie, je connecte l'analyseur. Je remarque une harmonique autour de 6GHz qui peut monter jusqu'à 15 dBm.
    Remarque : Lorsque je branche une charge 50 Ohm en entrée, l'oscillation disparait. Mais je recherche la stabilité inconditionnel, donc je veux que mon ampli soit stable pour n'importe quel charge en entrée.

    Bonsoir gwgidaz,

    - Pourquoi 2 couches de masse ? En hyperfréquence, une seule suffit, les grandes surfaces de la deuxième créent des résonateurs incontrolés si on ne le relie pas partout avec des vias serrés.Tout au plus peut-on utiliser l'autre couche juste au dessus des lignes, pour faire des triplaques. mais il faut réaliser des vias masse -masse tout le long .
    => J'ai utilisé 2 couches de masse car j'avais besoin de 2 couches conducteur ( un pour la RF et un pour l'alim). Pour obtenir un nombre de couches pairs ( contrainte de fabrication), je dois avoir 2 couches de masses. Pour éviter d'avoir un résonateur, j'ai multiplié les trous métallisés.

    -quel est l'ordre des couches ?
    => L'ordre est : RF=>masse RF => Alim => masse ( couche supérieur => couche inférieur ).

    - des pistes "non RF" cohabitent-elles sur la couche des pistes RF ?
    => Oui, il y a quelques bouts de pistes non RF qui servent à alimenter l'ampli qui cohabitent avec la RF;

    La couche de masse est-elle complète ( pas de fente !!...)
    => Oui, j'ai bien fait attention à avoir une couche de masse continue.

    - le PCB est-il fixé dans un boîtier ? si oui, distance entre le fixations. Si le contact n'est pas continu, l'espace entre le boîtier et le PCB constitue un résonateur lambda/2 entre deux fixations
    => Le PCB n'est pas fixé à un pcb, j'utilise des colonnettes pour la maintenir. Par contre j'ai tendance à regarder le lambda/4 pour vérifier mes résonances, vaut mieux regarder le lambda/4 ou le lambda/2 ?

    - le blindage rajouté est-il mis à la masse par des points suffisamment proches?
    => Le blindage rajouté est mis à la masse via une surface continue ( voir la surface en rose qui représente l'absence de vernie épargne sur la photo du layout). Les trous de fixation sont assez éloignés.

    - épaisseur entre les pistes et le plan de masse ? A cs fréquences, les pistes rayonnent un peu et 60 dB, c'est vite rebouclé entre entrée et sortie. On peut -uniquement là- utiliser une deuxième couche pour la masse , mais uniquement au dessus des lignes, pour faire des triplaques.
    L'épaisseur entre les pistes et la masse est de 0.36 mm. Cette épaisseur est fixé par les contraintes de fabrications.

    -dimensions des blindages? Ne font-ils pas un guide TM ou TE si leur largeur s'approche de la demi-onde de la fréquence haute? si oui, il faudra une paroi dans le blindage.
    => Les dimensions du blindage sont : 54mm*16.7mm ( voir photo ). Vu que ça peut résonner, j'ai pensé mettre de l'absorbant sur les parois mais cela n'a strictement rien changé à l'oscillation. Ce qui me laisse croire que l'onde ne passe pas par l'air mais uniquement dans le substrat entre les couches ( et donc une carte entière qui résonne comme vous l'avez souligné ). En effet, même en touchant le bas du capot ou même la masse sur la première couche, le phénomène subsiste.
    Fichiers attachés Fichiers attachés

  6. #5
    Gwinver

    Re : Probleme d'oscillation sur un ampli RF à fort gain

    Bonsoir.

    J'ai quelques petites remarques sur ce sujet.

    Un gain de 60 dB en une seule étape à une seule fréquence est la limite à ne ps dépasser pour la stabilité d'un amplificateur, car c'est le niveau de fuite que l'on peut avoir entre sortie et entrée. Il est possible de faire mieux, mais cela représente des précautions très particulières.

    Si l'amplificateur couve 1 à 4 GHz et qu'il y a une instabilité à 6 GHz, il faut regarder du côté des tés de polarisation. Il faut vérifier leurs comportements en dehors de cette plage de fréquence.

    Si possible, il serait bon de faire une simulation de l'amplificateur, il existe des logiciels payants et gratuits très bien adaptés. En particulier, des études de stabilité pourraient donner des éléments de réflexion, en particulier sur les éléments "annexes" de l'amplification comme les circuits de polarisation.

  7. A voir en vidéo sur Futura
  8. #6
    gwgidaz

    Re : Probleme d'oscillation sur un ampli RF à fort gain

    Citation Envoyé par Fortare Voir le message
    Bonsoir et merci gienas ,


    => La mesure de l'oscillation se fait avec un analyseur de spectre. En entrée, je branche un circuit ouvert et en sortie, je connecte l'analyseur. Je remarque une harmonique autour de 6GHz qui peut monter jusqu'à 15 dBm.
    Remarque : Lorsque je branche une charge 50 Ohm en entrée, l'oscillation disparait. Mais je recherche la stabilité inconditionnel, donc je veux que mon ampli soit stable pour n'importe quel charge en entrée.

    Bonsoir gwgidaz,


    => J'ai utilisé 2 couches de masse car j'avais besoin de 2 couches conducteur ( un pour la RF et un pour l'alim). Pour obtenir un nombre de couches pairs ( contrainte de fabrication), je dois avoir 2 couches de masses. Pour éviter d'avoir un résonateur, j'ai multiplié les trous métallisés.


    => L'ordre est : RF=>masse RF => Alim => masse ( couche supérieur => couche inférieur ).


    => Oui, il y a quelques bouts de pistes non RF qui servent à alimenter l'ampli qui cohabitent avec la RF;


    => Oui, j'ai bien fait attention à avoir une couche de masse continue.


    => Le PCB n'est pas fixé à un pcb, j'utilise des colonnettes pour la maintenir. Par contre j'ai tendance à regarder le lambda/4 pour vérifier mes résonances, vaut mieux regarder le lambda/4 ou le lambda/2 ?


    => Le blindage rajouté est mis à la masse via une surface continue ( voir la surface en rose qui représente l'absence de vernie épargne sur la photo du layout). Les trous de fixation sont assez éloignés.


    L'épaisseur entre les pistes et la masse est de 0.36 mm. Cette épaisseur est fixé par les contraintes de fabrications.


    => Les dimensions du blindage sont : 54mm*16.7mm ( voir photo ). Vu que ça peut résonner, j'ai pensé mettre de l'absorbant sur les parois mais cela n'a strictement rien changé à l'oscillation. Ce qui me laisse croire que l'onde ne passe pas par l'air mais uniquement dans le substrat entre les couches ( et donc une carte entière qui résonne comme vous l'avez souligné ). En effet, même en touchant le bas du capot ou même la masse sur la première couche, le phénomène subsiste.
    Bonjour,

    1- Je ne comprends pas la connectique RF en entrée et sortie. A quoi servent les aplats notés 1 et 2 qui entourent chaque sortie ? s'il s'agit de la masse du connecteur ( SMA ?) , je ne vois pas les nombreux vias qui devraient relier cette masse du connecteur au plan de masse.
    Avec un tel gain, il est essentiel que les câbles d'entrée et de sortie n'aient pas le moindre courant de gaine ( mode commun), donc il faut travailler la connectique qui doit être rigoureusement à la masse. D'ailleurs, pour supprimer des reliquats de courant de gaine, je vous conseille de placer aussi deux tubes ferrites de "mode commun" sur chaque câble, l'un à ras du connecteur, l'autre 15 mm plus loin.

    2- Les pistes d'entrée/sortie sont à l'extérieur du blindage J'espère qu'elles sont recouvertes par la masse de la connectique...Sino, à 5cm de distance l'une de l'autre, elles risquent de se voir à moins de 60 dB d'atténuation.

    3- Le boitier est un guide à la coupure pour le 6 GHz, il ne devrait pas trop transmettre de l'entrée vers la sortie, mais avec 60 dB.....à calculer. Peut-être une cloison centrale agirait.
    Il faut espérer que votre capot touche ailleurs qu'aux endroits des vis : intercalez un film conducteur pour faire surépaisseur où il faut, à mi-chemin entre les deux vis les plus distantes .

    4- pour toutes les pistes autres que la RF Il devrait y avoir une impédance en série ( ferrite cms) très près de l'ouverture, où la piste entre dans le capot .

    Je n'ai pas compris à quoi votre PCB est fixé par les colonnettes à chaque coin : colonnettes métalliques?, à la couche de masse RF ? J'imagine que le support est métallique, car votre carte devrait être dans un boitier métallique. Si c'est le cas, l'ensemble de la carte peut être en résonance . La fréquence de résonance sera celle pour laquelle la distance entre ces colonnettes est une demi-onde. '(Les résonances se font en demi-onde entre deux points de masse) . Si votre carte est ainsi fixée par ces colonnettes, il faudra envisager de placer au moins un autre contact entre le dessous de votre carte et le fond du boîtier.

    Une méthode efficace pour progresser dans la résolutuion du problème:

    Vous ottez une capa série vers le centre de l'ampli, de façon à effondrer son gain --> plus d'oscillation.
    Vous passez alors au tracking de l'analyseur de spectre avec entrée du signal tracking sur la sortie de votre ampli , et entrée de l'analyseur sur son entrée. Vous visualisez ainsi la courbe de réponse inverse ( paramètre S12 de votre ampli) .
    Il faut évidemment trouver une atténuation supérieure à 60 dB !... Cette mesure va montrer tous les couplages parasites de la sortie vers l'entrée. En tripotant avec les doigts les composants , les pistes, les différents endroits de masse, etc... vous allez mettre en évidence les points chauds ( hautes impédances) de toutes les résonances de votre carte. Y compris les problèmes de courant de gaine, en pinçant entre vos doigts les câbles d'entrée et de sortie.

  9. #7
    Yvan_Delaserge

    Re : Probleme d'oscillation sur un ampli RF à fort gain

    Citation Envoyé par gwgidaz Voir le message

    Une méthode efficace pour progresser dans la résolutuion du problème:

    Vous ottez une capa série vers le centre de l'ampli, de façon à effondrer son gain --> plus d'oscillation.
    Vous passez alors au tracking de l'analyseur de spectre avec entrée du signal tracking sur la sortie de votre ampli , et entrée de l'analyseur sur son entrée. Vous visualisez ainsi la courbe de réponse inverse ( paramètre S12 de votre ampli) .
    Il faut évidemment trouver une atténuation supérieure à 60 dB !... Cette mesure va montrer tous les couplages parasites de la sortie vers l'entrée. En tripotant avec les doigts les composants , les pistes, les différents endroits de masse, etc... vous allez mettre en évidence les points chauds ( hautes impédances) de toutes les résonances de votre carte. Y compris les problèmes de courant de gaine, en pinçant entre vos doigts les câbles d'entrée et de sortie.
    Et ceci doit se faire avec l'ampli alimenté ou pas?
    Un civet, un plat de côtes et puis, glissez-moi une petite paupiette avec.( Lino Ventura)

  10. Publicité
  11. #8
    Yvan_Delaserge

    Re : Probleme d'oscillation sur un ampli RF à fort gain

    Un conseil glane sur les forums de radio-amateurs: En UHF et au-dessus, ne jamais mettre plus de deux étages d'amplification dans une même boîte.
    Un civet, un plat de côtes et puis, glissez-moi une petite paupiette avec.( Lino Ventura)

  12. #9
    gwgidaz

    Re : Probleme d'oscillation sur un ampli RF à fort gain

    Citation Envoyé par Yvan_Delaserge Voir le message
    Et ceci doit se faire avec l'ampli alimenté ou pas?
    Ampli alimenté pour ne pas trop modifier les impédances et garder les résonances parasites. Mais il faut oter une capa de la chaîne vers le milieu de l'ampli pour supprimer l'oscillation ...Le but est de faire apparaître l'isolation entre les composants des premiers et derniers étages, par des chemins détournés en parallèle sur les étages centraux.

    Oui, les techniques des radio-amateurs ne permettent guère d'avoir plus de 40 dB de gain dans le même boitier. Mais je suppose qu'il s'agit ici d'un montage professionnel . On peut avoir des gains de 80 dB sur des boitiers guère plus grands. Mais déjà, pour atteindre les 60 dB, il faut avec au moins les précautions que j' ai données ....Probablement même qu'il faudrait ici au moins deux capots séparés, pour les premiers étages et pour les derniers.
    La difficulté d'un ampli très large bande à fort gain, c'est qu'on n'a pas le droit d'avoir une seule fréquence dans la bande qui couple entrée et sortie, donc il faut faire la chasse aux résonances parasites . Je ne cache pas que ce n'est pas gagné d'avance. Quand les cartes sont très bien routées et blindées, le principal pb qui reste vient des courants de gaine des câbles d'entrée et sortie. Il faut alors des câbles à double blindage pour avoir les impédances de transfert adéquates.
    Dernière modification par gwgidaz ; 08/02/2019 à 17h54.

  13. #10
    polo974

    Re : Probleme d'oscillation sur un ampli RF à fort gain

    le bouclage peut très bien revenir par les alims.

    à une époque (lointaine), pour découpler les alims, je soudais des résistances cms en parallèle sur la piste, ce qui créait des pertes purement résistives (dissipation thermique et non rayonnement), bref, ça générait moins de problèmes de résonances que des selfs de choc et ça coûtait nettement moins cher...
    Daudet, tu vas nous manquer...

  14. #11
    gwgidaz

    Re : Probleme d'oscillation sur un ampli RF à fort gain

    Citation Envoyé par polo974 Voir le message
    le bouclage peut très bien revenir par les alims.

    à une époque (lointaine), pour découpler les alims, je soudais des résistances cms en parallèle sur la piste, ce qui créait des pertes purement résistives (dissipation thermique et non rayonnement), bref, ça générait moins de problèmes de résonances que des selfs de choc et ça coûtait nettement moins cher...
    A ces fréquences, je pense que le mieux, ce sont les ferrites CMS . Aucune résonance, et pas cher. Dans le cas présent, j'imagine qu'il a fait ce qu'il fallait côté alim....Enfin, j'espère.

Discussions similaires

  1. Ampli AD797 - Oscillation
    Par Flo7374 dans le forum Électronique
    Réponses: 35
    Dernier message: 03/04/2014, 13h20
  2. Problème oscillation d'un petit ampli
    Par indri dans le forum Électronique
    Réponses: 3
    Dernier message: 25/05/2012, 10h14
  3. Ampli op Gain X10
    Par marvinl dans le forum Électronique
    Réponses: 15
    Dernier message: 26/05/2010, 14h00
  4. ampli a gain programmable (PGA)
    Par luckygk dans le forum Électronique
    Réponses: 3
    Dernier message: 18/01/2008, 13h22
  5. Amplification à fort gain an tension
    Par WhiteBird dans le forum Électronique
    Réponses: 10
    Dernier message: 08/12/2005, 18h51