Répondre à la discussion
Affichage des résultats 1 à 7 sur 7

DM algorithme / suites urgent SVP




  1. #1
    SiixNews

    DM algorithme / suites urgent SVP

    Bonjour, j'ai un devoir maison en mathématiques pour lundi sur algobox, et je bloque sur la première question malgré mes recherches... Les suites n'ont jamais été mon point fort...
    On a U(0) = 2200 et U(n+1)=0.5*U(n)+100 Et il me faut trouver U(n)
    En calculant les premiers termes j'obtiens :
    U(0) = 2200
    U(1) = 1200
    U(2) = 700
    U(3) = 450
    De plus je trouve U(1)/U(0) = 6/11 et U(2)/U(1) = 7/12 Donc cette suite n'est pas géométrique.
    Et U(1)-U(0) = -1000 et U(2)-U(1) = -500 et U(3)-U(2) = -250 Donc elle n'est pas arithmétique non plus. Cependant on constate que les raisons sont divisées à chaque fois par 2...
    Mais bon ceci ne m'aide toujours pas à définir U(n)...
    Quelqu'un pourrait m'aider s'il-vous-plait ?

    -----


  2. Publicité
  3. #2
    Pisces

    Re : DM algorithme / suites urgent SVP

    Bonjour,

    Tu es en présence d'une suite arithmético-géométrique, je te laisse donc trouver tes réponses (car elles y sont) sur wikipédia dans la rubrique "suite arithmético-géométrique.

    Pisces

  4. #3
    SiixNews

    Re : DM algorithme / suites urgent SVP

    Merci je vais regarder ca de suite !


  5. #4
    Inees7

    Re : DM algorithme / suites urgent SVP

    Bonjour à tous !
    Je suis en 1ere année de BTS informatique et j'ai du mal sur un algorithme :
    "On vous demande de placer une série de mots saisis par un utilisateur dans un tableau de type chaine de caractères.
    Les règles sont les suivantes :
    * L'utilisateur choisit un nombre de mots qu'il va saisir, pas moins de 10 mots
    * Le nombre de mots de cette liste correspondra à la taille du vecteur de stockage
    * Vous devez classer cette liste de mots par ordre alphabétique et ranger ces mots dans le tableau appelé Dictionnaire "
    Si quelqu'un pourrait m'aider ce serait très gentil merciiiiiiiiii !!!!
    FIN

  6. #5
    Pisces

    Re : DM algorithme / suites urgent SVP

    Bonjour Inees7,

    Tout d'abord, je pense qu'il aurait fallu que tu crées un nouveau post pour ne pas mélanger les sujets mais ce n'est pas grave

    Que ne comprends-tu pas exactement dans cet algorithme ? (le raisonnement d'obtention, le codage à réaliser pour obtenir cet algorithme... ?)

    Pisces

  7. A voir en vidéo sur Futura
  8. #6
    Inees7

    Re : DM algorithme / suites urgent SVP

    Oh je suis vraiment désolée.. C'est vrai que cela aurait mieux..

    En fait j'i fait un algorithme mais je ne sais pas si il est bon et quand je le traduit en java il me dit qu'il y a une erreur car l'opérateur ">" n'est pas reconnu avec les chaines de caractères..

    Voici l'algorithme :
    Dictionnaire (n) et Interm en chaines de caractères
    n, i, j en entiers
    DEBUT
    repeter
    ecrire("donner le taille du tableau telque n>=10")
    lire(n)
    jusqu'à (n>9)
    pour i<-- 1 à n faire
    ecrire("donner le mot N°",i)
    lire(Dictioner[i])
    fin pour
    pour i<-- 1 à n-1 faire
    pour j<-- i+1 à n faire
    si Dictioner[i]>Dictioner[j] alors
    Interm<--Dictioner[i]
    Dictioner[i]<--Dictioner[j]
    Dictioner[j]<--Interm
    fin si
    fin pour
    fin pour
    FIN


    Merciiiii

  9. #7
    Pisces

    Re : DM algorithme / suites urgent SVP

    J'ai relevé plusieurs choses dans ton algorithme (dis moi si je me trompe car n'ayant jamais fait de java je vais me baser sur mes connaissances en C++...) :
    - Dans l'algorithme, tu as mis "Dictioner" au lieu de Dictionnaire donc il va y avoir un pb de table inconnue
    - Tu vas surement avoir un problème d'indice car l'indice de ton "tableau" intitulé Dictionnaire commence à 0 et non à 1
    - Je ne pense pas que tu puisse directement utiliser les commande "<, >, =, ..." pour comparer des lettres, il doit y avoir des commandes spéciales pour ça non ?

    J'espère t'avoir aidé avec ces quelques indications, redis moi si tu as toujours des soucis

    Pisces

  10. Publicité

Discussions similaires

  1. Petits calculs
    Par Lilouchkaa dans le forum Mathématiques du collège et du lycée
    Réponses: 10
    Dernier message: 16/08/2012, 10h34
  2. algorithme-programmation en Pascal-urgent svp
    Par yacino15 dans le forum Programmation et langages, Algorithmique
    Réponses: 25
    Dernier message: 23/12/2010, 18h38
  3. ALGORITHME, svp aidez moi
    Par catimini77 dans le forum Mathématiques du supérieur
    Réponses: 0
    Dernier message: 15/11/2009, 00h20
  4. algorithme tableau.m'aider SVP
    Par imakh dans le forum Mathématiques du supérieur
    Réponses: 0
    Dernier message: 05/01/2009, 22h31