Répondre à la discussion
Affichage des résultats 1 à 2 sur 2

Algorithmie Congruence/division eucldienne



  1. #1
    Huntere

    Algorithmie Congruence/division eucldienne

    Bonsoir ,

    quelqu'un pourrait me donner une piste pour l'algorithme 2 et Vérifier si le 1 à l'aire de tenir la route ?
    Merci d'avance !


    1er algorithme,
    "il doit afficher les restes de la divisions euclidienne de A^N par M."

    j'ai fait :

    1 VARIABLES
    2 A EST_DU_TYPE NOMBRE
    3 N EST_DU_TYPE NOMBRE
    4 M EST_DU_TYPE NOMBRE
    5 K EST_DU_TYPE NOMBRE
    6 R EST_DU_TYPE NOMBRE
    7 DEBUT_ALGORITHME
    8 AFFICHER "Saisir le nombre "
    9 LIRE A
    10 AFFICHER "Saisir le modulo"
    11 LIRE M
    12 AFFICHER "Saisir la limite de l'exposant du nombre A"
    13 LIRE K
    14 POUR N ALLANT_DE 1 A K
    15 DEBUT_POUR
    16 R PREND_LA_VALEUR (pow(A,N))%M
    17 SI (R>=0) ALORS
    18 DEBUT_SI
    19 AFFICHER "Pour N ="
    20 AFFICHER N
    21 AFFICHER "le reste R est :"
    22 AFFICHER R
    23 PAUSE
    24 FIN_SI
    25 SINON
    26 DEBUT_SINON
    27 R PREND_LA_VALEUR R+13
    28 AFFICHER "Pour N = "
    29 AFFICHER N
    30 AFFICHER "le reste R est :"
    31 AFFICHER R
    32 PAUSE
    33 FIN_SINON
    34 FIN_POUR
    35 FIN_ALGORITHME


    2er algorithme )

    "il doit afficher, quand c'est possible, le plus petit entier naturel N supérieur ou égal à 1, tel que A^N congrue à 1 modulo M"



    Merci d'avance !

    -----


  2. #2
    gg0

    Re : Algorithmie Congruence/division eucldienne

    Bonjour.

    Pour le deuxième algorithme, tu peux reprendre les idées du premiers, puisque la question est de savoir quand le reste vaut 1.

    Pour le premier, au lieu de calculer AN à chaque fois, tu peux multiplier par A la valeur précédente.
    Je n'ai pas compris pourquoi tu tests si R est positif : Ta fonction reste ne le donne pas automatiquement ? et le R+13 ensuite sort d'où ? Pourquoi 13 ?

    Si tu n'as pas une fonction qui donne le reste (positif) il vaut mieux la construire par programme.

    Je ne peux pas en dire bien plus, je ne connais pas le langage utilisé (pow, %).

    Cordialement.

Sur le même thème :

Discussions similaires

  1. congruence
    Par Ulbritch48 dans le forum Mathématiques du supérieur
    Réponses: 8
    Dernier message: 18/08/2011, 10h47
  2. la division euclidienne et congruence.
    Par charle630 dans le forum Mathématiques du collège et du lycée
    Réponses: 4
    Dernier message: 20/01/2011, 11h38
  3. exercixe spe : Congruence et division euclidienne
    Par tornich' dans le forum Mathématiques du collège et du lycée
    Réponses: 17
    Dernier message: 12/11/2008, 18h15
  4. Congruence
    Par dimacom dans le forum Mathématiques du supérieur
    Réponses: 16
    Dernier message: 02/01/2008, 21h25
  5. congruence
    Par m4x_7 dans le forum Mathématiques du collège et du lycée
    Réponses: 3
    Dernier message: 08/11/2007, 12h47