Répondre à la discussion
Affichage des résultats 1 à 2 sur 2

16F887 avec MPLab 7.5 => CONFIG



  1. #1
    Toufinet

    16F887 avec MPLab 7.5 => CONFIG


    ------

    Bonjour à tous.

    Voilà, j'ai un petit souci quand à la programmation de la config du pic.

    J'ai toujours eu l'habitude de faire ainsi :
    Code:
    __CONFIG _param1 & _param2 & _param3 ...
    Hors pour le 16F887, il semblerait qu'il ne faille pas faire ainsi. En effet, ce PIC contient 2 config word ( _CONFIG1 et _CONFIG2 ).

    Dans ce cas, comment faire ?
    J'ai essayé :
    Code:
    __CONFIG1 _param1 & _param2 etc ...
    mais ça ne fonctionne pas.

    Comment programme-t'on alors la config du 16F887 ?

    Merci.

    -----

  2. #2
    Toufinet

    Re : 16F887 avec MPLab 7.5 => CONFIG

    C'est bon, j'ai trouvé sur un forum de microchip.
    Il faut faire :
    Code:
    __CONFIG _CONFIG1, _param1 & _param2 etc ...
    __CONFIG _CONFIG2, _param1 & _param2 etc ...
    Désolé pour les posts inutiles ( ou pas ... peut-être que ça servira à quelqu'un ).

Sur le même thème :

Discussions similaires

  1. PB Installation MPLAB avec vista
    Par electromo dans le forum Électronique
    Réponses: 5
    Dernier message: 01/09/2007, 19h05
  2. Mplab / 16f887 Tqfp
    Par Toufinet dans le forum Électronique
    Réponses: 5
    Dernier message: 10/02/2007, 13h54
  3. Debuggage avec MPLAB 7.20 ??
    Par Adrian1903 dans le forum Électronique
    Réponses: 2
    Dernier message: 06/05/2006, 08h45
  4. Problèmes MPLAB et ICPROG avec XP
    Par twinotter dans le forum Électronique
    Réponses: 3
    Dernier message: 07/02/2005, 14h24
  5. pb de config avec un routeur
    Par Caesar dans le forum Internet - Réseau - Sécurité générale
    Réponses: 6
    Dernier message: 14/08/2004, 19h04
Découvrez nos comparatifs produits sur l'informatique et les technologies.