Répondre à la discussion
Affichage des résultats 1 à 12 sur 12

Problème voltage Optocoupleur



  1. #1
    Romee

    Problème voltage Optocoupleur


    ------

    Bonjour à tous.

    Alors avant toutes choses, je tiens à vous dire que je suis nul en électronique. Mes connaissances se sont arrêtés aux cours de techno du college et des quelques notions que j'ai pu apprendre sur internet donc autant vous dire, débutant de chez débutant

    Je dois utiliser un optocoupleur sur un circuit.
    C'est un 4N35.
    http://www.google.com/imgres?q=4N35&...1t:429,r:2,s:0

    Mon problème est que la tension qui entre en 5 est différente que celle qui sort du 6.
    En mesurant la tension, j'ai 5V en 5 et 1,7V en 6...

    Est-ce normal?


    Merci beaucoup pour votre aide!

    -----

  2. Publicité
  3. #2
    DAUDET78

    Re : Problème voltage Optocoupleur

    Ton schéma est complétement Shadok .....
    1/ on n'utilise jamais la broche 6 qui est la base
    2/ un optocoupleur ne donne pas de tension. Il lui faut une alimentation externe. Elle est où?
    J'aime pas le Grec

  4. #3
    Romee

    Re : Problème voltage Optocoupleur

    Excuses-moi!

    Oui effectivement, je n'utilises pas la 6 mais la 4.

    Ma tension arrive d'un Arduino, qui est un micro-controlleur qui fourni du 5V.
    Donc ma tension à la sortie de mon arduino et à l'entrée de la broche 5 est de 5V mais seulement de 1,7 V à la broche 4.


    Voilà, dsl pour la confusion!

  5. #4
    DAUDET78

    Re : Problème voltage Optocoupleur

    Citation Envoyé par Romee Voir le message
    Voilà, dsl pour la confusion!
    Faut arrêter les confondaisons !
    Ton µC envoi un courant dans la LED du photocoupleur (broche 1 et 2)
    Ton phototransistor est donc bloqué ou passant. Sans source de tension à droite, tu ne mesureras rien du tout en 4 et 5. Et ton symbole d'interrupteur est complétement folklo !
    J'aime pas le Grec

  6. #5
    Romee

    Re : Problème voltage Optocoupleur

    Oui merci je sais.

    Si il n'y a pas de courant sur les bornes 1 et 2 les bornes 4 et 5 ne laisseront rien passer.
    C'est le principe d'un Optocoupleur.

    Quand j'envoi du courant dans les bornes 1 et 2 c'est passant
    Quand j'en envoi pas, c'est bloqué. Mon problème n'est pas là.

    Je vais essayé d'être plus clair.

    Quand passant:
    Broche 1 entrée 5V
    Broche 2 sortie 5V
    Broche 5 entrée 5V
    Broche 4 sortie 1,7V

    Pourquoi?

  7. A voir en vidéo sur Futura
  8. #6
    DAUDET78

    Re : Problème voltage Optocoupleur

    Citation Envoyé par Romee Voir le message
    Quand passant:
    Broche 1 entrée 5V
    Broche 2 sortie 5V
    Je ne vois pas comment tu mesures 5V sur une broche reliée au Ground .....
    Broche 5 entrée 5V
    Broche 4 sortie 1,7V
    Il faut te le chanter en Grégorien ?
    Tu ne peux pas mesurer de tension sur les broches 4 et 5 : Il n'y a pas d'alimentation à droite du photocoupleur
    J'aime pas le Grec

  9. Publicité
  10. #7
    Snootlab

    Re : Problème voltage Optocoupleur

    Bonjour,

    Je pense qu'il faudrait revenir sur ce qu'est un optocoupleur.
    Rapidement : En faisant circuler un courant (suffisant) à travers la diode, dans le sens
    Arduino -> Résistance -> Patte_1 -> Diode(en interne) -> Patte_2 -> Masse,
    la diode va générer de l'infrarouge, qui va être réceptionnée sur la base du transistor.

    Comme tu le sais, le transistor est un interrupteur commandé.
    Quand on alimente suffisamment sa base, il va permettre de "fermer" un "interrupteur" présent entre le collecteur et l'émetteur,
    permettant au courant de circuler dans le sens Collecteur-> Émetteur (dans le cas du transistor NPN).

    Cela implique deux choses.

    La première, c'est que tu as besoin d'une source d'alimentation, sur le collecteur de ton transistor,
    pour que lorsque tu fasses la commutation et que celui-ci devienne passant,
    du courant puisse être envoyé là où tu le souhaites, après être passé par l'émetteur.
    En effet, cela ne sert à rien d'ouvrir un robinet d'eau pour remplir une bassine, si il n'a pas été raccordé au réseau d'eau au préalable.

    La deuxième est qu'un transistor (ou un optocoupleur dans ce cas), n'est qu'un interrupteur.
    Pour comprendre ton circuit, les causes de ton problème et tout le reste, il est nécessaire de savoir avec quoi tu as interfacé cet interrupteur.

    Donc, postes-nous ton schéma en entier, on comprendra peut-être mieux.

    Et, effectivement, le schéma que tu as posté sur le 4N35 est complètement "Shadok"...

    En espérant t'avoir aidé,

    Bonne journée.

    -----
    Stéphane
    SNOOTLAB - Distributeur Officiel Arduino - Concepteur de shields qui défrisent

  11. #8
    Romee

    Re : Problème voltage Optocoupleur

    Merci Stéphane pour toutes ces précisions.

    Je vais préciser un peu mon circuit.

    Je fais un capacitif sensor sur la base de ce projet:
    http://interface.khm.de/index.php/la...ensing-device/

    C'est une antenne de Thérémin.
    Ça marche parfaitement.
    J'ai ajouté à ce montage une ampoule basse consommation 5220V)qui s'allume en fonction de l'antenne de Theremin. Mon arduino ne peut fournir une telle tension donc l'ampoule est alimenté par du 220V et pour réaliser le ON/OFF j'ai utilisé un relais contrôlé par l'Arduino.

    Donc quand ma main est suffisamment proche de l'antenne, 5V sont envoyés depuis mon Arduino vers le relais, permettant à l'ampoule de s'allumer.
    Mon problème est, comme expliquer dans le lien ci-dessus, que même un bout de fil supplémentaire peut parasiter l'antenne. C'est pourquoi, quand j'alimente mon relais pour qu'il puisse laisser passer le 220V, lui et le fil qui le relis à l'ampoule deviennent eux aussi antennes (j'imagine) et donc la fréquence capté par l'Arduino est beaucoup plus grande lorsque le relais est alimenté.

    Je voulais donc utiliser un optocoupleur pour qu'il n'y ait aucun lien "matériel" entre mon circuit Arduino et le circuit 220V (relais+ampoule basse conso.).
    Voici un schéma plus sérieux de l'optocoupleur:
    http://measure.feld.cvut.cz/groups/edu/osv/4N35.pdf

    La broche 1 de l'optocoupleur est alimenté par mon Arduino, la broche 2 est reliée elle au GND de l'Arduino.
    La broche 4 et 5 sont relié à une alimentation externe de 5V.

    Je récapitule:
    Lorsque l'antenne capte une fréquence suffisante selon un seuil que j'ai , l'Arduino envoie 5V à l'optocoupleur pour que son emetteur et son collecteur laisse passer les 5V d'une alimentation externe (transfo) qui vont activer l'interrupteur de mon relais pour que ce dernier laisse passer les 220V nécessaire à l'alimentation de l'ampoule.

    Mon problème est que l'optocoupleur n'allume pas le relais.
    J'ai utiliser un voltmètre et la tension mesuré sur la broche 5 est de 5V (égale à la tension fourni par mon transo) alors que la tension qui sort de l'optocoupleur au niveau de l'émetteur (broche 4) est seulement de 1,7V.
    Ces 1,7V ne sont pas suffisant pour actionner l'interrupteur de mon relais.

    Est-ce qu'une telle déperdition de tension est normal...

    J'espère avoir apporter les informations nécessaire à la bonne compréhension de mon problème et encore une fois, merci de votre patience.

  12. #9
    DAUDET78

    Re : Problème voltage Optocoupleur

    Citation Envoyé par Romee Voir le message
    Je voulais donc utiliser un optocoupleur pour qu'il n'y ait aucun lien "matériel" entre mon circuit Arduino et le circuit 220V (relais+ampoule basse conso.).
    optocoupleur inutile ... le relais fait l'isolement
    Mon problème est que l'optocoupleur n'allume pas le relais.
    Normal ! ton optocoupleur reçoit un courant de l'ordre de 5mA et il a un gain de 0,4 (voir la spécification ) .... donc il peut piloter un relais qui a un besoin de .....2 mA pour coller!
    les 5V d'une alimentation externe (transfo)
    Ah ! enfin! on y arrive ! Donc ton schéma de départ est bidon
    J'aime pas le Grec

  13. #10
    Romee

    Re : Problème voltage Optocoupleur

    D'ac! merci de ton aide!

  14. #11
    Snootlab

    Re : Problème voltage Optocoupleur

    Bonjour,

    Effectivement, rien ne sert de mettre en oeuvre un optocoupleur si tu as un relais qui va déja agir en isolation galvanique.

    Bonne journée,

    -----
    Stéphane
    SNOOTLAB - Distributeur Officiel Arduino - Concepteur de shields qui défrisent

  15. #12
    Romee

    Re : Problème voltage Optocoupleur

    D'accord merci!

  16. Publicité

Sur le même thème :

Discussions similaires

  1. Optocoupleur
    Par gimmy dans le forum Électronique
    Réponses: 10
    Dernier message: 24/05/2009, 17h29
  2. probleme Transistor en mode commutation et voltage
    Par cookieParis dans le forum Électronique
    Réponses: 21
    Dernier message: 02/09/2008, 23h22
  3. Optocoupleur
    Par Michael37 dans le forum Électronique
    Réponses: 3
    Dernier message: 30/05/2007, 11h29
  4. Optocoupleur
    Par myst33 dans le forum Électronique
    Réponses: 8
    Dernier message: 12/04/2007, 01h02
  5. optocoupleur
    Par trece dans le forum Électronique
    Réponses: 10
    Dernier message: 15/01/2005, 15h27
Découvrez nos comparatifs produits sur l'informatique et les technologies.