Répondre à la discussion
Affichage des résultats 1 à 21 sur 21

Help pont en H je m'en sort pas...



  1. #1
    biduleur34

    Help pont en H je m'en sort pas...


    ------

    Bonjour,
    depuis lusieur moi j'essaye de metre au point une carte pour alimenté un moteur DC brusched.
    Cette carte integre un recepteur RS485 pour le codeur, une sortie pour alimenté le frein en continue.

    Toute la partie logique de controle du pont fonctionne, mais des que je met sous tension j'ai systematiquement un mosfet qui fume, referencé BH sur mon schema.
    J'ai pris tres son de mon layout, mes drivers sont en CMS ce sont des HIP2101.

    Les valeur sont celle du schema, sauf les condo, c22 c24 c25 c5 qui sont des 100nf au lieu des 10nf. Les diode zener d6 d7 d8 d9 ne sont pas n place non plus.
    mon alim est decouplé par un condo low esr 470UF 100V.
    le tout alimenté en 45V DC.
    frequence de decoupage 20kHz

    merci de votre aide

    -----
    Fichiers attachés Fichiers attachés
    Dernière modification par biduleur34 ; 16/10/2011 à 09h12.

  2. Publicité
  3. #2
    DAUDET78

    Re : Help pont en H je m'en sort pas...

    - Quelle est la valeur de R39? R49 ? si tu piques trop de courant pour les LEDs, tu n'as plus un niveau haut suffisant
    - Valeur de R5 C7 et référence du comparateur ?
    - Comment est faite la limitation de courant? DEFAUT va sur un µC ? Donc il faut 3 plombes pour qu'il réagisse et coupe le PWM ...... On passe généralement par un circuit hard qui bloque le PWM immédiatement quand le courant dépasse la valeur la limite
    J'aime pas le Grec

  4. #3
    biduleur34

    Re : Help pont en H je m'en sort pas...

    Citation Envoyé par DAUDET78 Voir le message
    - Quelle est la valeur de R39? R49 ? si tu piques trop de courant pour les LEDs, tu n'as plus un niveau haut suffisant
    - Valeur de R5 C7 et référence du comparateur ?
    - Comment est faite la limitation de courant? DEFAUT va sur un µC ? Donc il faut 3 plombes pour qu'il réagisse et coupe le PWM ...... On passe généralement par un circuit hard qui bloque le PWM immédiatement quand le courant dépasse la valeur la limite
    R39 et R49 sont des ressitance de 330Ohm j'ai remarqué durant la phase debuguage que le niveau haut des porte logique qui alimente les diode sont a 3.5V au lieu de 5V .

    R5=1K et c7 100nF le comparateur est un comparateur rapide max9031.

    Le comparateur et l'ensemble des circuit logique coupe la commande logique de la partie haute du pont, la bascule memorise le defaut le temp que le pc reagisse.

  5. #4
    biduleur34

    Re : Help pont en H je m'en sort pas...

    En fait je n'est pas etait bien clair dans mon premier post, le mosfet ne grille pas a la mise sous tension, mais des que je demande un mouvement.

    voici le PCB

    PCB_cms.png

  6. A voir en vidéo sur Futura
  7. Comparatifs

    Gagnez du temps et de l'argent grâce à nos comparatifs de produits. Parmi nos sujets :
  8. #5
    DAUDET78

    Re : Help pont en H je m'en sort pas...

    Citation Envoyé par biduleur34 Voir le message
    le mosfet ne grille pas a la mise sous tension, mais des que je demande un mouvement.
    D’où ma question sans réponse
    Citation Envoyé par DAUDET78 Voir le message
    Comment est faite la limitation de courant? DEFAUT va sur un µC ? Donc il faut 3 plombes pour qu'il réagisse et coupe le PWM ...... On passe généralement par un circuit hard qui bloque le PWM immédiatement quand le courant dépasse la valeur la limite
    J'aime pas le Grec

  9. #6
    biduleur34

    Re : Help pont en H je m'en sort pas...

    je pensez avoir repondu a la question
    Le comparateur et l'ensemble des circuit logique coupe la commande logique de la partie haute du pont, la bascule memorise le defaut le temp que le PC reagisse.
    .

    La sortie 3 de IC6 valide le fonctionnement du PWM
    merci

  10. Publicité
  11. #7
    DAUDET78

    Re : Help pont en H je m'en sort pas...

    Sorry, j'avais pas vu .... c'est un PC qui pilote la limitation de courant ? Ce n'est pas 3 plombes .... mais 6 plombes qu'il met à réagir ! Ne cherche pas plus loin ....
    J'aime pas le Grec

  12. #8
    biduleur34

    Re : Help pont en H je m'en sort pas...

    Non ce n'est pas un pc qui gere la limitation du courant, c'est les porte logique, le signal est memorisé par la bascule et envoyer au pc a travers un optocoupleur on peu voir que en bas de la bascule on coupe PWM si on est en defaut.

    Pour faire un peu avencé le shimblick les IC sont un 74HC00 et un 74F08.

    En fait pour etre plus precis j'ai deja grillé 3 mos, la premiere fois le mos BH, ensuite j'ai rajouté ma capa de decouplage 470UF 100V, et a l'essaye suivant j'ai grillé BH et BL.
    donc surement un probleme de cross conduction toujours coté B.
    A chaque fois ma protection en courant semble reagir mais trop tard.
    pour le moment la parti retour du defaut vers le PC n'est pas gere par le PC, mais aucune importance car la coupure du courant se fait en hard sur la carte grace au 74F08.

    merci
    Dernière modification par biduleur34 ; 16/10/2011 à 12h43.

  13. #9
    biduleur34

    Re : Help pont en H je m'en sort pas...

    est ce que le fait de tiré trop de courant pour alimenté ma diode defaut ralentirai la comutaion de IC6A et pareillement est ce que LED2 tirerai trop de courant afin de ralentir la comutation de IC2B

    Mais dans tous les cas il ne devrait pas y a voir de defaut..

    merci
    Dernière modification par biduleur34 ; 16/10/2011 à 12h49.

  14. #10
    biduleur34

    Re : Help pont en H je m'en sort pas...

    Autre piste de reflection, si on par sur l'hyppothese qu'il y a un probleme de crossconduction sur le coté B, on deuit donc que BL est passant en meme temp que BH.Ayant suffisament retardé la comutation des mos grace au resistence de 270 ohm pour Ton et 12ohm pour toff. je peut supposé que le probleme ne vienne pas de la mais directement de DIR/_BLI qui reste trop longtemp a 1.

    DIR/_BLI est direct en sortie de l'optocoupleur, qui a une resistance de pull up de 1.5kohm.

    qu'en pensez vous ?

  15. #11
    biduleur34

    Re : Help pont en H je m'en sort pas...

    Suivant ce meme raisonement, en considerant que DIR/_BLI soit a 1 et donc que BL soit passant.
    pour qu'il y est un soucis il faut que la coupure du mosfet sois plus lente que la comutation de IC6C + IC2D + Ton de BH. ce qui parait peu probable non ??

  16. #12
    DAUDET78

    Re : Help pont en H je m'en sort pas...

    Avec toutes les étiquettes que tu as sur ton schéma, on ne voit pas qui gère quoi ... quelles sont les signaux internes et externes.
    Tu parles de photocoupleur , il y a le OV d'un coté et le 0V de l'autre ....ils servent à rien

    Fait un schéma , sans RS422, sans brake , bref sans les trucs qui servent à rien dans ton pont H, et tire les ficelles qui servent localement
    J'aime pas le Grec

  17. Publicité
  18. #13
    biduleur34

    Re : Help pont en H je m'en sort pas...

    les optocoupleur sont bien isolé, et sont alimenté par la carte externe pour les signaux sortant et par ma carte pour les signaux entrant, c'est peu etre pas clair sur mon schema mais je suis sur de moi sur ce coup la.
    par contre, je vient de faire un essaye, j'ai remplacé le moteur par une ampoule alogene alimenté en 5V sur le rail puissance.
    j'ai demonté l'optocoupleur de ma carte afin de simulé le fonctionement de celui ci par des bout de fil, et mon pont en H fonctionne bien en forcant PWM a 1 et en comutant DIR de maniere aleatoir avec un bout de fil.
    mais a force de faire j'ai reussi a declenché la protection en courant, ce qui n'est pas normal..
    apres reset du defaut, tout refonctione comme avant sauf defaut courant quand je titille trop le DIR.

    je refait mon schema simplifié.

    merci
    Dernière modification par biduleur34 ; 16/10/2011 à 15h38.

  19. #14
    fabang

    Re : Help pont en H je m'en sort pas...

    Pourrais-tu donner la référence des MOS, celle des diodes (DAH,DBH..), référence des diodes (D1) et justifier la présence d'un condensateur de 100nf (C5) aux bornes de D1, qui annule tout l'intérêt de D1.
    D1 doit servir à mieux maitriser le Tr et Tf, ce qui ne dispense pas de prévoir un dead time dans le pilotage des MOS. D'autre part il est impératif que le temps de recouvrement des diodes (pour le courant considéré) soit plus court que le Tr des MOS.
    La surveillance de I pont avec un comparateur, c'est bien, mais quelles sont les valeurs de R5 et C7. D'une façon générale, un schéma sans les valeurs des composants présente peu d'intérêt. De plus le nom de signal DIR/ALI sur le HIP2101 m'inquiète un peu, ce circuit ne gère pas la notion de DIR.

  20. #15
    biduleur34

    Re : Help pont en H je m'en sort pas...

    J'ai simplifié un peu..

    H-BRIDGE MESA simplifié.pdf

    si c'est bien un probleme de X conduction je pense que le probleme doit se trouver entre IC2D IC2C et IC6D. Le PWM sort de IC2B.

    merci
    Dernière modification par biduleur34 ; 16/10/2011 à 16h21.

  21. #16
    biduleur34

    Re : Help pont en H je m'en sort pas...

    Citation Envoyé par fabang Voir le message
    Pourrais-tu donner la référence des MOS, celle des diodes (DAH,DBH..), référence des diodes (D1) et justifier la présence d'un condensateur de 100nf (C5) aux bornes de D1, qui annule tout l'intérêt de D1.
    D1 doit servir à mieux maitriser le Tr et Tf, ce qui ne dispense pas de prévoir un dead time dans le pilotage des MOS. D'autre part il est impératif que le temps de recouvrement des diodes (pour le courant considéré) soit plus court que le Tr des MOS.
    La surveillance de I pont avec un comparateur, c'est bien, mais quelles sont les valeurs de R5 et C7. D'une façon générale, un schéma sans les valeurs des composants présente peu d'intérêt. De plus le nom de signal DIR/ALI sur le HIP2101 m'inquiète un peu, ce circuit ne gère pas la notion de DIR.
    Les mosfet sont des IRF540N
    Les diodes DAH et DBH sont des diodes rapide 200V 2A type BYV27 "je n'est plus la ref en tete.
    D1 D3 D5D7 sont des 4148.
    les condo en paralele sur ces diode sont la pour evité les pic de tension a la comutation de celle ci, c'est une erreur ? sont cablé actuellement des 100nf mais a la base j'avait prevu des 10nF.
    R5 vaut 1k ohm et C7 100nF.

    Concernant l'apelation DIR/ALI c'est peu etre une apelation mal adroite, oui le HIP 2101 ne gere pas le dir , juste qu'en sortie le l'optocoupleur dir j'attaque directement le HIP.

    merci

  22. #17
    biduleur34

    Re : Help pont en H je m'en sort pas...

    condensateur de 100nf (C5) aux bornes de D1, qui annule tout l'intérêt de D1
    peu tu me preciser pour quelle raison ??
    merci

  23. #18
    biduleur34

    Re : Help pont en H je m'en sort pas...

    Comme precisé plus haut je n'est pas de dead time pour le pilotage de mes mosfet, j'ai ralentit mes mos uniquement avec les resistance de gate.
    peu etre que 270ohm ce n'est pas suffisant. ???

  24. Publicité
  25. #19
    fabang

    Re : Help pont en H je m'en sort pas...

    Si tu mets un condensateur aux bornes de la 1N4148, cette diode ne sert plus a rien, surtout que le condensateur à une valeur très supérieure à la capa de gate du MOS. Du coup tu n'as plus de différence entre le Rgate présenté au MOS pour le switch On et pour le Switch Off.
    La diode 1N4148 n'est pas bien dimensionnée, elle ne supporte pas plus de 450mA, il lui faudrait donc une résistance en série de plus de 20ohms, je vois 10 sur le schéma.
    Supprime la capa, et deux résistances 20 et 120ohms devrait aller pour la commande des MOS.
    Quel est le courant d'appel du moteur? ou qu'as-tu comme info sur sa résistance de bobinage et inductance?

  26. #20
    biduleur34

    Re : Help pont en H je m'en sort pas...

    merci, je vais essaye ça, donc d'apres toi le souci vien de la la gate du mosfet qui reste chargé et le mos reste ON trop longtemp ??

    le moteur est doné pour 200W sous 75V 3.6 A en courant nominal, mais actuellement il est alimenté sous 42V.

    merci

  27. #21
    biduleur34

    Re : Help pont en H je m'en sort pas...

    Bonjour,
    j'ai donc fait les modif conseillé plus haut, et pour le moment ça fonctione. j'ai donc suprimé le condensateur de 100nf et remplacer la resistance de 12ohm par une de 50ohm.
    pour le moment j'ai une resistance de 470ohm pour le Ton et 50ohm pour le Toff. que pensez vous de ces valeurs, je peu baissé celle de 470ohm ??

    sinon coment retardé la comutation de mon mosfet ??
    merci

Discussions similaires

  1. Inéquation : please je m'en sort pas :(
    Par Dreamoflove dans le forum Mathématiques du collège et du lycée
    Réponses: 3
    Dernier message: 12/10/2011, 11h32
  2. [Blanc] friteuse, je m'en sors pas!
    Par Godblessme dans le forum Dépannage
    Réponses: 3
    Dernier message: 03/07/2009, 10h01
  3. Je m'en sort plus avec Iris
    Par cuda71 dans le forum Matériel astronomique et photos d'amateurs
    Réponses: 15
    Dernier message: 23/02/2009, 14h26
  4. je ne m'en sort pas avec les x2!
    Par lisa65 dans le forum Mathématiques du collège et du lycée
    Réponses: 9
    Dernier message: 03/02/2009, 15h57
  5. Calculs : je m'en sors pas !
    Par Noé38 dans le forum Chimie
    Réponses: 10
    Dernier message: 29/02/2008, 08h48
Découvrez nos comparatifs produits sur l'informatique et les technologies.