Répondre à la discussion
Affichage des résultats 1 à 15 sur 15

Problème Pont en H MosFET



  1. #1
    hissokaaaa

    Problème Pont en H MosFET


    ------

    Bonjour,
    Je suis entrain de réaliser une commande pour un moteur à CC (500mA, 12V) avec un pont en H avec deux mosfet P et deux mosfet N (IRFZ24) , j'ai trouvé le schéma sur le net et me semble correcte.
    Le problème est lorsque je mets A et D en état Haut le moteur tourne dans un sens.
    Lorsque je met C et B en état Haut rien ne se passe ....
    Aide SVP...
    Le schéma est ci-joint

    -----
    Images attachées Images attachées  

  2. Publicité
  3. #2
    hissokaaaa

    Re : Problème Pont en H MosFET

    Personne n'a rencontrer un tel problème ??

  4. #3
    vincent66

    Re : Problème Pont en H MosFET

    Bonsoir,
    Le schéma semble correct, il doit y avoir une erreur dans son implémentation physique, mauvaise soudure ou court-circuit...
    Vincent
    Leonardo était ingénieur "sans papier", et moi diplômé juste...technicien...

  5. #4
    Antoane
    Responsable technique

    Re : Problème Pont en H MosFET

    Bonjour,
    Juste pour préciser que le montage n'est pas adapté à un fonctionnement en PWM (diodes et commutation des MOS trop lentes), je ne sais pas si tu en es conscient.
    Dernière modification par Antoane ; 07/07/2012 à 09h28.
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  6. A voir en vidéo sur Futura
  7. #5
    hissokaaaa

    Re : Problème Pont en H MosFET

    Merci vincent66 et Antoane pour vos réponses;
    @Antoane à vrai dire je le savais pas par contre je sais que les mosfet n'engendrent pas de grandes pertes si on augmente la période du signal PWM , c'est ça non??

    existe-t-il des montages adaptés à un fonctionnement en PWM ou y a seulement les CI ?

  8. #6
    Antoane
    Responsable technique

    Re : Problème Pont en H MosFET

    Citation Envoyé par hissokaaaa Voir le message
    les mosfet n'engendrent pas de grandes pertes si on augmente la période du signal PWM , c'est ça non??
    Une bonne partie des pertes à lieu lors des commutations, elles diminuent donc avec l'augmentation de la période du signal.

    comment sont génèrés les signaux de commande A, B, C & D ?
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  9. Publicité
  10. #7
    hissokaaaa

    Re : Problème Pont en H MosFET

    Les signaux PWM sont générés avec un PIC 16F877, pour le protéger bien évidement j'ai mis un opto-coupleur .

  11. #8
    Qristoff
    Animateur Électronique

    Re : Problème Pont en H MosFET

    Juste pour préciser que le montage n'est pas adapté à un fonctionnement en PWM (diodes et commutation des MOS trop lentes), je ne sais pas si tu en es conscient
    je ne vois pas pourquoi tu dis ça ? je t'accorde que les diodes 1N4004 ne servent à rien ici (elles ne conduiront jamais en fait car les diodes de body de l'IRFZ24 sont bien meilleures en Vf) et quand on place des diodes en parallèle d'un mos, il faut insérer une autre diode dans la source pour forcer le chemin de retour du courant.
    Le circuit PWM peut trés bien n'attaquer que les mos du bas et dans ce cas, le circuit fonctionne trés bien ! La commande des mos P sera peut être un peu plus lente (constante de temps à vérifier selon la capacité de grille des IRF9Z30) mais rien n'empéche fonctionnellement d'appliquer aussi du PWM.
    Par contre c'est la commande à base d'opto-coupleur qui risque de limiter grandement tout ce petit monde, mais sans schéma précis on ne peut rien dire.
    Tout existe, il suffit de le trouver...!

  12. #9
    polo974

    Re : Problème Pont en H MosFET

    utiliser des mos aussi gros pour 500mA
    utiliser des mos aussi vieux (ok, on voit encore des schémas avec des 2n3055...)
    utiliser une pullup pour couper les pmos
    utiliser des diodes 1A en roue libre de transistors capable de 17A
    utiliser des 1n4004 trop lentes

    bon heureusement, comme l'a indiqué Qristoff, les 1n4004 sont là pour décorer...
    perso, je réduirais les 10k, sinon, il risque d'y avoir conduction simultanée dans les changements de sens.

    enfin, pour la panne, car c'est une panne, il faut vérifier et mesurer.
    comme le montage est symétrique, ça doit un peut aider (mesure coté qui marche, inversion de sens, comparaison).
    Jusqu'ici tout va bien...

  13. #10
    Antoane
    Responsable technique

    Re : Problème Pont en H MosFET

    Les diodes de body ont des caractéristiques minables, donc il vaut mieux les doubler, non ?

    il faut insérer une autre diode dans la source pour forcer le chemin de retour du courant.
    Ca, j'ai pas saisi ?

    J'avais pas pensé à ne PWMer que les mos du bas, c'est sûr que c'est bien plus futé.

    Pour l'IRF9Z30 : http://www.irf.com/product-info/data...ta/irf9z30.pdf
    Qg = 39nC @Vgs=-10V, donc constante de temps de 40µs, sur une période de 100µs (@10kHz), ça fait beaucoup. Mais si on gère effectivement le PWM que par le bas, c'est ok.
    Au passage : dans la datasheet, quelle charge faut-il considérer ? je prend toujours la plus grande, mais est-ce que Qgs suffit ?
    Dernière modification par Antoane ; 08/07/2012 à 10h49.
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  14. #11
    Qristoff
    Animateur Électronique

    Re : Problème Pont en H MosFET

    Les diodes de body ont des caractéristiques minables, donc il vaut mieux les doubler, non ?
    pas nécessairement ! Il faut bien choisir son mos suivant l'application, mais il y a des mos de compét avec des diodes trés performantes ! il faut bien lire les datasheet.
    Ca, j'ai pas saisi ?
    Si tu ajoutes une diode en parallèle, il faut s'assurer que c'est bien elle qui conduit et non pas la diode de body (comme c'est le cas ici). De plus, il faut en prendre une avec un temps de recouvrement meilleur que celle du mos. Pour garantir que c'est bien la diode ajoutée en parallèle qui va conduire, on insère une diode (généralement du même type que celle on met en parallèle) en série avec le mos dans la source. Ainsi, lorsque le courant est positif, il passe par le mos et lorsqu'il est négatif, il est obligé de passer par la diode parallèle.
    Tout existe, il suffit de le trouver...!

  15. #12
    hissokaaaa

    Re : Problème Pont en H MosFET

    Bon j'arrive pas à trouver le problème, j'ai changé donc le montage, et ça a marché

    MERCI A VOUS TOUS

  16. Publicité
  17. #13
    Tonave72

    Re : Problème Pont en H MosFET

    Salut hissokaaaa,

    Pourrai tu mettre le schéma STP?

    J'avoue que j'ai un petit montage un peu dans ton style à réaliser pour une commande perso et si le tiens marche pourquoi pas l'étudier et le reprendre?

    Par avance, merci!
    Rien ne se perd, rien ne se crée, tout se transforme. Lavoisier

  18. #14
    hissokaaaa

    Re : Problème Pont en H MosFET

    Salut
    en fait le montage si joint je l'ai réalisé avec des transistor je suis entrain chercher des mosfet qui répondent à mes besoins mais j'imagine que l'idée du montage est la même
    Nom : Robinson_H_bridge_rev1.gif
Affichages : 55
Taille : 10,1 Ko

  19. #15
    Tonave72

    Re : Problème Pont en H MosFET

    Salut,

    Ah oui en effet la philosophie est la même....

    Merci!
    Rien ne se perd, rien ne se crée, tout se transforme. Lavoisier

Discussions similaires

  1. Pont H avec MOSFET
    Par waldoman dans le forum Électronique
    Réponses: 4
    Dernier message: 12/05/2011, 08h32
  2. Pont en H et MOSFET canal N
    Par freax dans le forum Électronique
    Réponses: 20
    Dernier message: 06/04/2009, 21h16
  3. Identification Mosfet pont en H
    Par junior1978 dans le forum Électronique
    Réponses: 3
    Dernier message: 21/08/2008, 15h18
  4. Pont en H avec MOSFET
    Par Mr.FLY dans le forum Électronique
    Réponses: 2
    Dernier message: 05/03/2007, 16h47
  5. Pont en H avec Mosfet
    Par Agahaz dans le forum Électronique
    Réponses: 8
    Dernier message: 14/11/2006, 13h48
Découvrez nos comparatifs produits sur l'informatique et les technologies.