Répondre à la discussion
Affichage des résultats 1 à 16 sur 16

Ampli d'instrumentation non linéaire




  1. #1
    sly37

    Ampli d'instrumentation non linéaire

    Bonjour à tous,

    J'ai besoin de convertir le signal provenant d'un capteur de pression (pont de wheastone) pour qu'il soit lisible par mon µC.
    J'ai utilisé le montage d'un ampli d'instrumentation classique.

    Le produit final devra fonctionner sur pile allant de +3.6V à +3V.
    Le but étant que le µC interprète toujours la même valeur de pression quelque soit la tension d'alim.

    Voici le montage ampli seul sans le µC et le reste du sché
    sch1.JPG

    Vu que ça marche pas top, pour mes tests j'ai remplacé le capteur pour 4 résistances qui me reforment le pont.

    Et voici le résultat de mesure en fonction du niveau Valim :
    Tab1.JPG

    A partir d'une certaine valeur d'alimentation, je perd la linéarité alors que les tensions d'entrées et sorties des amplis sont loin du Valim.
    De plus l'ampli AD8606 est RtoR entrée/sortie, faible offset ...

    Je comprends pas la non linéarité du montage.
    Je l'ai testé sous PSPICE et ça marche nikel.

    Je pensais à des erreurs de mode commun mais à l'origine j'avais un gain de 400 au 1er étage un gain 1 au 2nd étage mais j'arrivais en saturation d'où le gain de 1.8 au 2nd étage.
    De plus le problème était identique.

    Autre test, j'ai mis en court-circuit la mesure du pont et je suis toujours non-linéaire lorsque que je lis les sorties 1 et 7 de U3.

    Avez-vous une explication ou des infos à me fournir ?
    Merci beaucoup par avance.

    -----


  2. Publicité
  3. #2
    DAUDET78

    Re : Ampli d'instrumentation non linéaire

    - Sans lien WEB sur la datasheet des ampliOPs....
    - Sans lien WEB sur la datasheet du capteur....

    PS : le câblage de U6B n'est pas bon ..... probablement 5=0V et 6=B
    L'age n'est pas un handicap .... Encore faut-il arriver jusque là pour le constater !

  4. #3
    sly37

    Re : Ampli d'instrumentation non linéaire

    Merci pour le retour DAUDET78.

    Datasheet de l'ampli :
    http://www.analog.com/static/importe..._8606_8608.pdf

    Datasheet capteur de pression :
    http://www.metallux.ch/sites/default...0ME501_B_1.pdf

    Pour U6B, les entrées de l'ampli non-utilisé sont à la masse !
    Je ne comprends pas ta remarque.


  5. #4
    fabang

    Re : Ampli d'instrumentation non linéaire

    Donne nous la valeur des résistances qui forment le pont, on ne connait que la valeur de la tension d'alim et la tension de sortie constatée.
    L'ampli diff de sortie avec des résistances à 1%, ce sera pas top pour la réjection de mode commun inévitable de ce montage.
    Tu parles de 1 et 7 de U3, tu veux dire 1 de U3 et 7 de U5?
    Quand tu mets la sortie de pont en CC, tu conserves bien la tension de mode commun d'environ 2V?
    Si tes AOP sont rail to rail en entrée, c'est pas tout à fait vrais pour la sortie. Refais nous le relevé de tension des trois sorties en fonction de la tension d'alimentation.

  6. #5
    sly37

    Re : Ampli d'instrumentation non linéaire

    Bonjour,

    J'ai copier/coller mon schéma d'origine avec Orcad, qui m'a renommé les amplis.
    Donc voici le vrai schéma:
    sch1.JPG

    Le Vampli varie de +3 à +3.6V environ.
    Les valeurs mesurées sont dans la seconde image du 1er post.

    En théorie, lorsque la tension Vampli varie, la sortie de U5A varie proportionnellement.
    Dans si mon µC mesure la tension Vampli et la tension de sortie, puis fait le rapport des deux, cela me donne l'image de la tension aux bornes du pont.
    Et par conséquent la valeur de pression.

    Comme je l'écris dans le 1er post, j'ai remplacé le capteur par un pont de résistances. Ceci permet de faire abstraction de la variation de pression d'un jour sur l'autre pour les essais.
    Je ne connais pas exactement les valeurs du pont de R au milliohm près mais peut importe...
    On peut réfléchir sur le montage en lui même et l'expérience que vous en avez dans ces conditions de variation d'alim.

  7. A voir en vidéo sur Futura
  8. #6
    fabang

    Re : Ampli d'instrumentation non linéaire

    La seule explication possible de ton problème étant que la tension de sorite d'un des amplis approche du rail d'alimentation 0v ou +V.
    On peut le vérifier par calcul si on connait les valeurs des résistances utilisées pour simuler le pont. Pour le moment on ne sait pas.

  9. #7
    sly37

    Re : Ampli d'instrumentation non linéaire

    Dans le 1er schéma du 1er post j'indique 5K et 7.5K en guise de pont de R.
    En faisant les mesures au multimètre, les sorties de U3 de sont pas du tout saturées.
    Et au scope il n'y a pas d'oscillations !

    Je pensais aussi à une histoire de flux de soudure conducteur mais après avoir nettoyé de mlutiples fois, ça ne change rien.
    J'ai même été jusqu'à changer tous les composants du montage et nettoyer le PCB avant remontage.

    Au vu de la courbe, c'est comme si le gain changeait en fonction de la tension d'alim.

  10. Publicité
  11. #8
    fabang

    Re : Ampli d'instrumentation non linéaire

    Donc il faut prendre les valeurs du pont du premier schéma les nom des composants du second schémas et les tolérances de résistances du premier ou du second pour savoir ce qui est réellement câblé?

  12. #9
    fabang

    Re : Ampli d'instrumentation non linéaire

    Ne laisse pas l'ampli non utilisé en boucle ouverte, ça peut poser des problèmes. Mets l'entrée + à 0V si tu veux, et reboucle la sortie avec l'entrée moins.

  13. #10
    fabang

    Re : Ampli d'instrumentation non linéaire

    quand tu mets en court-circuit les sorties du pont, tu devrais avoir 0V (V saturation bas en fait) quelque soit la tension d'alimentation. Pourquoi tu parles de linéarité de la réponse dans ce cas?

  14. #11
    jiherve

    Re : Ampli d'instrumentation non linéaire

    Bonjour,
    J'attire ton attention sur le fait d'utiliser des résistances discrètes, elles ont beau être précises (quoique 0,1% c'est leger) elle n'en sont pas pour autant égales et c'est rédhibitoire pour tout les problème de réjection de mode commun ce qui semble être ton cas.
    Il faut OBLIGATOIREMENT utiliser des réseaux de résistances dont la valeur importe peu tant que l'appairage perdure car ce type de montage ne dépend que du rapport des résistance, surtout le dernier étage.J’équilibrerais aussi un peu mieux le gain entre les deux étages.
    Ici il te faudra un réseau de 10K, un de 18k,et une esseulée.
    JR
    l'électronique c'est pas du vaudou!

  15. #12
    sly37

    Re : Ampli d'instrumentation non linéaire

    Bonjour jiherve,

    Quand tu parles de réseau de R, toutes les résistances du réseau dérivent de la même manière ? Et elles sont toutes égales ?
    En regardant un peu sur le net, les réseaux de R ont un prix non négligeable... ça pique.

    Pour l'équilibrage des étages, je ne suis pas tout à fait d'accord car plus on amplifie au 2ème étage plus les erreurs due au mode commun sont importantes.
    Ou bien mon raisonnement est faux.

  16. #13
    fabang

    Re : Ampli d'instrumentation non linéaire

    Avec des résistances à 1% tu as une réjection de mode commun de 40dB, donc avec un gain de 200 les amplis sont dans le mur (Saturé) avec les 2V de mode commun du montage. C'est pour ça que j'insistai sur la tolérance des résistances. Sur un amplificateur d'instrumentation les résistances sont équilibrées (La valeur exacte n'a pas d'importance) au laser à lieux que 0,001% pour atteindre 80dB de réjection de mode commun. Avec des résistances discrètes qu'on ne peut pas équilibrer, on est contraint de prendre des résistances de haute précision pour arriver au résultat, et c'est cher. La solution la plus économique c'est acheter un amplificateur d'instrumentation.

  17. #14
    fabang

    Re : Ampli d'instrumentation non linéaire

    Ce que tu n'as pas fait dans ta simulation sous Spice, c'est d'introduire les erreurs de tolérances sur les résistances, ça change pas mal le résultat. Faire attention à rechercher le sens critique des erreurs de chaque résistance pour savoir jusqu'ou le montage peut disfonctionner.

  18. #15
    jiherve

    Re : Ampli d'instrumentation non linéaire

    Re
    Oui dans un réseau de bonne qualité toutes les résistances ont la même valeur et dérivent de concert ce qui évite bien des problèmes, au final c'est moins cher que des résistances discrètes de grande précision.
    Sur l’étage final avec des 0,1% discrètes la précision c'est 0,4% au mieux.
    Ton raisonnement est juste mais il faut tenir compte de la tension d'offset du premier étage dont l'effet sera proportionnel à son gain , tout est question de mesure.
    JR
    l'électronique c'est pas du vaudou!

  19. #16
    sly37

    Re : Ampli d'instrumentation non linéaire

    Bonjour,

    Je rappelle qu'à l'origine du montage, la référence de l'ampli utilisé était un AD8606.
    Datasheet AD8606 : http://www.analog.com/static/importe..._8606_8608.pdf

    Après de multiples essais et mesures, j'ai décidé de changer de référence d'ampli.
    Je suis partit sur un TL082... et là bingo ça marche, pas de variation inexpliquée de la tension de sortie en fonction de la tension d'alim.
    Comme le TL082 n'est pas RtoR, j'ai choisi un LTC2051HVHS8 que j'avais en stock.
    Datasheet LTC2051HVHS8 : http://www.farnell.com/datasheets/1575791.pdf

    Avec celui ci ça fonctionne aussi.
    Illustration du phénomène.
    Dessin1.jpg

    Pour l'instant je n'arrive pas à comprendre pourquoi l'AD8606 provoque ce phénomène sachant qu'entre les différents changements d'ampli, rien d'autre n'a changé.

    J'aime pas rester dans l'inconnu même si ma solution de changer d'ampli fonctionne donc si quelqu'un a une piste qui m'aiderait à comprendre... je suis preneur.

    Merci d'avance.

Sur le même thème :

Discussions similaires

  1. Problème Pré-ampli et Ampli
    Par iSmouz76 dans le forum Électronique
    Réponses: 56
    Dernier message: 23/12/2013, 17h51
  2. Réponses: 9
    Dernier message: 07/08/2009, 00h22
  3. Ampli de classe A: meilleur qu'un ampli de commerce?
    Par Bourkanieche dans le forum Électronique
    Réponses: 8
    Dernier message: 24/06/2009, 21h08
  4. Ampli op en suiveur ou ampli op en ampli de tension?
    Par Xezbeth dans le forum Électronique
    Réponses: 7
    Dernier message: 13/08/2008, 17h29
  5. [Brun] panne ampli pré-ampli
    Par epo4807 dans le forum Dépannage
    Réponses: 1
    Dernier message: 17/02/2008, 17h46