Répondre à la discussion
Affichage des résultats 1 à 16 sur 16

Test de diode différent seule ou connectée au circuit.




  1. #1
    Valohxc

    Test de diode différent seule ou connectée au circuit.

    Bonjour,

    Je suis en train de construire une pédale d'effet pour guitare DIY et j'ai un composant qui me pose problème : la diode...

    Je précise que tous les éléments ne sont pas encore montés sur le circuit imprimé (il manque des condo, des transistors et les potentiomètres mais quand je prend mes mesures sur la diode soudée à la carte, j'obtiens un passage de courant dans les deux sens (bip sur le multimètre) et une tension proche de 0 dans les deux sens, ce qui s'apparenterait à un court-circuit de la diode...

    Mais voila, une fois déconnectée, celle-ci répond au test normalement : 835mv dans un sens et aucun contact dans l'autre sens !!

    Je l'ai donc ressoudée et même problème qu'au début, ça bip dans les deux sens et courant quasi nul...

    Est-ce que ça peut être du au fait que pas mal de composants ne sont pas encore sur la carte ?

    Ou alors à un défaut de la carte ? Ou à la diode ? (C'est une 2N3904 silicium)

    Je joins une photo.IMG_20190119_214937.jpg

    Merci

    -----


  2. Publicité
  3. #2
    Gwinver

    Re : Test de diode différent seule ou connectée au circuit.

    Bonsoir.
    L'idéal serait d'avoir un schéma du circuit, éventuellement avec un repérage des composants non encore montés.
    A priori, ce n'est pas la diode, ça pourrait être lié aux autres composants sur la carte ou à un court circuit dans le PCB.
    Une mesure de résistance entre les deux points de connexion de la diode sur le PCB mais sans la diode pourrait lever le doute sur la diode.

  4. #3
    Valohxc

    Re : Test de diode différent seule ou connectée au circuit.

    Ok voila le lien vers le schéma du circuit :

    https://guitarpcb.com/wp-content/upl...D_Mastodon.pdf

    Sachant que je n'ai pas monté les C2 et C5 (condo 10nF), ainsi que Q1 et Q2 (transistors 2N3904), d'ailleurs je me suis planté dans mon premier message, la diode est une 1N4001 et non une 2N3904.

    Je n'ai pas monté les potentiomètres EQ (10k lin) et PINCH (500k lin).

    Je n'ai pas encore relié la carte 3PDT ni aucun fil en IN, GROUND, +9V, et OUT.

    Je n'ai pas branché la LED non plus en D2.

    Donc, je viens d'aller retirer la diode, j'ai un contact entre les deux points même sans la diode (ça bip au multimètre) et j'ai 1.5 Ohm de résistance entre les deux, je suppose que c'est pas normal puisque c'est la diode qui est sensé faire contact uniquement dans un sens non ?

    Merci.


  5. #4
    Valohxc

    Re : Test de diode différent seule ou connectée au circuit.

    Autre détail, la diode déconnectée ne bip pas au multimètre ni dans un sens, ni dans l'autre donc à priori aucun contact dans les deux sens...

    Merci.

  6. #5
    Patrick_91

    Re : Test de diode différent seule ou connectée au circuit.

    Bonjour,

    Pour tester la diode il faut utiliser le mode "test de jonction" du multimètre qui devrait donner
    de l'ordre de 0,8 V dans le sens passant et bien sur overflow dans le sens inverse. La diode semble OK , en revanche il n'y a pas de raison d’après le schéma d'avoir 0 ohms a l'emplacement de la diode, avec ou sans la diode.
    Il doit y avoir une erreur de câblage ou une bavure de soudure qui donne 0 ohms entre les deux points de connexion de la diode sur le circuit.
    A plus
    C'est l'étincelle qui a fait déborder le vase !

  7. A voir en vidéo sur Futura
  8. #6
    Valohxc

    Re : Test de diode différent seule ou connectée au circuit.

    Salut, Je n'ai pas dit que j'avais 0 Ohm, au contraire, j'ai 1.5 Ohm aux bornes D1 (là où la diode se soude), je n'ai pas relevé la valeur quand elle est soudé dessus.

    Ce que j'ai dit c'est que j'avais une tension quasi en nulle (en mV !!) quand elle est soudé dessus !

    Est-ce que c'est bon signe du coup ?

    Et est-ce normal d'avoir un contact (bip au multimètre) entre mes bornes D1 quand la diode n'est pas soudée ???
    Dernière modification par Valohxc ; 20/01/2019 à 08h13.

  9. #7
    gienas

    Re : Test de diode différent seule ou connectée au circuit.

    Bonjour Valohxc et tout le groupe

    Bienvenue sur le forum.

    Citation Envoyé par Valohxc Voir le message
    Autre détail, la diode déconnectée ne bip pas au multimètre ni dans un sens, ni dans l'autre donc à priori aucun contact dans les deux sens ...
    Hum. S'agit-il toujours de la même diode "capricieuse"?

    Les tests tous azimuts ne sont pas indiqués. Il faut beaucoup de soin pour réaliser les circuits, respecter scrupuleusement les consignes et les schémas, et ne jamais tester de composant en place car l'environnement peut influencer les résultats.

    Également, comme le suggère Patrick_91, il faut apprendre à se servir d'un multimètre et savoir interpréter les résultats.

    Là, j'ai le sentiment que des mesures sont faites en dépit du bon sens.

    Je crois comprendre qu'un véritable court-circuit est présent quelque part (de zéro ohm), mais, quand je vois les soudures visibles sur la face du #1 à la droite du marquage D2, je ne suis pas surpris. On y voit des bavures monumentales qui peuvent en provoquer. Et ça, c'est seulement ce qui est visible.

  10. Publicité
  11. #8
    Valohxc

    Re : Test de diode différent seule ou connectée au circuit.

    Alors oui il s'agit bien de la même diode "capricieuse", je sais me servir d'un multimètre, il n'y a aucun endroit où il y a 0 Ohm, je l'ai précisé, j'ai 1.5 Ohm entre mes bornes au D1.

    Ensuite pour les marques à droite du D2, oui, une LED avait été mal soudée à cet endroit et ça a été une galère de la retirer car les broches étaient pliée derrière, elle est désormais soudée proprement sur un 3PDT et je ne me sers plus de cette partie du PCB (que j'ai d'ailleurs testé en mettant mon testeur en position diode, il n'y a de contact avec aucun des emplacements réservés à mes composants).

    Je reste ouvert à des conseils constructifs.
    Dernière modification par Valohxc ; 20/01/2019 à 08h41.

  12. #9
    Patrick_91

    Re : Test de diode différent seule ou connectée au circuit.

    Hello,
    Il y a donc 1,5 Ohms entre les bornes de D1 ... au vu du schéma, c'est impossible. Il y a forcément une bavure coté cablage. Oui la mesure D1 en mode diode, dans ces conditions doit forcément donner 0V ou pas loin et dans les deux sens.
    Il faut enlever la diode et trouver d’où vient cette impédance fantôme (dans le sens ou elle ne figure pas sur le schéma.).
    A plus
    C'est l'étincelle qui a fait déborder le vase !

  13. #10
    Valohxc

    Re : Test de diode différent seule ou connectée au circuit.

    Ok je viens de me rendre compte que j'ai les deux bornes D1, cathode et anode ensemble qui bip, donc sont en contact l'une comme l'autre avec (la liste est longue) :
    GROUND, +9V, OUT et R8.

    Méga souci...

  14. #11
    Valohxc

    Re : Test de diode différent seule ou connectée au circuit.

    Et la résistance R8 qui donne 1k8 sur le schéma (mais est indiquée à 3k3 sur la liste des composants) ne peut-elle pas justifier cette valeur de 1.5 Ohm en D1 ?

  15. #12
    gienas

    Re : Test de diode différent seule ou connectée au circuit.

    Citation Envoyé par Valohxc Voir le message
    ... je sais me servir d'un multimètre ...
    Je suis désolé de te contredire, mais, en aucun cas, on ne teste une diode avec un ohmmètre. Ce mode est réservé aux mesures de résistances ou des continuités à trouver.

    Une diode se mesure en test diode, qui consiste à lui présenter une tension polarisée limitée en courant. Si la polarité rend la diode conductrice, l’appareil mesure la tension présente, en calibre 2V, ce qui donne environ 0,6V pour une bonne diode. Dans l’autre polarité, pas de courant, donc la tension est inchangée, et, comme elle est supérieure au calibre 2V, le voltmètre affiche débordement, ce qui est normal.




    ... il n'y a aucun endroit où il y a 0 Ohm, je l'ai précisé, j'ai 1.5 Ohm entre mes bornes au D1 ...
    "Chez moi" (et je ne suis pas le seul), un court circuit c’est zéro ohm. Quand j’ai rédigé ma réponse du #7, je n’avais pas connaissance de ta réponse suivante qui remplace zéro par 1,5.

    Que ce soit zéro ou 1,5 c’est du pareil au même, c’est un court circuit. Les résistances utilisées dans ton montage sont supérieures au kiloohm soit 1000Ω. C’est donc impossible sans être en court circuit, qui, forcément, doit être visible.

    ... Je reste ouvert à des conseils constructifs.
    Encore faut-il accepter les conseils, en tenir compte, et ne pas supposer qu’on n’en a pas besoin, et qu’on est plus qualifié que les conseilleurs.

    Citation Envoyé par Valohxc Voir le message
    Et la résistance R8 qui donne 1k8 sur le schéma (mais est indiquée à 3k3 sur la liste des composants) ne peut-elle pas justifier cette valeur de 1.5 Ohm en D1 ?
    Non! Absolument pas.

    Si c’est bien 1,5Ω (et pas 1,5kΩ), c’est bel et bien un court circuit, de mauvaise qualité. Ce ne peut être qu’une bavure de soudure qu’il faut chercher à voir, à la loupe.

  16. #13
    f6exb

    Re : Test de diode différent seule ou connectée au circuit.

    C'est quoi cette soudure foireuse en haut à droite au potar de volume ?
    Mets nous des photos recto verso de ta réalisation.
    Dernière modification par f6exb ; 20/01/2019 à 19h19.
    Seuls les faucons volent. Les vrais restent au sol.

  17. #14
    Valohxc

    Re : Test de diode différent seule ou connectée au circuit.

    A Genias :

    Je n'ai jamais testé de diode avec un ohmmètre, j'ai pris la résistance qu'il y avait en D1 sans la diode et ai relevé la valeur de 1.5 Ohm largement avant que tu n'arrives sur ce topic (c'est précisé, il suffit de lire).

    Le test diode je l'avais déjà fait, et j'avais également relevé une mesure de 0.835mV dans le sens passant, bref, le problème n'étant pas ça, il y a effectivement court circuit quelque part, je cherche (ça peut être en D2 vu l'état de la carte).

    J'aimerais retracer le trajet du + et du - pour voir où ça fait court circuit mais je n'ai pas de filon à suivre en partant du +9V et du GROUND sur la carte, il faut sans doute se référer au schéma électrique et se creuser la tête.

    Entre autre, peux tu arrêter les commentaires condescendant stp ?

    A f6exb :

    J'ai mis les photos en pièce jointe sur ce message, de quelle soudure foireuse tu parles, je ne me souviens pas avoir posté des images où on voit un potar de volume ???
    Images attachées Images attachées

  18. #15
    f6exb

    Re : Test de diode différent seule ou connectée au circuit.

    Citation Envoyé par Valohxc Voir le message

    A f6exb :

    J'ai mis les photos en pièce jointe sur ce message, de quelle soudure foireuse tu parles, je ne me souviens pas avoir posté des images où on voit un potar de volume ???
    Je parle de la soudure en haut à droite sur laquelle est soudé le potar de volume. (Si si, c'est bien écrit "vol" sur le circuit. Dans le pdf et sur le verso de ta carte).
    D'autre part, sur le verso de la carte il y beaucoup de pâtés de soudure à la place de vraies soudures et il est possible que l'un d'entre eux entre en contact avec le plan de masse. Mais les photos sont trop floues pour que je puisse donner plus de précisions.
    Tu devrais réchauffer tes soudures avec un fer bien chaud et secouer le circuit pour faire tomber l'excédent.
    Dernière modification par f6exb ; 20/01/2019 à 20h44.
    Seuls les faucons volent. Les vrais restent au sol.

  19. #16
    Valohxc

    Re : Test de diode différent seule ou connectée au circuit.

    Ok je vais virer l'excédent et faire une recherche de contact à la loupe...

    Mais je pense avoir déjà trop abîmé ce PCB donc j'en ai commandé un autre avec des composants neufs que je souderais avec beaucoup plus de précision et de netteté, si j'arrive à réparer celui-là c'est tant mieux, sinon il m'aura servi à connaître les erreurs à ne pas faire.

    Merci à tous.

Sur le même thème :

Discussions similaires

  1. [Outils/Fab/Comp] Resitance de déclenchement du test diode
    Par Ozmoz dans le forum Électronique
    Réponses: 7
    Dernier message: 06/03/2016, 19h44
  2. Une seule porte NAND dans mon circuit, comment faire ?
    Par sierramike dans le forum Électronique
    Réponses: 18
    Dernier message: 05/03/2015, 22h00
  3. Bloc diode test lampes
    Par jeff-49 dans le forum Électronique
    Réponses: 2
    Dernier message: 05/03/2014, 23h46
  4. Circuit diode
    Par pgwt dans le forum Électronique
    Réponses: 8
    Dernier message: 11/12/2013, 18h07
  5. circuit a diode.
    Par elekis dans le forum Physique
    Réponses: 0
    Dernier message: 04/01/2005, 08h50