Répondre à la discussion
Affichage des résultats 1 à 5 sur 5

Problème intégration LTSpice



  1. #1
    zenvice

    Problème intégration LTSpice


    ------

    Bonjour à tous !

    Tout d'abord je préfère vous dire que je débute sous LTSpice,

    J'ai pour vœux de faire tourner un montage avec un AOP AD8099, j'ai donc à ma disposition un fichier .asy et un fichier .cir à ces liens :

    http://ltwiki.org/files/LTspiceIV/ex...evices/ad8099/

    et

    https://www.analog.com/en/products/a...#product-tools

    Mais impossible de faire tourner le composant dans un schéma car il semble lui manquer des données ou un modèle.

    J'ai mis le fichier .asy dans les symboles mais je ne sais pas quoi faire du .cir...

    Que me manque il pour que ça fonctionne ?

    Google n'est plus mon ami, il veut rien me dire de plus !

    à bientôt

    -----

  2. Publicité
  3. #2
    curieuxdenature

    Re : Problème intégration LTSpice

    Bonjour

    tu n'as pas le bon modele de .cir (des modeles contiennent 9 pins au lieu de 7)

    Un copié collé de celui là à la place de AD8099.cir et ça marche.

    * www.spicemodel.com
    * accuracy should be verified by user
    * ----------------------------------------------------------------------------

    * AD8099 SPICE Macro-model
    * Description: Amplifier
    * Generic Desc: Low distortion 1nV/rt Hz Op-Amp
    * Developed by:
    * Revision History: 08/10/2012 - Updated to new header style
    *
    * Copyright 2012 by Analog Devices, Inc.
    *
    * Refer to http://www.analog.com/Analog_Root/st...e_general.html for License Statement.
    * Use of this model indicates your acceptance of the terms and provisions in the License Statement.
    *
    * BEGIN Notes:
    *
    * Not Modeled:
    *
    * Parameters modeled include:
    * voltage noise
    * small signal bandwidth
    * slew rate
    * open loop gain and phase
    * frequency compensation
    * output swing
    * input common mode range
    * input bias current and supply current
    *
    * END Notes
    *
    * PSpice Model Editor - Version 10.2.0

    *Model created by AEi Systems, LLC www.aeng.com

    *
    .SUBCKT AD8099 INp INm Vcc Vee Vout Comp FB

    * In+ In- Vcc Vee Vout Comp FB

    * Input

    Rinm 13 INp 1k
    Cinm INm 13 2p
    Ib vcc 15 DC=4m
    Q1in 26 INm 15 QIN
    Q2in 6 2 15 QIN

    .MODEL QIN PNP BF=300 IS=3e-12 ISE=1.2e-13 NE=1.65 RE=18 KF=2E-14 AF=1

    * Comp

    Cco comp 0 2.6p
    R0 comp 0 450k
    Rdiff INm INp 4k
    Vos 2 INp DC=.1m
    Ios INp INm DC=30n
    RCq1 26 3 375
    RCq2 6 vee 375

    * Interstage

    GBIgain 0 comp Value={ v(26,6)*3m }
    Rp1 16 zfp1 265
    Cp1 zfp1 0 1.43p
    Rp2 1 4 265
    Cp2 4 0 1.43p
    Ebuf 1 0 zfp1 0 1

    * Output

    V5 3 vee
    E2 FB 0 4 0 1
    EB1 16 0 Value={ IF ( v(comp) > v(vcc) , v(vcc), IF ( v(comp) < v(vee) , v(vee) , v(comp) ) ) }
    Q11 vcc 29 31 _Q2_modX
    Q12 vcc 31 14 _Q2_modX

    .MODEL _Q2_modX NPN RC=30 RE=0

    Q13 vee 33 34 _Q6_modX
    Q14 vee 34 14 _Q6_modX

    .MODEL _Q6_modX PNP RC=20 RE=0

    Rout 14 38 15
    Cout vout 40 1.5p
    RCout 40 0 .1
    Co 14 43 2p
    Ro 43 0 .15
    Lout 38 vout 2.5n
    V14 29 zfp1 DC=1.555
    V15 zfp1 33 DC=1.555
    V16 vcc 36 DC=1.87
    V17 37 vee DC=1.87
    D5 zfp1 36 DMOD
    D6 37 zfp1 DMOD

    .MODEL DMOD D

    .ENDS
    L'electronique, c'est fantastique.

  4. #3
    zenvice

    Re : Problème intégration LTSpice

    Bonjour curieux,

    Je mets donc le fichier .asy dans Documents\LTspiceXVII\lib\sym
    et le .cir modifié avec tes données dans Documents\LTspiceXVII\lib\sub

    Donc désormais la simulation se lance correctement ! Par contre le composant ne peut tjrs pas etre edité quand je clique dessus, est ce normal ?

  5. #4
    curieuxdenature

    Re : Problème intégration LTSpice

    Bonjour

    je n'ai pas d'info la dessus mais je pense que c'est le cas pour tous (moi aussi).
    Peut-être sous licence protégée ou pour que l'utilisateur ne fasse pas de fausse manip avec un composant aux caractéristiques pointues ?
    Dans ce dernier cas l'édition est inutile.
    L'electronique, c'est fantastique.

  6. #5
    curieuxdenature

    Re : Problème intégration LTSpice

    A propos des répertoires de destination des fichiers : tu peux placer tous les fichiers dans le même répertoire, ça marche aussi bien.
    ça peut être utile pour retrouver tout ce beau monde pour le sauvegarder ou pour le refiler aux copains.
    L'electronique, c'est fantastique.

  7. A voir en vidéo sur Futura

Sur le même thème :

Discussions similaires

  1. [Analogique] Problème avec LTSPICE
    Par omega7130 dans le forum Électronique
    Réponses: 4
    Dernier message: 26/06/2018, 12h01
  2. Problème LTSpice
    Par alban.s dans le forum Électronique
    Réponses: 5
    Dernier message: 20/12/2014, 17h14
  3. probleme simulation sur LTSPICE
    Par nunu27 dans le forum Électronique
    Réponses: 41
    Dernier message: 05/12/2014, 20h55
  4. problème ampli op LTSpice
    Par noob_man dans le forum Électronique
    Réponses: 11
    Dernier message: 29/01/2013, 08h14
  5. Problème modèle LTSpice
    Par katmai dans le forum Électronique
    Réponses: 1
    Dernier message: 10/09/2010, 06h35