Répondre à la discussion
Affichage des résultats 1 à 4 sur 4

Carte leds 12V "pixels" avec mosfets. Problème de scintillement



  1. #1
    -Julien-

    Lightbulb Carte leds 12V "pixels" avec mosfets. Problème de scintillement


    ------

    Bonjour à tous,

    D’abord merci à tous ceux qui prendront le temps de me lire et de m’aider à trouver une réponse à mon problème. Pour un travail de scultpures autour de la lumière, j’utilise des leds 12V qui consomment entre 20 et 60W. j’utilise ces leds en chaine, les unes à la suite des autres, comme une guirlande.
    Jusqu’à présent, je tirais deux câbles par led (+ et -), pour pouvoir les contrôler séparément avec un contrôleur dmx central. Mais les sculptures s’agrandissant, cela me fait tirer beaucoup de câbles et cette solution n’est pas vraiment viable.

    Dans les rubans de leds 5V, il y a les “leds pixels” qui permettent d’avoir seulement deux câbles de puissance et un câble de signal pour transmettre l’information d’une led à l’autre. Ils sont basés sur des petits contrôleurs, les WS2811 /2813 /2818… C’etait la solution idéale pour moi car ils permettent d’avoir seulement 3 cables et de “chainer” les leds;
    La seule condition pour pouvoir utiliser ces micro-contrôleurs était de leur joindre des mosfets pour gérer la puissance du 12V;

    Je me suis inspiré de quelques cartes qui existent déjà et qui reprennent ce principe
    ws2812-extender
    Le schema

    et aussi

    addressable-n-mosfet-driver-output-module schema

    avec quelques explications en plus pour la première :
    http://www.riderx.info/ws2811-expander/
    http://www.riderx.info/ws2811-expand...visions-again/

    Personnellement, je n’avais pas besoin des trois canaux RVB
    et je voulais que la carte soit la plus petite possible, alors je l’ai redessiné avec 1 seul canal et de plus petits mosfets.
    je l’ai fait assembler en chine pour m’assurer que les soudures soient bien faites,
    et que ce ne soit pas un problème de fabrication qui trouble le fonctionnement sur la carte.

    Voici mon circuit et ma carte:
    circuit.jpg
    IMG_7226.jpg

    Je les contrôle avec un ESP32 et un sn74HC245N pour avoir du 5V en signal, comme il est recommandé.
    Mes petites cartes marchent bien, à priori. Elle me permet de contrôler mes leds. Pourtant quand je mets le niveau à moitié sur une led, les leds d’après commence a avoir un battement, comme-ci le courant consommé par une led influencais la suivante…
    pas de soucis sur des leds pixels 5V. seulement sur mes cartes.

    Je me suis acheté un oscillo pour essayer de voir précisément ce que cela pouvait être..
    Pour autant, est-ce que quelqu’un qui s’y connait en électronique pourrait me souffler une piste? J'ai essayé de mettre des condos sur chaque petite carte. J'ai essayé plusieurs alimentations 12V, mais qui ont l'ampérage largement suffisant donc ça ne semble pas venir de cela...
    Il y a peut être des choses qui sont liés au mosfets mais que je connaitrais pas...
    voila, je suis preneur de toutes suggestions,

    Merci d’avance,

    Julien

    -----
    Dernière modification par -Julien- ; 31/03/2021 à 17h59.

  2. Publicité
  3. #2
    Antoane
    Responsable technique

    Re : Carte leds 12V "pixels" avec mosfets. Problème de scintillement

    Bonjour,

    Si les fils entre l'alimentation et la carte sont longs et/ou fins, il est possible que la chute de tension y soit relativement élevée et diminue trop la tension disponible pour alimenter les WS2811. La datasheet de ce dernier n'est cependant pas très claire quant au contraintes pour l'alimenter.
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  4. #3
    bobflux

    Re : Carte leds 12V "pixels" avec mosfets. Problème de scintillement

    Le WS2811 a une tension d'alim maximum de 6V.

  5. #4
    bobflux

    Re : Carte leds 12V "pixels" avec mosfets. Problème de scintillement

    Ah pardon, plus loin dans la datasheet ils disent que ça marche avec 12V si tu mets la résistance de 2k7 dans l'alim... bon.

    > j’utilise des leds 12V qui consomment entre 20 et 60W

    OK, ça fait pas mal de courant, et d'après la photo on dirait que ça passe dans les petits fils multicolores ?

    Je pense qu'il s'agit simplement d'un problème de câbles trop fins pour le courant demandé, d'où chute de tension.

    Aussi, ton schéma va commuter le MOSFET très rapidement car il n'y a pas de résistance dans la grille, donc il faudrait des condensateurs de découplage sur le 12V.

    Examine à l'oscilloscope la tension entre "+12V" et "GND" sur la carte en bout de chaîne, la plus loin de l'alim, je pense que tu vas voir des chutes de tension brusques de quelques µs lors des allumages des LED.

  6. A voir en vidéo sur Futura

Discussions similaires

  1. [Outils/Fab/Comp] Faire un pont H avec des mosfets sous ISIS
    Par firzenV dans le forum Électronique
    Réponses: 12
    Dernier message: 26/05/2017, 18h05
  2. [Divers] problème avec leds
    Par nonodu56 dans le forum Dépannage
    Réponses: 36
    Dernier message: 20/02/2016, 19h31
  3. Flash LED avec MOSFETs
    Par olouis dans le forum Électronique
    Réponses: 25
    Dernier message: 08/05/2011, 08h20
  4. Problème avec leds !
    Par sogozor dans le forum Physique
    Réponses: 6
    Dernier message: 20/12/2010, 18h29
  5. Circuits résonateur avec des MOSFETs
    Par yangus dans le forum Électronique
    Réponses: 2
    Dernier message: 08/08/2009, 20h03
Découvrez nos comparatifs produits sur l'informatique et les technologies.