Répondre à la discussion
Affichage des résultats 1 à 3 sur 3

sondes PH ORP et problème parasites



  1. #1
    mmarc2007

    Question sondes PH ORP et problème parasites


    ------

    bonjour à tous,

    je suis sur un projet de contrôle de redox/PH pour piscine et je me heurte à un problème de parasite dans l'eau de la piscine qui fausse les valeurs.

    Le montage est très simple,
    j'ai deux sondes reliées à des modules d'amplification tout prêt.
    un ORP METER SEN0165 V1.0 pour le redox
    un module 4502c pour le PH

    C'est ni plus ni moins que des AOP qui filtrent et amplifient le signal des sondes.

    Les sorties de ces modules vont sur un convertisseur analogique numérique ADS1115 pour numériser les valeurs et les lire avec un contrôleur.

    Le tout est alimenté en 5V avec une alimentation de PC ATX. J'ai également testé avec une alimentation de labo de très bonne qualité.

    Lorsque je mes les sondes dans un verre d'eau tout se passe bien et évidemment quand je les plonge dans la piscine dans une chambre d'analyse les problèmes apparaissent.

    Dans une première version, mon local technique était alimenté par ma maison avec une prise de terre commune. Là des que les sondes étaient immergées avec ou sans filtration, les sondes s'affolaient dans tous les sens. Avec une lecture à l'oscilloscope j'ai constaté une tension de fuite venant de ma piscine de 50hz et pouvant aller jusqu'à 2V avec le neutre. Notez que ma piscine n'a pas de poolterre sur la tuyauterie.

    J'ai revu le câblage et mis une terre indépendante dans mon local non reliée à la maison. Depuis les sondes se comportent mieux jusqu'à ce que je mette la filtration en route. A ce moment je constate un léger décalage des sondes que j'ai pu corriger via le code du contrôleur.

    Évidemment si j’alimente mon montage avec une batterie, tout fonctionne à merveille il n'y a aucun décalage.

    Ma conclusion c'est que j'ai donc un signal parasite qui remonte par l'eau de la piscine (elle est en béton armée et doit faire office de terre).
    Mes compétence en électronique sont très basiques, avec mes mots à moi je dirais qu'il faudrait isoler suffisamment mon alimentation 5V du circuit de ma maison.

    Que me conseilleriez vous?
    des filtres RC sur l'alim? des optocoupleurs entre les AOP et le contrôleur? une batterie avec un panneau solaire ?

    Merci d'avoir pris le temps de me lire.

    -----

  2. #2
    Qristoff
    Animateur Électronique

    Re : sondes PH ORP et problème parasites

    Bonsoir,
    j'ai regardé vite fait les informations capteurs/amplis et tu es clairement sur une problème de mode commun entre maison/piscine/local. Je ne connais pas la distance entre les différents points mais pour transmettre un signal analogique sans trop de perturbations, on peut utiliser des liaisons différentielles analogiques. Il existe beaucoup d'AOP de ce type qui sont tolérant à un mode commun important. Il faudrait juste rajouter un petit module sur chaque capteur qui transforme le single ended en différentiel et modifier ton interface d'entrée Arduino pour passer de différentiel à single ended en entrée ADC.
    Tout existe, il suffit de le trouver...!

  3. #3
    Antoane
    Responsable technique

    Re : sondes PH ORP et problème parasites

    Bonjour,

    Je verrais plutôt un problème de couplage entre les modules, et une fuite secteur. Une solution serait alors d'utiliser des alimentations et des tranceivers isolés pour la communication.
    https://forums.futura-sciences.com/e...daquarium.html a eu un problème, me semble-t-il, similaire.
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

Discussions similaires

  1. Problème de parasites
    Par Guillaume48 dans le forum Électronique
    Réponses: 11
    Dernier message: 15/11/2013, 15h26
  2. Problème de parasites
    Par rdelectronique dans le forum Électronique
    Réponses: 13
    Dernier message: 02/08/2011, 17h58
  3. Problème de précision des sondes pH. HELP!
    Par osmium dans le forum Chimie
    Réponses: 5
    Dernier message: 20/12/2010, 13h29
  4. Probleme parasites ampli!
    Par chak01 dans le forum Électronique
    Réponses: 10
    Dernier message: 24/08/2009, 08h23
  5. problême de parasites alim pc
    Par jandre dans le forum Matériel - Hardware
    Réponses: 0
    Dernier message: 17/09/2004, 18h42
Découvrez nos comparatifs produits sur l'informatique et les technologies.