Répondre à la discussion
Affichage des résultats 1 à 18 sur 18

Stabilité d'une alimentation



  1. #1
    schneiderj

    Stabilité d'une alimentation

    Bonsoir,

    je suis toujours à la mise au point de mon thermométre à bvase d'une Pt100 et d'un PIC. Et j'ai un probléme dont je vous ai déjà parlé : la conversion de la tension du pont de résistance n'est pas stable et varie d'environs +/-10%. Je viens de regarder mon systéme à l'oscillo et j'ai pu constaté que le signal est trés bruité. Je suis remonté à l'alimentation... il en est de même. Le +5V est une horreur (le -5V est beaucoup plus stable).
    Le +12V est fourni par un adaptateur secteur que l'on trouve un peu partout et le montage est le suivant :


    Comment puis-je stabiliser cette alimentation ?

    Merci pour votre aide,
    Jean-Marie

    -----


  2. Publicité
  3. #2
    DAUDET78

    Re : Stabilité d'une alimentation

    Sur c11, il faut au moins mettre en parallèle un 470µF
    Et sur C15 et C16, un 0,1µF
    J'aime pas le Grec

  4. #3
    louloute/Qc

    Re : Stabilité d'une alimentation

    Je seconde Daudet (comme toujours, et lui présente mes respects du soir), un 7805 ça donne un oscillographe plat comme l’électroencéphalogramme de Charlemagne. Si tu sais pas que ça prend de la capa de lissage après ton pont de diode, mets pas ça sur le dos de MONSIEUR 7805!

    du 50Hz ce n'est pas du bruit, c'est la version électronique de ce que les informaticiens appellent un 'code 18' (le problème est 18 pouces en avant de l'écran)

    J’en ai fait marcher 8 (de 7805) pendant cinq ans, 24H sur 24, sur des cartes à 80 degrés (température du chip). Respecte!.
    男人不坏,女人不爱

  5. #4
    schneiderj

    Re : Stabilité d'une alimentation

    Bonsoir et merci pour vos réponses.

    Voici un résumé de mes essais :
    • J'ai fait les modifs selon vos conseils, mais il n'y a pas d'amélioration (1.3 V crête/crête).
    • J'ai remplacé l'adaptateur secteur par une batterie : pas d'amélioration
    • remplacé mon montage (PIC, etc...) par une résistance : c'est presque une ligne droite (moins de 0.1 V crête/crête)
    • enlevé le PIC, le LCD, la partie mesure par pont de résistance : faible amélioration (1 V crête/crête)
    • enlevé le max232 : très nette amélioration (crête/crête : 0.3 V)

    Qu'est-ce qui cloche ? Mon montage est sur une platine d'essai. est-ce que cela pourrait en être la cause ?

    Jean-Marie

  6. #5
    schneiderj

    Re : Stabilité d'une alimentation

    Bonjour,

    Est-ce que je suis le seul à rencontrer ce type de difficulté ?

    Jean-Marie

  7. A voir en vidéo sur Futura
  8. #6
    DAUDET78

    Re : Stabilité d'une alimentation

    Citation Envoyé par schneiderj
    Mon montage est sur une platine d'essai.
    Un truc blanc avec des trous où on enfile des fils? Il est possible que ça vienne de là. Faut pas faire passer beaucoup de courant et les contacts sont pas terribles
    J'aime pas le Grec

  9. Publicité
  10. #7
    f6bes

    Re : Stabilité d'une alimentation

    Bjr schneiderj,
    Petite question: quelle est la CONSOMMATION sur le 7805 ?
    Quelle puissance peut délivrer "l'adaptateur secteur" ?
    Le Max (ainsi que le PIC) sont ils BIEN découplés ?
    Bonne soirée
    "Ce fut la goutte d'eau de trop qui mit le feu aux poudres!"

  11. #8
    schneiderj

    Re : Stabilité d'une alimentation

    Merci !

    Daudet : oui il s'agit de cela. Ce soir je vais faire un montage sur une platine d'essai mais avec soudure.

    Citation Envoyé par f6bes Voir le message
    Bjr schneiderj,
    Petite question: quelle est la CONSOMMATION sur le 7805 ?
    Quelle puissance peut délivrer "l'adaptateur secteur" ?
    Le Max (ainsi que le PIC) sont ils BIEN découplés ?
    Bonne soirée
    L'ensemble du montage consomme 47 mA et l'adaptaeur est donné pour 350 mA.
    Je pense que le PIC et le MAX sont correctement découplés. Mais je n'y mettrais pas ma main au feu. Voici le schéma du montage :


    Qu'en penses-tu ?
    Jean-Marie

  12. #9
    schneiderj

    Re : Stabilité d'une alimentation

    Je n'ai toujours pas réussi à régler mon probleme.

    Et si je mettais une inductance sur l'alimentation du PIC, est-ce que cela pourrait améliorer la situation ?

    Jean-Marie

  13. #10
    DAUDET78

    Re : Stabilité d'une alimentation

    Non, pas de self
    On voit pas le 7805? pas de condensateur sur la ligne +5V?
    a quoi sert le -5V
    J'aime pas le Grec

  14. #11
    schneiderj

    Re : Stabilité d'une alimentation

    Bonsoir,

    si, si le 7805 et bien là. Voici le schéma global du montage : http://www.schneiderj.net/Electroniq.../Pt100-PIC.jpg .
    Le -5V sert à alimenter l'INA129.

    Que penses-tu de la solution suivante : alimenter le pic par un deuxiéme 7805 ?

    Jean-Marie

  15. #12
    DAUDET78

    Re : Stabilité d'une alimentation

    A part C16, il n'y a pas de découplage, faut un couple (10µF et 0,1µF) sur le PIC, sur le INA129 (sur les deux alimentations), sur le MAX232

    PS ton générateur de courant avec le BF245 ...c'est un thermomètre!. Utilise une stabilisation avec un TL431A
    J'aime pas le Grec

  16. Publicité
  17. #13
    schneiderj

    Re : Stabilité d'une alimentation

    Oui c'est exacte je veux monter un thermomètre. A terme j'aimerais intégrer une station météo avec détection de ciel clair (je suis également passionné par l'astronomie et j'aimerais enregistrer l'évolution du temps). Quelques photos que j'ai réalisées sont ici : http://www.schneiderj.net/Astro/mesI..._Luminance.jpg

    Je vais regarder l'utilisation du TL431A et voire comment je peux l'utiliser dans mon montage.

    J'ai ajouté les condensateurs à mon montage :http://www.schneiderj.net/Electroniq...00-PIC_dec.jpg qu'en penses-tu ?

    Jean-Marie

  18. #14
    DAUDET78

    Re : Stabilité d'une alimentation

    Et le -5V de l'INA129, il y a pas le droit? il est puni ?
    Une PT100 pour une station météo? le luxe, il y a le LM35 plus simple à utiliser (et plus de tension -5V)
    J'aime pas le Grec

  19. #15
    schneiderj

    Re : Stabilité d'une alimentation

    Humm... bon j'ai oublié le -5 volts. J'ai soudé les condensateurs au plus prés des composants et maintenant j'ai un beau 5 Volts... par contre mon PIC ne fonctionne plus. J'ai enlevé le condo de 10µ, cette fois il démarre une fois sur quatre et ce fige au bout de 10 à 15 secondes (enfin l'afficheur LCD).

    Et je viens de constaté que ce phénomène existe également lorsque je n'ai pas de condo sur l'alim du PIC, mais il faut plus de temps.
    Qu'est-ce qui cloche sur mon montage ?

    Jean-Marie

  20. #16
    schneiderj

    Re : Stabilité d'une alimentation

    Ca y est mon problème est résolu. La lecture de la tension aux bornes du pont de résistance est stable (variation 1 unité sur 1024).

    Merci
    Jean-Marie

  21. #17
    DAUDET78

    Re : Stabilité d'une alimentation

    Et le "Question" était où???
    J'aime pas le Grec

  22. #18
    schneiderj

    Re : Stabilité d'une alimentation

    Citation Envoyé par DAUDET78 Voir le message
    Et le "Question" était où???
    Je ne suis pas sur de comprendre ta question... mais si c'est relatif à "qu'est-ce qui cloche sur mon montage ?" et bien le problème est résolu : la résistance de 10k qui relie MCLR à Vdd était mal soudé.

    A+
    Jean-Marie

  23. Publicité

Sur le même thème :

Discussions similaires

  1. Critère de stabilité d'une solution d'équilibre
    Par Lévesque dans le forum Mathématiques du supérieur
    Réponses: 1
    Dernier message: 24/10/2007, 02h06
  2. Stabilité d'une molécule
    Par lnk dans le forum Chimie
    Réponses: 5
    Dernier message: 06/02/2007, 12h53
  3. stabilité d'une EQ3 2
    Par hammadi dans le forum Matériel astronomique et photos d'amateurs
    Réponses: 4
    Dernier message: 10/08/2006, 15h25
  4. stabilité d'une fonction
    Par cdg974 dans le forum Mathématiques du supérieur
    Réponses: 12
    Dernier message: 20/06/2006, 14h37
  5. Tester la stabilité d'une alim?
    Par superpross dans le forum Matériel - Hardware
    Réponses: 1
    Dernier message: 30/04/2006, 23h54