Répondre à la discussion
Affichage des résultats 1 à 10 sur 10

AOP: haut gain et bruit?



  1. #1
    beginnerequest

    Red face AOP: haut gain et bruit?


    ------

    Bonjour,

    Mon montage: un AOP haute tension (alimenté en -30V,+160V) qui a un gain de 41 (R2=120k+75k;R1=4k7) monté en inverseur. Dessus je lui met une tension à l'aide d'une pile -1,5V AA. J'obtiens bien en sortie les +60V escomptés.

    Malheureusement, cette sortie est entachée d'un bruit irrégulier en fréquence et en amplitude(0,1 à 10Hz, en gros ce n'est pas une sinusoide). Il est de l'ordre de 3mV (mesure optique).
    Si quelqu'un aurait une idée d'où il pourrait provenir ?!

    Ou bien si quelqu'un aurait une idée d'un quelconque test que je pourrait faire...

    Je précise que le système de mesure est éprouvé et qu'avec une alimentation haute tension sans bruit, il délivre une mesure à 0,01mV. Donc il semble qu'il ne soit pas à l'origine du phénomène.

    Merci d'avance à ceux qui auront des idées, car là je sèche...

    -----

  2. Publicité
  3. #2
    Antoane
    Responsable technique

    Re : AOP: haut gain et bruit?

    Bonjour et bienvenu sur Futura,
    Quelques vérifications :
    Référence de l'AOP ? Datasheet ?
    L'alimentation est-elle correctement découplée ?
    Quelle tension de bruit mesures-tu sur le 1,5V ?
    Quel est le but du système (signal d'entrée, environnement...) ?

    3mV sur 60V, c'est pas énorme : -86dB, c'est vraiment pas énorme.
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  4. #3
    DAUDET78

    Re : AOP: haut gain et bruit?

    Bonjour beginnerequest et bienvenue sur FUTURA
    Citation Envoyé par beginnerequest Voir le message
    Si quelqu'un aurait une idée d'où il pourrait provenir ?!
    sans le schéma utilisé .....

    et 73µV de bruit en entrée .... faut des sacrés blindages !
    et utiliser une pile comme tension de référence ....bof ... bof !
    J'aime pas le Grec

  5. #4
    gienas
    Modérateur

    Re : AOP: haut gain et bruit?

    Bonjour beginnerequest et tout le groupe

    Bienvenue sur le forum.

    Citation Envoyé par beginnerequest Voir le message
    ... J'obtiens bien en sortie les +60V escomptés ... un bruit irrégulier ... de 3mV ...
    Sans savoir comment c'est construit, difficile à dire. Pourtant, un tel rapport de plus de 80 dB, c'est remarquable, je ne vois pas bien de quoi tu te plains.

    Je suis curieux, d'ailleurs, de savoir comment tu mesures.

  6. A voir en vidéo sur Futura
  7. Comparatifs

    Gagnez du temps et de l'argent grâce à nos comparatifs de produits. Parmi nos sujets :
  8. #5
    Tropique

    Re : AOP: haut gain et bruit?

    Citation Envoyé par beginnerequest Voir le message
    Mon montage: un AOP haute tension (alimenté en -30V,+160V) qui a un gain de 41 (R2=120k+75k;R1=4k7) monté en inverseur. Dessus je lui met une tension à l'aide d'une pile -1,5V AA. J'obtiens bien en sortie les +60V escomptés.

    Malheureusement, cette sortie est entachée d'un bruit irrégulier en fréquence et en amplitude(0,1 à 10Hz, en gros ce n'est pas une sinusoide). Il est de l'ordre de 3mV (mesure optique).
    Cela représente ~70µV ramenés à l'entrée; avec des impédances de source aussi basses, et une bande de 10Hz, c'est de l'ordre de 100x ce que l'on peut espérer d'un ampli moderne.
    Il doit donc y avoir un souci. Si ce ne sont pas des composants externes, genre condo de compensation céramique ou mica fuiteux, il faut soupçonner l'ampli lui-même.
    C'est loin d'être exceptionnel, il suffit que les entrées soient insuffisamment protégées, déterioration des jonctions BE ou GS des transistors d'entrées par claquage inverse, et la messe est dite.

    Ou même sans stress particulier, il suffit d'un aléa genre contamination, et on se retrouve avec du bruit.
    Le plus simple est l'échange immédiat, quitte à investiguer plus loin si ça ne résout pas le problème.
    Pas de complexes: je suis comme toi. Juste mieux.

  9. #6
    jlcms

    Re : AOP: haut gain et bruit?

    Citation Envoyé par beginnerequest Voir le message
    un AOP haute tension (alimenté en -30V,+160V) qui a un gain de 41 (R2=120k+75k;R1=4k7) monté en inverseur.
    Essaye de changer tes résistances, et regarde si le bruit change.
    Essaye de diviser par deux tes valeurs de résistance, et regarde si le bruit change.

  10. Publicité
  11. #7
    beginnerequest

    Smile Re : AOP: haut gain et bruit?

    Tout d'abords merci à tous pour vos contributions.

    Tout d'abords, c'est vrai, j'ai été très lacunaire:

    L'AOP est un APEX (Cirrus maintenant) 241DF : http://www.datasheetcatalog.org/data...9/398857_1.pdf

    Maintenant, voici les tests que j'ai effectué :
    1. Je l'ai connecté à une référence de tension (LM4120) et un buffer (AD8626 en suiveur) et à une autre référence de tension (LM4040) et un buffer (OPA350), ca n'a rien donné (j'ai aussi essayé avec un OPA820 pour essayer un autre buffer).
    2. En voyant cela, je me suis dit que la meilleure référence de tension serait encore un processus chimique: les piles. Mais mon oscillo ne descend pas en-dessous de 20mV/DIV et je n'ai pas vu de bruit lent.
    Il faut bien comprendre que mon phénomène est très lent, et donc pas facilement décelable.
    3. Je me suis aussi posé la question des alimentations: j'ai donc appliqué à mon système de mesure directement un diviseur de tension: le résultat est bon, je n'ai pas ce bruit. Sur le +200V il y a 4,7uF et sur le -30V il y a 22uF.
    4. J'ai essayé avec un modèle acheté dans le commerce (Piezosystem Jena) qui lui n'utilise pas d'AOP mais utilise simplement un AOP basse tension et régule sur des transistors, et ca passe, sans bruit.
    5. J'ai ramené les résistances à 10 fois leurs valeurs (470 à la place de 4k7), et ca n'a strictement rien changé.

    Par contre Tropique, qu'entends-tu par "Si ce ne sont pas des composants externes, genre condo de compensation céramique ou mica fuiteux, il faut soupçonner l'ampli lui-même." ? Quels genre de condensateurs me conseilles-tu ? J'ai pour l'instant des Electrolytiques Panasonic pour les alim (il faut que je vérifie, mais il me semble que ce soit des X7R). Et pour le composant: j'ai fait faire 3 platines, justement pour ce genre de problèmes, et j'ai le souci sur les 3...

    Mon problème de 3mV se situe partout: du 1V en sortie au +150V ou -20V (avec des variations de quelques mV dans le bruit, mais difiiciles à quantifier).

    L'objectif est de commander en tension un élément Piezo.
    Images attachées Images attachées

  12. #8
    Antoane
    Responsable technique

    Re : AOP: haut gain et bruit?

    Si je comprend bien la datasheet :
    "INPUT : Noise, low frequency (1Hz-10Hz) : 125µV p-p (typique)"
    Or, tu trouves 146µV p-p, donc c'est cohérent.

    Autant que possible, éviter des rajouter des éléments dont on puisse se passer (buffers par exemple) dans le trajet du signal car chacun rajoute un peu de bruit (et de distorsion).
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  13. #9
    Tropique

    Re : AOP: haut gain et bruit?

    Cet ampli a un bruit énorme, c'est dû aux transistors MOS d'entrée.
    Il faudrait soit prendre un modèle plus "normal", soit l'asservir par un ampli basse tension à faible bruit qui imposera ses caractéristiques d'entrée.

    Par contre Tropique, qu'entends-tu par "Si ce ne sont pas des composants externes, genre condo de compensation céramique ou mica fuiteux,
    Je parle du condo de compensation, pas de découplage (Cc). Il faut un type de bonne qualité, de 250V au moins.
    Pas de complexes: je suis comme toi. Juste mieux.

  14. #10
    beginnerequest

    Thumbs up Re : AOP: haut gain et bruit?

    Merci pour vos réponse, je crois qu'on touche le problème, je vous tiens au courant dès que possible.

    Citation Envoyé par Tropique Voir le message
    Cet ampli a un bruit énorme, c'est dû aux transistors MOS d'entrée.
    Il faudrait soit prendre un modèle plus "normal", soit l'asservir par un ampli basse tension à faible bruit qui imposera ses caractéristiques d'entrée.


    Je parle du condo de compensation, pas de découplage (Cc). Il faut un type de bonne qualité, de 250V au moins.
    Citation Envoyé par Antoane Voir le message
    Si je comprend bien la datasheet :
    "INPUT : Noise, low frequency (1Hz-10Hz) : 125µV p-p (typique)"
    Or, tu trouves 146µV p-p, donc c'est cohérent.

    Autant que possible, éviter des rajouter des éléments dont on puisse se passer (buffers par exemple) dans le trajet du signal car chacun rajoute un peu de bruit (et de distorsion).

Discussions similaires

  1. Gain statique aop
    Par Jerem2107 dans le forum Électronique
    Réponses: 5
    Dernier message: 03/03/2011, 17h23
  2. Gain AOP : g ? , g0 ? , G ? , G0 ?
    Par AmigaOS dans le forum TPE / TIPE et autres travaux
    Réponses: 2
    Dernier message: 11/12/2010, 17h03
  3. Calcul gain AOP
    Par KHENEDA dans le forum Électronique
    Réponses: 13
    Dernier message: 09/02/2009, 19h36
  4. adaptation gain AOP
    Par christo448 dans le forum Électronique
    Réponses: 8
    Dernier message: 12/11/2008, 19h25
  5. AOP: gain bien trop élevé !
    Par Phanoo dans le forum Électronique
    Réponses: 5
    Dernier message: 02/08/2006, 14h50
Découvrez nos comparatifs produits sur l'informatique et les technologies.