Répondre à la discussion
Affichage des résultats 1 à 13 sur 13

Probleme relais, contacts qui se soudent



  1. #1
    hary

    Probleme relais, contacts qui se soudent


    ------

    Bonjour.

    Je travaille sur la commande d'un volet roulant assez classique de dimension modeste que je souhaite commander par un module relais qui est piloté par un ESP8266.

    Je rencontre un soucis dans la mesure ou l'un des relais inverseur a les contacts qui se sont "soudé" entre eux.

    J'ai pourtant mis une tempo entre la commutation de l'inverseur et de la marche lors de la mise en route et entre la marche et l'inverseur pour l'arrêt (20ms) pour exclure des problèmes d'inversion de sens tant que le relais inverseur n'est pas "stabilisé" (à cause des rebonds de contacts), mais cela ne semble pas suffisant et je soupçonne que mon problème vient de là.

    Les relais pilotés en 5VDC sont indiqués pour 250VAC 5A (or mon volet doit faire moins de 100W !
    - D'après vous, quelle tempo serait nécessaire ? (je ne vois pas d'autre raison pour ce problème. Je précise que ça a fonctionné dans les 2 sens, montée/descente avant que le phénomène se produise, il n'y a donc pas eut de cours circuit ou autre et j'ai pu décollé les contacts très facilement du bout de l'ongle.)

    -----

  2. Publicité
  3. #2
    herrmattoon

    Re : Probleme relais, contacts qui se soudent

    Salut Hary,

    Tu vas détester ma réponse : je trouve ça aussi bizarre que toi

    20ms c'est amplement suffisant. Si tu as un oscilloscope et que tu veux voir combien de temps il faut aux contacts pour établir de manière définitive le contact après rebonds. Tu peux brancher "Vcc" sur une borne puis une résistance à la masse sur l'autre et observer la durée de la transition.

    Comme je doute que ce soit le problème, peut-être as-tu une tension d'activation de la bobine à la limite requise? Le relais se mettrait à "osciller" entre l'état fermé et ouvert, ce qui pourrait souder les contacts. Une autre piste serait que tu essaie de contrôler une charge inductive (moteurs) . Au déclenchement, les contacts pourraient restent collés du fait de l'arc qui s'établit.

    Tu pourrais encore t'assurer que les sorties de ton ESP se comportent comme tu le désires. Si j'ai bien vu, il s'agit d'un uC avec connectivité Wifi. Il ne suffit pas de mesurer une durée de vingt ms à la transmission de l'ordre pour que cette dernière soit identique à la réception des paquets...

    Voilà ce que j'en pense. Peut-être suis-je à côté de la plaque, mais ce sont déjà quelques pistes. En tout cas, il n'a pas du y avoir de court-circuit, sinon les disjoncteurs de ton installation électrique auraient sautés!

    Bonne chance!

  4. #3
    obladi

    Re : Probleme relais, contacts qui se soudent

    Bonjour,

    Il arrive que les contacts de relais restent "collés/soudés" ensemble à cause d'une surintensité au démarrage, donc lors de la fermeture des contacts.

    C'est ce qui arrive lorsqu'on enclenche un moteur ou une alimentation à découpage (charge des condendateurs internes). Le courant de démarrage
    peut être énorme et on peut voir de belles étincelles lors de l'enclenchement du relais si ce dernier a un boîtier transparent.

    A mon avis le relais que vous utilisez est trop petit et n'a pas un pouvoir de coupure suffisant. Il n'est pas fait pour piloter des charges
    qui consomment 5A sous 250V, surtout des charges inductives ou capacitives (si j'ai bien vu la puissance max que le relais peut couper c'est 125VA).

    (même la charge de 100W de votre store risque d'être trop importante à mon avis (à cause de la surintensité au démarrage)

    Bonne soirée
    Dernière modification par obladi ; 20/11/2017 à 22h50.

  5. #4
    obladi

    Smile Re : Probleme relais, contacts qui se soudent

    Désolé j'ai mal lu, ce n'est pas marqué 125VA, mais 125VAC.
    Je pense néanmoins que c'est parce que le relais n'est pas assez 'costaud'

  6. #5
    hary

    Re : Probleme relais, contacts qui se soudent

    Merci pour ces réponses très intéressantes, mais je dois préciser que le relais qui s'est "soudé" très légèrement est celui qui me sert d'inverseur montée/descente du volet.
    Celui-ci est d'abord commandé alors que le circuit n'est pas encore sous tension, j'attends une tempo de 50ms pour qu'il n'y ait plus de rebonds (en fait de changement de sens de marche montée/descente) et ensuite seulement j'enclenche le relais de mise sous tension.

    Pour l'arrêt, même traitement : mise hors tension par le relais de marche, tempo de 50ms, et relâchement du relais inverseur le cas échéant.

    Sinon, pour le coups, oui, j'alimente bien un moteur (de volet roulant) et donc inductif.
    Mais avant j'utilisais un télécommande dédiée du commerce qui était équipée du même type de relais, voire un peu plus petit en dimension !

    Sinon, quand vous me parlez de pouvoir de coupure, c'est vrai que quand j'ai ouvert mon relais "soudé" et que j'ai vu les distances entre contact (même les distances entre circuit de commande et circuit commandé dans ce petit boîtier) ça fait peur !

    herrmattoon

    Comme je doute que ce soit le problème, peut-être as-tu une tension d'activation de la bobine à la limite requise? Le relais se mettrait à "osciller" entre l'état fermé et ouvert, ce qui pourrait souder les contacts. Une autre piste serait que tu essaie de contrôler une charge inductive (moteurs) . Au déclenchement, les contacts pourraient restent collés du fait de l'arc qui s'établit.
    J'alimente la commande des relais avec du 5V, par contre j'ai un montage typre breadbord, et en effet je peux pas garantir l'absence de microcoupure en effet. Je pense qu'il faut que j'aille dans ce sens ! D'autant que si la micro coupure c'est faite sur l'inverseur tout en étant sous tension, l'effet inductif aura sans doute été amplifié fortement (montée/descente d'un coup sans arrêter le moteur).


    herrmattoon
    Tu pourrais encore t'assurer que les sorties de ton ESP se comportent comme tu le désires. Si j'ai bien vu, il s'agit d'un uC avec connectivité Wifi. Il ne suffit pas de mesurer une durée de vingt ms à la transmission de l'ordre pour que cette dernière soit identique à la réception des paquets...
    Oui en effet, mais la tempo est programmée dans le uC et j'ai une LED sur le shield relais qui m'indique la commande et le déroulement me semble cohérent.

    herrmattoon Voilà ce que j'en pense. Peut-être suis-je à côté de la plaque, mais ce sont déjà quelques pistes. En tout cas, il n'a pas du y avoir de court-circuit, sinon les disjoncteurs de ton installation électrique auraient sautés!
    Oui, et je pense que l'intérieur de mon relais aurait été tout noir et plein de métal vaporisé, hors c'est tout propre.

  7. A voir en vidéo sur Futura
  8. #6
    Chtulhu

    Re : Probleme relais, contacts qui se soudent

    Bonsoir,

    si vos contacts collent c'est probablement du à une commande trop molle.
    Une commande molle augmente de façon importante la phase de rebonds ce qui n'est pas souhaitable du tout.
    Il faut donc vérifier que votre tension appliquée à la bobine ne s'écroule pas, elle doit être bien stable durant toute la phase de chargement en courant de la bobine, la consommation étant à son maximum lors de la mise en mouvement de l'équipage mécanique.

  9. Publicité
  10. #7
    hary

    Re : Probleme relais, contacts qui se soudent

    Citation Envoyé par Chtulhu Voir le message
    Bonsoir,

    si vos contacts collent c'est probablement du à une commande trop molle.
    Une commande molle augmente de façon importante la phase de rebonds ce qui n'est pas souhaitable du tout.
    Il faut donc vérifier que votre tension appliquée à la bobine ne s'écroule pas, elle doit être bien stable durant toute la phase de chargement en courant de la bobine, la consommation étant à son maximum lors de la mise en mouvement de l'équipage mécanique.
    Je vais tacher de voir de ce coté aussi, mais comme je l'ai dis, quand ce relais commute, le circuit est normalement hors tension. Par contre si le 5V d'alimentation s'écroule à cause de l'autre relais qui commute, il peut en effet y avoir un relâchement temporaire de la bobine du relais inverseur qui à entrainé qu'il se soit soudé.

  11. #8
    Chtulhu

    Re : Probleme relais, contacts qui se soudent

    20ms est un peu court, 100ms serait sans doute mieux, à défaut d'avoir les caractéristiques de votre relais.
    Il faut aussi regarder avec un oscilloscope l'allure de ce courant commuté, profitez-en pour regarder, dans le même temps, comment la tension bobine se comporte.
    Vous y trouverez sans doute votre réponse.

  12. #9
    hary

    Re : Probleme relais, contacts qui se soudent

    Citation Envoyé par Chtulhu Voir le message
    20ms est un peu court, 100ms serait sans doute mieux, à défaut d'avoir les caractéristiques de votre relais.
    Il faut aussi regarder avec un oscilloscope l'allure de ce courant commuté, profitez-en pour regarder, dans le même temps, comment la tension bobine se comporte.
    Vous y trouverez sans doute votre réponse.
    J'ai modifié la tempo à 150ms dans le doute, ce n'est pas trop gênant.
    Je n'ai pas d'oscillo sur place, mais je vais essayer d'explorer ce que vous me dite en me procurant le nécessaire.

  13. #10
    obladi

    Re : Probleme relais, contacts qui se soudent

    Hello,

    Alors effectivement si vous commutez votre inverseur lorsqu'il est hors tension ça casse un peu ma théorie
    (et peut être aussi celle de la commande 'molle')

    Moi j'hésiterais pas à mettre des tempos de 1-2 secondes (si vous ne l'avez pas déjà fait et si c'est facile à faire dans le code) pour voir si la séquence se déroule bien.

    Je pense que pour piloter ce genre de relais il n'y a pas vraiment de problème, même sur le montage dont vous parlez, car ce n'est vraiment pas critique comme cas d'emploi.
    Si le driver n'a pas assez de 'puissance', un petit transistor (même un bon vieux NPN genre BC337) pourra facilement piloter les quelques 70-80 mA de ce relais.

    Quelques infos qui peuvent peut-être vous aidez:

    Les problèmes d'arcs, de surtension et de surintensité peuvent survenir lors de la fermeture des contacts tout comme lors de l'ouverture.

    J'ai lu dans l'excellent livre de CEM de Charoy que lorsque l'on ouvre un contact connecté à une charge inductive, il peut y avoir des salves de surtensions,
    soit des dizaines ou des centaines d'arcs durant les quelques millisecondes nécessaires à l'ouverture du contact, ce qui génère des parasites
    et peut aussi détériorer les contacts (En fait en première approximation le circuit se comporte comme un RLC : bobine de la charge + R et C des câbles etc.).
    On peut mettre des dispositifs de protection en parallèle avec la charge (varistance, circuit RC etc.).

    Enfin, dans mes montages, pour la partie courant fort 250V, et surtout pour le commutateur principal de courant, je préfère utiliser des contacteurs à plus fort
    pouvoir de coupure (de simples contacteurs à mettre sur des rails DIN, comme les disjoncteurs), surtout lorsqu'ils alimentent un équipement d'une maison via
    l'installation électrique intérieure de cette dernière. En effet en cas de défaut, ou de cc du côté de l'installation (dans le store par exemple), le circuit courant fort
    va 'tenir le coup' le temps qu'il faut au disjoncteur pour couper le circuit. Cela garantit aussi une bien meilleure protection pour votre système de commande numérique.

    En fait, quant je fais une commande pour des trucs qui sont installés dans une maison, j'utilise souvent un petit relais du genre 5VDC (contact 250V) comme le votre pour piloter un relais 250V à plus grand pouvoir de coupure, mais ça c'est l'ancien électricien un peu parano qui parle

    Bonne journée

  14. #11
    IC-CD0000

    Re : Probleme relais, contacts qui se soudent

    Bonjour

    Perso, je pense, que le pouvoir de coupure de ces relais ne sont pas suffisants, comme déjà mentionné par obladi, à cause du courant au démarrage du moteur (à vide 3 à 4 fois l'intensité nominale ; en charge ça peut monter jusqu’à 8-10 fois l’In).

    Dans les caractéristiques des relais SRD-...-SL-C (LIEN) l'intensité max que peut commuter les contacts est indiqué : 7A sous 230VAC pour une charge purement résistive (ce n'est pas ton cas) et 3A sous ... 120VAC pour une charge inductive, ce qui est le cas pour un moteur. Ces relais ne conviendraient donc pas pour ton application.

    Dans un premier temps, tu peux nettoyer les contacts avec un spray Contact, puis commuter un contacteur à l’aide de ces relais, ou carrément changer de relais par de ceux ayant un pouvoir de coupure adapté.

    Suggestion, autre piste qui pourrait soulager les pôv contacts : mettre un condensateur MKT ou céramique 100nF de type X2 (attention, impérativement du type X2, prévu pour 250VAC) aux bornes du moteur, pour amoindrir les pics de courant. Le mieux étant vraisemblablement de changer de relais. Bonne suite

    EDIT : yé souis grillé; la réf que j'avais faite se rapporte au premier post de Mr obladi, que je salue
    Dernière modification par IC-CD0000 ; 21/11/2017 à 09h53.

  15. #12
    obladi

    Re : Probleme relais, contacts qui se soudent

    Hello, je viens de penser à un truc :

    Et si le relais de mise sous tension restait lui-même collé un petit moment ? de temps en temps ? mais qu'il lâchait après une demi seconde, c'est tout à fait possible !
    (il est lui-même soumis à ces surintensités ou ces surtensions !)

    Dans ce cas le relais inverseur, que vous pensiez être hors tension pendant sa commutation, en fait se retrouve bel et bien à faire une commutation directe
    du moteur du store de montée vers descente ou vice versa !

    Et vous ne verriez rien avec les LED de contrôle car elles ne signalerait rien d'anormal, la commande fonctionnerait correctement en fait !

    Bonne journée et bonne chance si vous n'avez pas déjà trouvé le problème !

    Obladi

  16. Publicité
  17. #13
    nornand

    Re : Probleme relais, contacts qui se soudent

    Bjr; je pense que l’amorçage apparaît du fait de l'inductance du circuit moteur + câbles un circuit RC aux bornes des contacts devrait faire disparaitre l'étincelle et donc l'arc qui se produit et soude tes contacts: 100 nF / 400 V et 1 kO / 0,5 W montés en série , et mis en // sur le contact. ---| |--- Ω ----

Discussions similaires

  1. [Autre] Protection des contacts d'un relais
    Par USMC dans le forum Électronique
    Réponses: 11
    Dernier message: 19/09/2017, 12h46
  2. Le Platine prend-il à l'aimant ? (contacts de relais)
    Par PapaBravo dans le forum Chimie
    Réponses: 6
    Dernier message: 27/11/2013, 20h38
  3. pont en H à base de relais, protection des contacts
    Par charlesgg dans le forum Électronique
    Réponses: 10
    Dernier message: 15/12/2012, 19h22
  4. Probleme de contacts messagerie orange
    Par FoxHotel dans le forum Internet - Réseau - Sécurité générale
    Réponses: 14
    Dernier message: 22/02/2008, 11h53
  5. Relais: contacts NO et NF
    Par abracadabra75 dans le forum Électronique
    Réponses: 3
    Dernier message: 21/02/2008, 16h05
Découvrez nos comparatifs produits sur l'informatique et les technologies.