Répondre à la discussion
Page 1 sur 2 1 DernièreDernière
Affichage des résultats 1 à 30 sur 38

Problème de commande de moteur avec MOSFET



  1. #1
    natu

    Problème de commande de moteur avec MOSFET

    Bonjour à tous,

    Je désire commander avec le signal PWM d'une carte Arduino un moteur à courant continu brushed alimenté avec 7,4V et qui peut consommer jusqu'à 3A .
    Le problème est que je trouve quelques difficultés avec ce dernier car le moteur bipe sans arrêt lorsque je branche le tout et le MOSFET (canal N, IRF510) surchauffe.

    Auriez-vous des solutions à ce problème ?

    Voici le schéma de mon circuit : (la résistance vaut 10 kOhms et la diode est une 1N4007) (la batterie vaut 7.4 Volts)
    tinker2.JPG

    Voici le code que j'ai téléversé en voulant seulement mettre à l'état haut et bas mon moteur et ça ne fonctionne quand même pas :

    Code:
    int motor = 11;
    
    void setup() {
      pinMode(motor, OUTPUT);
    }
    
    void loop() {
      digitalWrite(motor, HIGH);
      delay(1500);
      digitalWrite(motor, LOW);
      delay(1500);
    }
    Bonne journée à vous,
    Natu

    -----

    Dernière modification par gienas ; 05/03/2019 à 07h36. Motif: Ajouté les balises code obligatoires sur les programmes

  2. Publicité
  3. #2
    paulfjujo

    Re : Problème de commande de moteur avec MOSFET

    bonjour,


    Delay(1500) ; en µS ?

    quelle est la valeur ( resistance) de ton enroulement... determine le I Max
    sans doute faut-il aussi un radiateur sur le mosfet .

  4. #3
    natu

    Re : Problème de commande de moteur avec MOSFET

    Merci de votre réponse.
    C'est en milisecondes.
    L'intensité max du moteur vaut 3 ampères mais je ne vois pas ce que vous voulez dire par enroulement?

  5. #4
    paulfjujo

    Re : Problème de commande de moteur avec MOSFET

    donc delay =1500 ms = 1,5 sec !
    mettre un delay en µS !
    la commande PWM est plutot en KHz , qu'en milli Hz

    A l'arret , la consommation est 7,4V / R enroulement
    De plus , suivant les disperssion de caracteristiques de MOSFET,
    le VGS fournit par l'arduino est peut etre trop faible pour saturer completement le MOSFET
    => augmente la dissipation thermique

    d'autant qu'avec un timing si lent, il a le temps de chauffer le Mosfet ..
    avec un ratio de 50% Ton = Toff
    le courant moyen est divisé par 2.

  6. #5
    bobflux

    Re : Problème de commande de moteur avec MOSFET

    IRF510 a une RdsON de 0.5 ohms quand il est commandé par un Vgs de 10V, quand à le commander en 5V cela ne fonctionnera pas. Il faut un MOSFET ayant une RdsON suffisamment faible et spécifiée pour Vgs de 4.5V.

  7. A voir en vidéo sur Futura
  8. #6
    natu

    Re : Problème de commande de moteur avec MOSFET

    Merci!
    Avez vous un MOSFET particulier à me conseiller ?
    Ainsi, hormis le MOSFET et le délai, rien n'est à changer dans ce que j'ai proposé comme circuit ?
    Dernière modification par natu ; 27/02/2019 à 17h16.

  9. Publicité
  10. #7
    paulfjujo

    Re : Problème de commande de moteur avec MOSFET

    il doit quand meme conduire un peu, puisqu'il chauffe ..

    voir IRLZ14
    ou AO3402 mais en boitier SOT23 30V 4A RDon <85 milliohm VGS=2,5V

    ou liste de DAUDET .. à retrouver sur ce forum.

    et cette valeur d'enroulement moteur ?
    Dernière modification par paulfjujo ; 27/02/2019 à 17h20.

  11. #8
    f6exb

    Re : Problème de commande de moteur avec MOSFET

    (Retrouver Daudet ou la liste ?)
    Seuls les faucons volent. Les vrais restent au sol.

  12. #9
    paulfjujo

    Re : Problème de commande de moteur avec MOSFET

    en fait c'est ici
    Utilisation des NMOS en interface de puissance
    sur fantaspic

  13. #10
    natu

    Re : Problème de commande de moteur avec MOSFET

    Que voulez-vous dire par enroulement moteur ? Je crois ne pas avoir cette donnée

    Edit : merci pour votre lien

  14. #11
    natu

    Re : Problème de commande de moteur avec MOSFET

    Demain, j’achèterai le IRLZ14 et je vous donnerai des nouvelles. Merci à tous !

  15. #12
    natu

    Re : Problème de commande de moteur avec MOSFET

    Bonjour à tous,
    Malheureusement le moteur réagit de la même façon avec le nouveau MOSFET. Avez vous des solutions à ce problème ?

  16. Publicité
  17. #13
    Patrick_91

    Re : Problème de commande de moteur avec MOSFET

    Hello,

    Il faudrait un vrai schéma quand meme ..
    A plus
    C'est l'étincelle qui a fait déborder le vase !

  18. #14
    natu

    Re : Problème de commande de moteur avec MOSFET

    Bonjour,

    Que voulez-vous dire par vrai schéma? Le premier ne suffit pas?

  19. #15
    dje8269

    Re : Problème de commande de moteur avec MOSFET

    Bonjour ,

    regarde le lien de Paulfjujo où i ly a un super tuto sur l'utilisation d'un MOSFET .

    Une petite Résistance en serie sur la Grille éviterai un courant trop fort sur celle ci.
    La diode est elle bien dans le bon sens ! sinon ....ca chauffe
    C'est en faisant des erreurs; que l'on apprend le mieux !!

  20. #16
    Patrick_91

    Re : Problème de commande de moteur avec MOSFET

    Citation Envoyé par natu Voir le message
    Bonjour,

    Que voulez-vous dire par vrai schéma? Le premier ne suffit pas?
    C'est n'est pas un schéma (clair) c'est un repère d'implatation .
    Si le transistor chauffe trop c'est qu'il n'est pas saturé.
    A plus
    C'est l'étincelle qui a fait déborder le vase !

  21. #17
    paulfjujo

    Re : Problème de commande de moteur avec MOSFET

    Citation Envoyé par natu Voir le message
    Que voulez-vous dire par enroulement moteur ? Je crois ne pas avoir cette donnée
    Edit : merci pour votre lien
    la reference du moteur , alors ?
    ou achete un petit controleur mutimetre .. on en trouve de 15€ à 40€
    qui te servira à mesurer la valeur de l'enroulement en Ohms
    et aussi de verifier si ton alimentation 7,4V ne s'ecroule pas
    des qu'on tire des amperes dessus

  22. #18
    natu

    Re : Problème de commande de moteur avec MOSFET

    C'est un LS-GM002. Voici un lien Bangood que j'ai trouvé : https://banggood.com/9115-2_4GHz-Car...-p-972220.html

    J'ai rajouté en série une résistance sur la grille mais rien n'y fait

    Comment faire pour saturer mon Mosfet?
    Dernière modification par Antoane ; 01/03/2019 à 11h41. Motif: réparation du lien pour utilisation desktop

  23. Publicité
  24. #19
    jiherve

    Re : Problème de commande de moteur avec MOSFET

    bonjour
    la resistance série dans la gate d'un Mosfet sert surtout à empêcher celui ci d'osciller , la resistance de pull down doit être de l'ordre de 100k elle n'est là que pour fixer le potentiel de la gate le temps du boot du µC.
    Si l'alimentation ne permet pas de fournir le courant de démarrage du moteur et pour ce type de moteur c'est plutôt 10A alors le tout cafouille.
    JR
    l'électronique c'est pas du vaudou!

  25. #20
    dje8269

    Re : Problème de commande de moteur avec MOSFET

    Citation Envoyé par natu Voir le message
    J'ai rajouté en série une résistance sur la grille mais rien n'y fait
    Oui la résistance n'est pas critique dans ton cas. cela n'était pas dit comme solution à ton probléme.

    Comment faire pour saturer mon Mosfet?
    Il faut s'assurer que la tension sur la Grille soit suffisante ( voir DS).
    Ton moituer est il libre de ces mouvements ? Si tu appliques directement la batterie aux bornes du moteur celui-ci tourne -t-il ? est il en charge ?
    Dernière modification par dje8269 ; 01/03/2019 à 12h43.
    C'est en faisant des erreurs; que l'on apprend le mieux !!

  26. #21
    antek

    Re : Problème de commande de moteur avec MOSFET

    Sans schéma . . .
    Et réaliser le montage sur une carte à trous, 3 A c'est un peu trop, sans parler des faux contacts.

  27. #22
    natu

    Re : Problème de commande de moteur avec MOSFET

    Lorsque je branche le moteur directement à la batterie, ce dernier tourne correctement.
    J'ai appris que lorsque le moteur bippait, cela signifiait que ce dernier était sous alimenté, cela voudrait donc dire que je suis en train d'alimenter mon moteur avec la pin de mon arduino mais pourquoi ?
    J'ai déjà brûlé un MOSFET et c'était le drain qui avait changé de couleur
    Dernière modification par natu ; 01/03/2019 à 14h27.

  28. #23
    dje8269

    Re : Problème de commande de moteur avec MOSFET

    Citation Envoyé par natu Voir le message
    Lorsque je branche le moteur directement à la batterie, ce dernier tourne correctement.
    J'ai appris que lorsque le moteur bippait, cela signifiait que ce dernier était sous alimenté
    Un moteur qui BIP ?????
    Il y a de l'electronique dedans ? tu ne nous dis pas tout .

    Citation Envoyé par natu Voir le message
    J'ai déjà brûlé un MOSFET et c'était le drain qui avait changé de couleur
    Pour faire changer la couleur il faut a sacré courant ! certainement un court-circuit .

    Les masse sont bien communes ? je ne vois pas le moins de la pile branché sur le moins de l'arduitruc ! faudrait commencé par la
    C'est en faisant des erreurs; que l'on apprend le mieux !!

  29. #24
    natu

    Re : Problème de commande de moteur avec MOSFET

    https://s3-eu-west-1.amazonaws.com/s...MOFSETBatt.png

    Si si dans mon schéma, le moins de la pile est bien relié au ground de l'arduino.
    C'est un moteur de voiture télécommandée, je ne comprends pas trop pourquoi ça bippe moi non plus

    Oui le drain est devenu violet.

  30. Publicité
  31. #25
    dje8269

    Re : Problème de commande de moteur avec MOSFET

    Franchement c'est bizarre .

    Une photo du montage ?

    Le pin de l'arduitruc peut bien être configurée en sortie ?
    La 10K n'est pas critique.

    Je ne vois pas ou cela bug ! essaye de remplacer le moteur par une led et une resistance pour voir si elle s'allume bien !
    C'est en faisant des erreurs; que l'on apprend le mieux !!

  32. #26
    paulfjujo

    Re : Problème de commande de moteur avec MOSFET

    essaye de remplacer le moteur par une led et une resistance pour voir si elle s'allume bien !
    et tant qu'à faire , plutot un ampoule de voiture 12V 15W entre la sortie DRain et ton +7,4V.
    à verifier aussi si ton alim tien le coup, en lui branchant cette ampoule 12V 15W dessus en direct.


    un moteur qui BIP ...
    on entendrait la frequence PWM mais en KHz, ça sifflerait plutot.

    au fait la valeur de delai dans le programme test , est de combien ?

    j'ai eu l'occasion de tester l'iRLZ14 avec une ampoule de voiture 12V 25W , pilotee en PWM par une sortie PIC,
    Alim par batterie 12V 7AH ..
    No problemo de commande de 0 à 100% en PWM .

  33. #27
    natu

    Re : Problème de commande de moteur avec MOSFET

    J'ai essayé de faire tourner ce moteur avec un shield ardumoto de ce type : https://www.sparkfun.com/products/14129
    Mais ce shield a brûlé.
    Pensez-vous que cela est dû à un problème de sur intensité ?
    Pensez-vous que ce shield fera l'affaire? https://www.seeedstudio.com/4A-Motor-Shield-p-1954.html

  34. #28
    HULK28

    Re : Problème de commande de moteur avec MOSFET

    Bonjour,

    Sans voir un schéma digne de ce nom vous n'aurez pas de réponse.
    De toute évidence le pilotage de votre MOS est inadapté.
    Un MOS directement raccordé à votre Arduino doit être obligatoirement compatible avec une commande Cmos, sinon il fonctionnera dans sa zone ohmique et donc chauffera excessivement...
    Tout est bien qui finit.

  35. #29
    HULK28

    Re : Problème de commande de moteur avec MOSFET

    L'IRF510 n'est pas adapté pour la raison que j'ai indiqué, donc rien de surprenant que celui-ci chauffe comme une baraque à frites....
    Tout est bien qui finit.

  36. #30
    paulfjujo

    Re : Problème de commande de moteur avec MOSFET

    Citation Envoyé par natu Voir le message
    J'ai essayé de faire tourner ce moteur avec un shield ardumoto de ce type : https://www.sparkfun.com/products/14129
    Mais ce shield a brûlé.
    Pensez-vous que cela est dû à un problème de sur intensité ?
    Ne pas confondre le Peak de courant supportable , par rapport au courant moyen maxi
    SANS RADIATEUR , normal qu'il fume , ce circuit .

    Meme le modele 4A , n'a pas de radiateur
    et on ne voit meme pas si il y a une surface de cuivre imprimé sous le composant
    faisant office de radiateur
    donc destiné à fumer aussi ..
    Prend un modele equipé d'un bon radiateur

Sur le même thème :

Page 1 sur 2 1 DernièreDernière

Discussions similaires

  1. [Analogique] transistor mosfet pour commande de moteur pas a pas
    Par Takoi dans le forum Électronique
    Réponses: 4
    Dernier message: 23/04/2018, 19h33
  2. [Energie] Problème avec un Mosfet > commande de moteur
    Par veau96101 dans le forum Électronique
    Réponses: 17
    Dernier message: 08/02/2017, 22h24
  3. Commande moteur avec MOSFET
    Par yop21 dans le forum Électronique
    Réponses: 36
    Dernier message: 11/06/2015, 13h21
  4. commande moteur par ULN et Mosfet
    Par obi1bi dans le forum Électronique
    Réponses: 17
    Dernier message: 08/01/2012, 21h17
  5. Réponses: 4
    Dernier message: 20/09/2009, 10h47