Répondre à la discussion
Page 1 sur 2 1 DernièreDernière
Affichage des résultats 1 à 30 sur 33

AOP monté en comparateur qui ne marche pas



  1. #1
    grandioso

    AOP monté en comparateur qui ne marche pas


    ------

    Bonjour,

    J'essaie de tester l'AOP en comparateur.
    Le but est de surveiller la tension au dessous de laquelle une batterie
    solaire ne doit pas descendre.J'ai réglé la tension à ne pas dépasser par le pont de résitance.
    Sur l'entrée + la tension de la batterie simulée ici par un potentiometre.
    Or j'ai beau baisser la tension au dessous des 9,56v à l'oscillo ou avec dune led branchée dans les 2 sens rien ne se passe la sortie est toujours à 0.AOPtest0.jpg

    -----

  2. Publicité
  3. #2
    penthode

    Re : AOP monté en comparateur qui ne marche pas

    On va attendre la validation du crobar

    Mais il faut savoir qu'un aop standard fait un comparateur exécrable
    Là où le mensonge prolifère, la tyrannie s'annonce ou se perpétue.

  4. #3
    gcortex

    Re : AOP monté en comparateur qui ne marche pas

    L'entrée + est toujours à 12V. Il manque aussi une résistance de pull up ou une led sur le +12V
    Si c'est une batterie au plomb ou NiCd, tu peux utiliser une zener comme référence.
    Dernière modification par gcortex ; 24/03/2020 à 16h10.

  5. #4
    penthode

    Re : AOP monté en comparateur qui ne marche pas

    Ton entrée positive est en butée haute

    Ça ne peut marcher

    D'autre part tes deux entrées variant en même temps
    Tu ne mesures rien du tout
    Dernière modification par penthode ; 24/03/2020 à 16h12.
    Là où le mensonge prolifère, la tyrannie s'annonce ou se perpétue.

  6. #5
    Antoane

    Re : AOP monté en comparateur qui ne marche pas

    Bonjour,

    Par ailleurs, le LM393 est un comparateur, et non un AOP. C'est donc un composant similaire à un AOP optimisé pour ce genre de montage en saturé/bloqué plutôt que linéaire.
    Sa sortie est en "collecteur ouvert", c'est à dire que le composant est capable de la connecter à la masse ou à rien ("haute impédance"), mais pas de la connecter au +12 V. Pour mesurer l'état de la sortie, il faut donc ajouter une résistance de pull-up, ou connecter une led (et sa résistance de limitation) entre la sortie du composant et le +12 V.
    Deux pattes c'est une diode, trois pattes c'est un transistor, quatre pattes c'est une vache.

  7. A voir en vidéo sur Futura
  8. #6
    freepicbasic

    Re : AOP monté en comparateur qui ne marche pas

    La 1 k doit être sur une tension de référence !
    Une zener (à la place de la 3K) par exemple 6V ou autre plus basse que la tension minimum mesurée.

    L autre entrée aura un pont de résistances qui donnera une tension inférieure à la référence zener quand on atteindra la tension désirée de basculement !

    9V tension désirée de basculement.
    6V tension de référence.

    pont de
    3k => 3V
    6K => 6V

    ou un potentiomètre pour régler...
    A+, pat

  9. Publicité
  10. #7
    grandioso

    Re : AOP monté en comparateur qui ne marche pas

    J'ai modifié le schema du compararateur.
    J'ai mis une zener de 9.1V qui definit la limite du basculement et j'abaisse manuelement la tension qui vient du generateur pour visualiser la sortie.
    Celle-ci suit la tension et descend sous les 9.1V sans basculer à 0 comme attendu.
    Voici le schema.
    AOPtest1.jpg

  11. #8
    gcortex

    Re : AOP monté en comparateur qui ne marche pas

    Un géné se branche à la masse.

  12. #9
    HULK28

    Re : AOP monté en comparateur qui ne marche pas

    A quoi as-tu relié les pins d'alimentation du comparateur? Ca n'apparaît pas sur ton schéma.
    As-tu pensé à mettre une capa de découplage sur ses pattes d'alim? (un 100nF)
    As-tu bien relié le + et le - sur le comparateur? Vu que tu n'indiques pas les numéros des pattes sur ton schéma...

    As-tu bien mesuré que tu as 9.1V environ sur la zéner?
    L’ignorance engendre plus fréquemment la confiance en soi que ne le fait la connaissance.

  13. #10
    HULK28

    Re : AOP monté en comparateur qui ne marche pas

    Comme il y a 2 comparateurs dans ce boitier, il faut que tu relies aussi les pins + et - de l'autre, qui est inutilisé, et tu les relies à la masse.
    Ca évitera que celui-ci oscille.
    L’ignorance engendre plus fréquemment la confiance en soi que ne le fait la connaissance.

  14. #11
    grandioso

    Re : AOP monté en comparateur qui ne marche pas

    "Ton entrée positive est en butée haute" ça veut dire quoi ?


    Les pins d'alimentation sont bien reliées. J'ai 8.96v sur la zener.
    Le générateur c'est une alim de labo.
    Je mets 100nF entre le plus et le moins du composant ? C'est plutot pour des problèmes d'oscillations non ?

  15. #12
    gcortex

    Re : AOP monté en comparateur qui ne marche pas

    Sur le 1er schéma, l'entrée + est à 12V.
    Mets le géné variable à la masse et c'est bon.

  16. Publicité
  17. #13
    HULK28

    Re : AOP monté en comparateur qui ne marche pas

    Mets un condensateur de découplage.
    Tu as combien de distance entre ton alim et ton montage?
    Dernière modification par HULK28 ; 27/03/2020 à 13h02.
    L’ignorance engendre plus fréquemment la confiance en soi que ne le fait la connaissance.

  18. #14
    HULK28

    Re : AOP monté en comparateur qui ne marche pas

    Citation Envoyé par gcortex Voir le message
    Sur le 1er schéma, l'entrée + est à 12V.
    Mets le géné variable à la masse et c'est bon.
    Mais de quoi parles-tu?
    L’ignorance engendre plus fréquemment la confiance en soi que ne le fait la connaissance.

  19. #15
    gcortex

    Re : AOP monté en comparateur qui ne marche pas

    Je réponds pour la butée d'une part,
    et le géné branché sur le +12 d'autre part.

    Comme d'ab aucun rapport entre les deux !
    (2 questions et 2 schémas différents)

  20. #16
    grandioso

    Re : AOP monté en comparateur qui ne marche pas

    MERCI
    Le générateur simule la batterie (qui va baisser sa tension jusqu'à environ 9V )et dés lors stopper la décharge pour pouvoir se recharger.
    Bon, le problème est résolu .
    J'ai interverti les entrées + et - et dés que la tension atteint 9v la sortie passe à 0.
    Maintenant je vais interfacer pour la commande d'un relais

  21. #17
    gcortex

    Re : AOP monté en comparateur qui ne marche pas

    Une dernière fois, ta batterie doit être branchée à la masse.
    Mets une résistance de forte valeur entre la sortie et l'entrée +, pour éviter les battements.
    Dernière modification par gcortex ; 27/03/2020 à 17h05.

  22. #18
    grandioso

    Comment interfacer un comparateur à un circuit de puissance

    Bonjour
    J'ai une petite pompe (1A) interfacée à une batterie solaire 12V.
    Quand elle se décharge le comparateur doit couper l'alimentation si le niveau de la batterie passe sous les 9v. Le comparateur marche bien à vide avec la led mais avec le moteur en marche la batterie continue à se décharger au delà des 9v.
    D'où ma question.
    J'ai essayé de séparer le comparateur du circuit à
    transistor par un optocoupleur mais ça ne marche pas.
    Ci-joint le schema :
    Images attachées Images attachées

  23. Publicité
  24. #19
    DAT44

    Re : Comment interfacer un comparateur à un circuit de puissance

    Bonjour,
    ici l'inter fait un CC

    Sinon tu peux prendre une zener un peu faible genre 3,3V a 6,8V (tu ajuste R1 pour obtenir 1 a 2 mA) et tu place un pont diviseur de la tension d'alim sur la patte 3 (<100µA) ainsi le LM393 dispose de suffisamment de distance de tension avec sa tension d'alim ...
    NB: il faut également placé une résistance d’hystérésis afin d'obtenir une commutation franche ...

    Autre proposition de montage :
    Images attachées Images attachées

  25. #20
    grandioso

    Re : Comment interfacer un comparateur à un circuit de puissance

    Merci pour ta réponse DAT44

    Effectivement mon inter fait un CC. J'ai modifié le schémaci-joint.
    Sur ton schéma je ne vois pas où se situe la sortie du comparateur et
    où mettre la résistance d’hystérésis ,je ne comprends pas comment avec une zener comme par exemple 3.6v
    le basculement se fera à 9v comme souhaité, mais mes connaissances en électronique sont assez sommaires.

    ControlBatri.jpg

  26. #21
    DAT44

    Re : Comment interfacer un comparateur à un circuit de puissance

    Bonjour,
    Citation Envoyé par grandioso Voir le message
    Sur ton schéma je ne vois pas où se situe la sortie du comparateur
    c'est la patte 1

    Citation Envoyé par grandioso Voir le message
    et où mettre la résistance d’hystérésis
    a la différence de la contre réaction qui agit sur l'entré inverseuse, l'hystérésis se fait sur l'entré non inverseuse, il faudra donc que tu place une résistance de forte valeur entre la patte 1 et la patte 3

    Citation Envoyé par grandioso Voir le message
    je ne comprends pas comment avec une zener comme par exemple 3.6v
    le basculement se fera à 9v comme souhaité, mais mes connaissances en électronique sont assez sommaires.
    Si tu utilisai un comparateur parfait ton montage serait presque fonctionnel , mais il manquerai un petit offset de tension négatif sur l'entré inverseuse(patte 2) de façon bien polarisé les deux entrées avec une petite différence de tension tant que la batterie n'a pas atteint sa tension minimum.
    Le problème est que le LM393 n'est pas parfait, si tu regarde "Common-mode input voltage range" dans sa notice, tu verras que les tensions appliqué a ces entrées doivent toujours être au moins 2 volts inférieur a sa tension d'alimentation, ce qui n'est pas le cas dans ton montage.
    C'est pour cela qu'il faut utiliser une diode Zener de tension assez faible et placé un pont diviseur de tension sur l'entré non-inverseuse (patte 3)
    Dernière modification par DAT44 ; 31/03/2020 à 13h12.

  27. #22
    DAT44

    Re : AOP monté en comparateur qui ne marche pas

    Bonjour
    il serai plus pratique d'utilisé un AOP genre TL081 pour cette application ...

  28. #23
    gcortex

    Re : AOP monté en comparateur qui ne marche pas

    les zeners de 5V et moins ont une mauvaise courbe I=f(U).
    Au dessus, ce sont des diodes à effet d'avalanche.

  29. #24
    grandioso

    Re : AOP monté en comparateur qui ne marche pas

    DAT44

    citation:
    "Sur ton schéma je ne vois pas où se situe la sortie du comparateur"

    Ma question était : où est-ce que la sortie 1 du comparateur s'intégre à ton schéma de sortie à transistor ?

    Merci encore pour tes explications.
    Je vais faire le montage à blanc avec un tl082 , une zener de 4,7v (j'ai pas plus petit) et une resistance de 100k(?) entre le 1 et le 3 du comparateur.
    Quant au pont diviseur :quelle tension ?

  30. Publicité
  31. #25
    DAT44

    Re : AOP monté en comparateur qui ne marche pas

    Bonjour,
    proposition de montage avec un TL081:
    Images attachées Images attachées
    Dernière modification par DAT44 ; 31/03/2020 à 15h18.

  32. #26
    DAT44

    Re : AOP monté en comparateur qui ne marche pas

    Bonjour,
    houps !
    j'ai permuté les deux entrées, donc c'est plutôt ça :
    TL081.gif

  33. #27
    gcortex

    Re : AOP monté en comparateur qui ne marche pas

    De mémoire le TL081 a une tension de déchet de 3V de chaque côté !
    Je propose un LM358 (qui peut aussi stopper la charge à 13.7V).
    Dernière modification par gcortex ; 31/03/2020 à 15h33.

  34. #28
    DAT44

    Re : AOP monté en comparateur qui ne marche pas

    Bonjour,
    non pas coté +

  35. #29
    jiherve

    Re : AOP monté en comparateur qui ne marche pas

    Bonsoir
    avec un comparateur monté convenablement cela devrait fonctionner c'est tout de même trivial.
    JR
    l'électronique c'est pas du vaudou!

  36. #30
    HULK28

    Re : AOP monté en comparateur qui ne marche pas

    Si il y a une pompe en sortie, mettre une diode de roue libre
    L’ignorance engendre plus fréquemment la confiance en soi que ne le fait la connaissance.

Page 1 sur 2 1 DernièreDernière

Discussions similaires

  1. Comparateur à fenêtre: Achat du comparateur
    Par fedor dans le forum Électronique
    Réponses: 2
    Dernier message: 24/02/2012, 12h26
  2. La petite bête qui monte, qui monte....
    Par scopy dans le forum Matériel astronomique et photos d'amateurs
    Réponses: 15
    Dernier message: 22/08/2009, 21h41
  3. Ampli Monté en Comparateur
    Par Kelme dans le forum Électronique
    Réponses: 1
    Dernier message: 12/11/2006, 19h04
  4. tp mpi "AO monté en comparateur"
    Par Nessbeal dans le forum Physique
    Réponses: 0
    Dernier message: 04/04/2006, 20h12
  5. ampli monté en Comparateur
    Par Tix dans le forum Électronique
    Réponses: 6
    Dernier message: 15/10/2004, 10h06
Découvrez nos comparatifs produits sur l'informatique et les technologies.