Répondre à la discussion
Affichage des résultats 1 à 14 sur 14

Problème de surchauffe transistor



  1. #1
    Cloro01

    Problème de surchauffe transistor


    ------

    Bonjour à tout le monde !!

    Je viens solliciter votre aide car je n'arrive malheureusement pas à trouver la solution à mon problème que ce soit dans les post déjà existant ou dans mes anciens cours d'électronique...

    L'objectif est de commander une pompe hydraulique en PWM. Suite à un claquage du transistor, j'ai décidé d'isoler le problème en supprimant la régulation PWM et en réalisant le montage suivant :

    #### Lien image externe supprimé ####

    En gardant un doigt sur le transistor afin de vérifier sa température pour pouvoir tout éteindre et éviter qu'il claque aussi, j'ai constaté un fonctionnement étrange en modifiant la résistance variable (R1/R2) :
    - Lorsque la pompe marche à régime nominal, la température du transistor n'est pas spécialement élevé,
    - Plus la pompe tourne doucement plus le transistor chauffe rapidement de manière très importante.

    J'ai bien vérifier les datasheet et il semblerait que le transistor ait une dissispation thermique suffisante quelque soit la situation mais apparement non...

    Voici les carastéristiques des composants :
    Alimentation : alimentation de PC
    Résistance variable de 2,18K
    Transistor BD137 (les datasheet indiquent : Puissance de dissipation du collecteur 12.5W, Ib=0.5A, Ic=1.5A)
    Pompe hydraulique qui en régime nominal sous 5V consomme 1.3A

    Détail des courants parcourant le transistor dans deux cas différents:

    1) Pour R2=0.17K et R1=2K -> ib=21.5mA / ie=1.22A / ic=1.2A
    Dans cette situation le transistor ne chauffe pas spécialement

    2) Pour R2=0.58K et R1=1.6K -> ib=6.1mA / ie=0.957A / ic=0.9A
    Dans cette situation le transistor chauffe énormément, je suis contraint d'éteindre l'ensemble afin d'éviter qu'il ne claque

    Auriez-vous une idée de l'origine du problème? Merci pour votre aide.

    -----
    Images attachées Images attachées
    Dernière modification par Tropique ; 04/06/2011 à 20h11. Motif: Conversion lien/PJ

  2. Publicité
  3. #2
    Tropique

    Re : Problème de surchauffe transistor

    Bonjour,

    Merci à l'avenir de respecter les http://forums.futura-sciences.com/el...-sabonner.html, et de placer les images en pièces jointes.

    Pour une première fois, j'ai effectué l'opération moi-même.
    Pas de complexes: je suis comme toi. Juste mieux.

  4. #3
    Cloro01

    Re : Problème de surchauffe transistor

    Désolé je ne referai plus cette erreur. Merci bien d'avoir corrigé le message

  5. #4
    simon.

    Re : Problème de surchauffe transistor

    Tu as un radiateur sur ton transistor ?
    Parce que sans c'est normal qu'il chauffe à mort...

  6. #5
    jiherve

    Re : Problème de surchauffe transistor

    Bonsoir,
    il serait bon de se souvenir que P= UI et que donc la tension aux bornes du transistor compte aussi.
    JR
    l'électronique c'est pas du vaudou!

  7. A voir en vidéo sur Futura
  8. #6
    Jack

    Re : Problème de surchauffe transistor

    Détail des courants parcourant le transistor dans deux cas différents:

    1) Pour R2=0.17K et R1=2K -> ib=21.5mA / ie=1.22A / ic=1.2A
    Dans cette situation le transistor ne chauffe pas spécialement

    2) Pour R2=0.58K et R1=1.6K -> ib=6.1mA / ie=0.957A / ic=0.9A
    Dans cette situation le transistor chauffe énormément, je suis contraint d'éteindre l'ensemble afin d'éviter qu'il ne claque

    Auriez-vous une idée de l'origine du problème? Merci pour votre aide.
    C'est normal, le BD137 possède un gain en courant de quelques dizaines. Dans ces conditions le transistor n'est pas saturé et fonctionne en régime linéaire, donc il chauffe.

    L'intérêt de la pwm, c'est de toujours fonctionner avec un transistor saturé. Modifie le schéma en commandant le transistor avec une pwm. Un montage avec l'indémodable 555 est suffisant.

    A+

  9. Publicité
  10. #7
    Cloro01

    Re : Problème de surchauffe transistor

    Merci pour vos avis.

    Pour répondre aux différentes questions, je n'ai pas de radiateur mais le commerçant m'a affirmé qu'il n'y en avais pas besoin sur le BD137 sur l'ensemble de sa plage de fonctionnement. Dans le doute, j'en ai fabriqué un maison ce matin avec une plaque d'aluminium découpée et tordue.

    Merci pour l'info sur la puissance, j'avais oublié cette composante. Pour les voltages, j'ai refait une série d'essai et voici les résultats :
    1) Pour R2=0.17K et R1=2K -> ib=11.7mA / ic=1.25A / ie=1.2A
    Vcb=0.5V / Vce=1.33V / Vbe=0.82V
    ==> Soit une puissance dissipée dans le transistor de 1.67W

    2) Pour R2=0.58K et R1=1.6K -> ib=6.1mA / ic=0.950A / ie=0.910A
    Vcb=1.42V / Vce=2.15V / Vbe=0.79V
    ==> Soit une puissance dissipée dans le transistor de 2.05W

    Ainsi on observe bien que plus la pompe ralentie plus la température du transistor est élevée. Toutefois, d'après les datasheet le BD137 est prévu pour une dissipation au niveau du collector de 12.5W et si la non utilité d'un radiateur tel que confirmé par le commerçant, on se retrouve quand même loin des 2.05W.

    Enfin, pour répondre au dernier avis, le montage était initalement réalisé en PWM non pas à l'aide d'un 555 mais avec une carte VELLEMAN K8055 qui permet la régulation de la commande PWM par le biais d'un PC. Cette carte dispose de collecteurs ouverts et nécessite par conséquent l'emploi d'une résistance de tirage fixée à 30ohms dans mon cas et branchée sur les 5V de l'alim.
    Je viens de refaire le montage et je constate la même anomalie avec l'utilisation du PWM :
    1) Lorsque je fait fonctionner la pompe à son régime nominal, le transistor monte doucement en température mais se stabilise à une température acceptable.
    2) Lorsque je diminue la vitesse de la pompe, le transistor monte beaucoup plus vite en température et devient brulant (j'éteint l'ensemble pour éviter qu'il ne claque)

    Ainsi malgré l'utilisation du PWM qui devrait en effet faire fonctionner le transistor en régime saturé et donc éviter qu'il ne chauffe trop, ce dernier devient brulant lorsque je diminue la vitesse de la pompe.

    Avez-vous une idée de ce qui pourrait expliquer cela et comment y remedier.
    Merci bien.

  11. #8
    DAUDET78

    Re : Problème de surchauffe transistor

    Citation Envoyé par Cloro01 Voir le message
    Cette carte dispose de collecteurs ouverts et nécessite par conséquent l'emploi d'une résistance de tirage fixée à 30ohms dans mon cas et branchée sur les 5V de l'alim.
    C'est beaucoup trop peu pour la carte K8055 !

    Tu peux donner ton schéma avec la sortie du K8055 et ton moteur ?
    J'aime pas le Grec

  12. #9
    simon.

    Re : Problème de surchauffe transistor

    Citation Envoyé par Cloro01 Voir le message
    Toutefois, d'après les datasheet le BD137 est prévu pour une dissipation au niveau du collector de 12.5W et si la non utilité d'un radiateur tel que confirmé par le commerçant, on se retrouve quand même loin des 2.05W.
    Oui mais si ma compréhension est bonne, les 12.5W annoncés c'est si le collecteur est maintenu à 25°C, c'est à dire avec un radiateur de dimensions infinies...

    Sans radiateur le datasheet indique 1.25W max.

  13. #10
    Jack

    Re : Problème de surchauffe transistor

    Pour répondre aux différentes questions, je n'ai pas de radiateur mais le commerçant m'a affirmé qu'il n'y en avais pas besoin sur le BD137 sur l'ensemble de sa plage de fonctionnement
    Il faut que ton commerçant se recycle.

    Oui mais si ma compréhension est bonne, les 12.5W annoncés c'est si le collecteur est maintenu à 25°C, c'est à dire avec un radiateur de dimensions infinies...
    Exactement.

    sans radiateur, le boitier serait porté à plus de 1000°C avec 12W.

    A+

  14. #11
    Cloro01

    Re : Problème de surchauffe transistor

    J'ai revérifié les limites de fonctionnement de la K8055 et effectivement une resistance de tirage 30ohms sous 5V est plus que limite!!!
    J'avais choisis initalement du 30ohms pour avoir une intensité élevé sur la base du BD137 afin de faire tourner la pompe rapidemment.
    Mais suite à tes commentaires et afin de ne pas cramer la K8055, j'ai revu le montage en insérant un transistor 2N2222 afin de faire la commande intermédiaire entre le PWM et le transistor "de puissance" du moteur (j'ai joint le schéma du montage en pièce jointe).

    Merci pour l'explication sur la puissance de dissipation théorique de 12W en présence d'un hypothétique radiateur infini. La valeur de 1.25W à température ambiante expliquerait beaucoup de choses. J'ai rajoutté deux autres radiateurs maison sur le transistor mais les ailettes restent brulantes au toucher, je pense que je vais aller en acheter un plus adapté à cette utilisation.

    En tout cas merci à tout le monde pour votre aide qui m'a permis de résoudre mon problème
    Images attachées Images attachées

  15. #12
    DAUDET78

    Re : Problème de surchauffe transistor

    Ton moteur ne doit pas consommer plus de 200mA .....

    Utiliser ce montage (I) http://forums.futura-sciences.com/at...nductive3oejpg
    J'aime pas le Grec

  16. Publicité
  17. #13
    Cloro01

    Re : Problème de surchauffe transistor

    A la vue du transistor employé (BD137), je devrais en effet limiter la consommation du moteur à 200mA. Toutefois, ce dernier ne se met à entrer en rotation qu'à partir de 600mA et se stabilise à 1.2A en régime nominal sous 5V.

    Avec l'ajout des radiateurs 'maison' sur le transistor, cela me permet de dépasser les 1.25W précisé dans le DATASHEET jusqu'a une valeur supérieure mais inconnue. Ce soir, je vais acheter un transistor BD911 dont la puissance de dissipation de 90W et l'intensité max dans le collecteur de 15A devraient amplement suffire (en prévision d'un fonctionnement ultérieur de la pompe sous 12V).

    Merci pour l'exemple du montage, j'avais oublié de mettre la diode de roue libre !! Par contre, je ne peux me contenter d'un seul transistor en raison de l'intensité max admissible par la K8055 et celle nécessaire dans la base du transistor de 'puissance'. De plus, je ne vois pas comment décliner ton schéma dans le cas d'un déclenchement via des collecteurs ouverts.

  18. #14
    DAUDET78

    Re : Problème de surchauffe transistor

    Citation Envoyé par Cloro01 Voir le message
    De plus, je ne vois pas comment décliner ton schéma dans le cas d'un déclenchement via des collecteurs ouverts.
    Ben ... tu rajoutes une résistance de PullUP !
    J'aime pas le Grec

Sur le même thème :

Discussions similaires

  1. problème de surchauffe!!
    Par Morgan B dans le forum Électronique
    Réponses: 26
    Dernier message: 22/07/2010, 22h41
  2. [Brun] Sony chassis AE-4 surchauffe transistor
    Par ladede dans le forum Dépannage
    Réponses: 26
    Dernier message: 12/06/2009, 07h54
  3. [RGB] surchauffe du transistor...
    Par freinsch dans le forum Électronique
    Réponses: 19
    Dernier message: 31/12/2008, 14h26
  4. probleme de surchauffe avec un 4011
    Par pinpinou dans le forum Électronique
    Réponses: 6
    Dernier message: 14/08/2008, 20h26
  5. Problème de surchauffe??
    Par schwanzlily dans le forum Matériel - Hardware
    Réponses: 1
    Dernier message: 30/10/2006, 18h31
Découvrez nos comparatifs produits sur l'informatique et les technologies.